• Cnchi 0.8.21 stops after confirming install partition


    Installing with Cnchi 0.8.21 on VMWare and I get a UnicodeDecodeError after confirming the install partition.

    [2015-04-14 09:10:37] [automatic] INFO: Antergos will install the bootloader ‘grub2’ in device '/dev/sda’
    SG_IO: bad/missing sense data, sb[]: 70 00 05 00 00 00 00 0a 00 00 00 00 20 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    Traceback (most recent call last):
    File “/usr/share/cnchi/cnchi/main_window.py”, line 381, in on_forward_button_clicked
    stored = self.current_page.store_values()
    File “/usr/share/cnchi/cnchi/installation/automatic.py”, line 182, in store_values
    self.start_installation()
    File “/usr/share/cnchi/cnchi/installation/automatic.py”, line 282, in start_installation
    ssd = {self.auto_device: fs.is_ssd(self.auto_device)}
    File “/usr/share/cnchi/cnchi/misc/misc.py”, line 175, in helper
    return func(*args, **kwargs)
    File “/usr/share/cnchi/cnchi/parted3/fs_module.py”, line 185, in is_ssd
    result = subprocess.check_output(cmd).decode()
    UnicodeDecodeError: ‘utf-8’ codec can’t decode byte 0xff in position 70: invalid start byte

    Full debug info here - http://pastebin.com/ji7V1caq.

    Any ideas?

  • @AllThatIsMatt said:

    SG_IO: bad/missing sense data, sb

    From what I was able to dig up on Google it seems that there’s something wrong with your USB drive/memory card/whatever it is ;-) Try using a different system to completely reformat the drive before attempting to install again.

  • Fixed it! After referencing this thread, it came to me. You were right about something being wrong with my disk which was a VMware SCSI disk. I changed it to SATA and the install completed!

    http://forum.antergos.com/topic/1929/partitioning-issue-on-vmware-esxi-5-5/4

    If anyone out there is using VMware, change your virtual disk to SATA or IDE, not SCSI which is the default.

  • I’m the one that started that other thread. I actually found that it has something to do with the LSI Logic Parallel vSCSI controller. Exactly what, I don’t know yet. It could be something with the implementation of the driver or the command that cnchi is using to identify the disk. I haven’t dug into cnchi to see what command is actually being called to start the partitioning.

    If you change it to another type of controller when you create the VM, it should work. So far I’ve only tried the VMWare Paravirtualized controller and that works if you want to use the SCSI controller instead of the IDE. I don’t know if there are any IO advantages between the SCSI and the IDE controller but that’s something to consider…

cnchi 0.8.212 utf-81 install77 Posts 4Views 1467
Log in to reply