• After a fresh install, lightdm fails to start


    I just made a fresh new install with cinnamon desktop environment, and when it boot for the first time the system refuses to start…
    It’s a lidhtdm problem. The message on screen is:
    " Failed to start light Display manager "

    Can you give me some help for this ? Thanks!

  • Press ‘Ctrl+Alt+F1’ to enter tty1 during boot process, enter your username and password to login, then type ‘startx’. That should lead you to the desktop. After that, refer to this post:http://forum.antergos.com/topic/1885/how-to-include-system-logs-when-asking-for-help to post the log of lightdm here.

  • I had the same problem but I managed to get it working.
    Last night I tried to run (after installing xorg-server-xephyr)
    lightdm --test-mode --debug
    and it failed but it prompted me an issue with the greeter, it resulted that there was no greeter installed. I installed lightdm-gtk-greeter and it worked.

  • @davos I’ve got same issue. Tip: http://forum.antergos.com/topic/1905/it-s-official-an-official-release-that-is/18
    Also - check if your home directory exists ( /home/yourusername ). Mine did not : (

  • @Alphanumerix Do you still have your cnchi log file in /var/log ? I want to have a look at it.

    Thanks!

  • @AlexMex90

    Thanks, this worked out. I’ve check if the home directory was created, and also the cnchi log file, and everything was OK.

    At login, i press Ctrl+Alt+F2 keys to enter in the alternate VT, and installed the lightdm-gtk-greeter file. It seems to be lost in the installation fase.

    Thanks for everyone, for your help!!!

  • @karasu said:

    @Alphanumerix Do you still have your cnchi log file in /var/log ? I want to have a look at it.

    Unfortunately, I do not have them : (

  • In my case same problem in two fresh installations

    Ctrl+Alt+F2 login in tty and re-install this packages: lightdm lightdm-gtk-greeter lightdm-webkit-theme-antergos lightdm-webkit2-greeter

    Reboot and solved 😉

    Antergos (Gnome)

  • @Yoyo said:

    In my case same problem in two fresh installations

    Ctrl+Alt+F2 login in tty and re-install this packages: lightdm lightdm-gtk-greeter lightdm-webkit-theme-antergos lightdm-webkit2-greeter

    Reboot and solved 😉

    Ok, I try this next time…

lightdm125 Posts 10Views 5389
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.