• Base install: Bootloader installation problem

    Received this error after attempting base install:

    IMPORTANT: There may have been a problem with the bootloader installation which could prevent your system from booting properly.

    Tried multiple times, alternating between grub2 and gummiboot with same error.

    Edit: Getting an error when trying to upload .tar of logs: 413 Entity too large.

    [logs.tar](uploading 100%)

  • I am getting the same issue. tried it twice now.

  • Same here. Installing Grub to a GPT disk gives an error in the logs (but the error code and/or message is blank…). Gummiboot does install, but following the UEFI entry on reboot gives an error along the lines of “cannot find vmlinuz-linux”. I partition my disk manually, pointing the bootloader installer to the drive containing the EFI partition, mounted at /boot.

  • @PopTart did that work? Pointing the bootloader installer at EFI?

  • I’m afraid not. I’m actually unable to get a working system installed with cnchi 0.8.16.
    I thought it may be unhappy that I’d formatted my drive at GPT (I read in another post that GPT support might be buggy), so I reformatted it as MBR and tried again. As before, grub fails to install (but does not say why). I haven’t tried gummiboot on MBR. In a last ditch attempt to get Antergos installed, I reverted to how I’ve always done it: let the installer erase the drive and configure partitions, along with LUKS and LVM. Cnchi instantly threw out LVM errors…

  • It looks like we are now stuck on the bootloader issue. We’re getting close guys. I noticed there is only the choice to put the bootloader on sda and not sda1. Not sure if it makes a difference. I am using virtualbox so not sure if that matters.

  • I guys,

    am I doing something wrong?

    Screenshot from 2015-04-14 10-49-54.png

  • @hlavij Your EFI partition should be mounted at /boot Be sure that you DO NOT select the option to format that mount point.

  • @lots.0.logs there is no way how to not format /boot partition when I am creating new partition table …

    and I have end up with:

    efi stub: error: failed to read file

    so I can not boot

  • @hlavij Well yes, that’s true. Are you sure you want to create a new table? That would overwrite your existing EFI directory. The latest version of cnchi is now fully functional once again. So provided their are no bad mirrors near your location, you should be able to complete your install now. Let me know how it goes. Cheers!

  • I die a fresh install of antergos.
    I habe an acer 5755g with unlocked bios. I can Boot in uefi but i still usw mbt and old BIOS Boot.

    After installing i geht an error. Could not install grub bootloader. Something swap.

    After reboot nothing there. No grub working. I used the manjaro wiki https://wiki.manjaro.org/index.php/Restore_the_GRUB_Bootloader
    And followed the mounting steps etc. After installing grub a quick grub-mkconfig … And it boots again.
    Only Problem is now that it does not Start. After login the display manager just quits again…
    So i am back in Windows. It still works. And typing my findings here in my phone.

  • @dehein If you could, please grab your system logs following the instructions on the HOW TO: Obtain System Logs sticky topic. Once you have the logs, create a new topic with the information and we’ll do what we can to help. Cheers!

  • @lots.0.logs

    I have allready try to install Antergos with cinhi 0.8.21 and it did not work.

    When I am usi UEFI with automatic partitioning it created only 253MB big partition for system …
    Because of that I ma trying to do manual partitioning, but after that I have problems with loader :D

    PS: I want to do clean install.

  • @hlavij said:


    Your EFI partition should be a minimum of 250MB. Your kernel will be stored there as well as grub’s files. Plus you want to have extra space for other OS’s you may install which will add bootloader files.

  • @lots.0.logs

    Screenshot from 2015-04-14 17-32-17.png
    Screenshot from 2015-04-14 17-32-40.png
    Screenshot from 2015-04-14 17-33-32.png

    Partitions will be aligned on 2048-sector boundaries
    Total free space is 975362530 sectors (465.1 GiB)

    Number Start (sector) End (sector) Size Code Name
    1 2048 411647 200.0 MiB EF00 UEFI_SYSTEM
    2 411648 935935 256.0 MiB 8300 ANTERGOS_BOOT
    3 935936 939815 1.9 MiB 8200 ANTERGOS_SWAP
    4 940032 1412834 230.9 MiB 8300 ANTERGOS_ROOT
    [2015-04-14 17:32:54] [auto_partition] DEBUG: EFI: /dev/sda1
    [2015-04-14 17:32:54] [auto_partition] DEBUG: Boot: /dev/sda2
    [2015-04-14 17:32:54] [auto_partition] DEBUG: Swap: /dev/sda3
    [2015-04-14 17:32:54] [auto_partition] DEBUG: Root: /dev/sda3
    [2015-04-14 17:32:54] [auto_partition] DEBUG: Device /dev/sda1 will have a vfat filesystem
    [2015-04-14 17:32:54] [auto_partition] DEBUG: Device /dev/sda2 will have a ext2 filesystem
    [2015-04-14 17:32:54] [auto_partition] DEBUG: Device /dev/sda3 will have a ext4 filesystem
    [2015-04-14 17:32:54] [auto_partition] DEBUG: Will format device /dev/sda3 as ext4
    [2015-04-14 17:32:54] [auto_partition] DEBUG: Device details: /dev/sda3 UUID=c92481ba-7338-4f96-995a-e20cbc42e34e LABEL=AntergosRoot
    [2015-04-14 17:32:54] [auto_partition] DEBUG: Will format device /dev/sda3 as ext4
    [2015-04-14 17:32:54] [auto_partition] ERROR: Can’t create filesystem ext4
    [2015-04-14 17:32:54] [auto_partition] ERROR: Command [‘mkfs.ext4’, ‘-q’, ‘-F’, ‘-L’, ‘AntergosSwap’, ‘/dev/sda3’] failed
    [2015-04-14 17:32:54] [auto_partition] ERROR: Output: None
    [2015-04-14 17:32:54] [process] ERROR: “Can’t create filesystem ext4”

    Now you undertand? The system is boot with UEFI method.

  • @hlavij Was this on your first attempt after booting the live media? Anytime you have a failed install attempt you must reboot your system before trying again. It appears that you might not have rebooted which would explain the error.

  • @lots.0.logs if I reboot. Partitions are created but instalation stuck because there is not enough space on root parition.

    Do you see? :
    4 940032 1412834 230.9 MiB 8300 ANTERGOS_ROOT

    And of course, when I made partitions manually, bootloader is broken. Grub and gummibot too.

  • Don’t worry,
    Manjaro 0.8.13 Thus and 0.9.0 Calamares are broken too.
    Same bootloader errors (Calamares manage to format one of my btrfs partition, without my permission).

    So, has anyone managed to install, without errors, Antergos with Cnchi 0.8.x?

  • I’m getting the same issues (If I don’t use LUKs on my drives)

  • @roberto said:

    Don’t worry,
    Manjaro 0.8.13 Thus and 0.9.0 Calamares are broken too.
    Same bootloader errors (Calamares manage to format one of my btrfs partition, without my permission).

    So, has anyone managed to install, without errors, Antergos with Cnchi 0.8.x?

    Well, that does not surprise me considering that Thus is our Cnchi code that Manjaro continues to copy, line for line, even though it has been over a year since they forked it as Thus. …But I digress…

    We have some changes to GPT partitioning in our development branch that needs testing before we push it to Cnchi Stable. If anyone is interested in testing it and reporting their results please contact me. Thanks!

grub226 Posts 45Views 36870
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.