• Wi-Fi not installing


    Got everything up and running - Trying to get the wi-fi installed - I got it working on Manjaro
    would like to make it work with Antergos… It is a belkin dual band (RTL8812au driver)
    tried to build the driver
    yaourt -S rtl8812au-dkms

    got to the build - that was my problem

    Building module:
    cleaning build area…
    make KERNELRELEASE=3.19.3-3-ARCH -C /usr/lib/modules/3.19.3-3-ARCH/build M=/var/lib/dkms/rtl8812au/4.2.2.7502.20130517/build…(bad exit status: 2)
    Error! Bad return status for module build on kernel: 3.19.3-3-ARCH (i686)
    Consult /var/lib/dkms/rtl8812au/4.2.2.7502.20130517/build/make.log for more information.
    error: command failed to execute correctly

    make.log

    ANY HELP WOULD BE GREATLY APPRECIATED

  • I did the samething using
    yaourt -S rtl8812au_asus-dkms

    This one seemed to compile fine - but is not working

  • Hi,

    Do you have the kernel headers installed?

    sudo pacman -S linux-headers
    
  • No - but I did a fresh install - loaded the rtl8812au-dkms driver from AUR - When installing it loaded all the 3.19 headers.
    It compiled fine, made fine and added to the kernel fine _ But when it completed it asked me (to quickly to read) to assure something like dkms daemon needed to start…
    The wi-fi never come on and the same driver wanting to keep getting updated

  • You need to enable dkms and then reboot:

    systemctl enable dkms
    
  • Did this… three times - it kept wanting to updated the same dkms driver and kept giving the same start daemon message
    it was like some kind of loop

  • So that it is clear for me - Let me review the steps…

    1.) Make sure system is updated
    ****Re-boot
    2.) load linux headers
    3.) install driver from AUR
    4.) systemctl enable dkms
    **** reboot
    This should get the wi-fi started - correct ?
    Am I missing any steps or out of order
    Thank You

  • @Tony-Armer said:

    rtl8812au

    Try installing this package instead: rtl8812au-git-dkms

    If that doesnt work you may have to use the LTS kernel until its fixed in the mainline kernel.

    sudo pacman -S linux-lts
    sudo grub-mkconfig -o /boot/grub/grub.cfg
    
  • Thank You…

    That is the one I installed from AUR - and it was the one that kept wanting to update and re-install
    If I go with the second solution - I just type what you have - Than install the rtl8812au-git-dkms driver
    correct ?

  • I know this card works in a 3.16 kernel - I had it running in Manjaro (xfce) - But have never tried it any higher kernel

  • I think your best bet is to use the LTS kernel. You won’t be missing out on anything as Arch’s LTS kernel doesn’t lag as far behind as debian and ubuntu. Simply run the two commands I provided and then reboot. You will need to choose the LTS kernel on the grub menu. Let me know how it goes!

Posts 11Views 1818
Log in to reply