• Can't create download package list.


    When I’m trying to install antergos everything works until I hit next after filling out the computer name and username/password and just get “Can’t create download package list. Check log output for details”.

    [2015-04-13 17:32:03] [cnchi] INFO: Using GTK v3.16.1
    [2015-04-13 17:32:03] [cnchi] INFO: Using pyalpm v0.7 as interface to libalpm v9.0.1
    [2015-04-13 17:32:03] [updater] WARNING: Could not find 'update.info' file. Cnchi will not be able to update itself.
    [2015-04-13 17:32:03] [main_window] INFO: Cnchi installer version 0.7.303
    [2015-04-13 17:32:03] [gtkbasebox] DEBUG: Loading 'welcome' screen
    [2015-04-13 17:32:08] [gtkbasebox] DEBUG: Loading 'language' screen
    [2015-04-13 17:32:08] [gtkbasebox] DEBUG: Loading 'location' screen
    [2015-04-13 17:32:08] [gtkbasebox] DEBUG: Loading 'check' screen
    [2015-04-13 17:32:08] [gtkbasebox] DEBUG: Loading 'desktop' screen
    [2015-04-13 17:32:08] [gtkbasebox] DEBUG: Loading 'features' screen
    [2015-04-13 17:32:08] [gtkbasebox] DEBUG: Loading 'keymap' screen
    [2015-04-13 17:32:08] [gtkbasebox] DEBUG: Loading 'timezone' screen
    [2015-04-13 17:32:08] [gtkbasebox] DEBUG: Loading 'ask' screen
    [2015-04-13 17:32:08] [gtkbasebox] DEBUG: Loading 'automatic' screen
    [2015-04-13 17:32:08] [gtkbasebox] DEBUG: Loading 'advanced' screen
    [2015-04-13 17:32:08] [gtkbasebox] DEBUG: Loading 'user_info' screen
    [2015-04-13 17:32:08] [gtkbasebox] DEBUG: Loading 'slides' screen
    [2015-04-13 17:32:09] [timezone] DEBUG: We have connection. Let's get our timezone
    [2015-04-13 17:32:10] [timezone] DEBUG: Timezone (latitude 38.1890, longitude -85.6768) detected.
    [2015-04-13 17:32:12] [check] INFO: We have Internet connection.
    [2015-04-13 17:32:12] [check] INFO: We're connected to a power source.
    [2015-04-13 17:32:12] [check] INFO: We have enough disk space.
    [2015-04-13 17:32:13] [connectionpool] INFO: Starting new HTTP connection (1): www.archlinux.org
    [2015-04-13 17:32:13] [connectionpool] DEBUG: "GET /mirrors/status/json/ HTTP/1.1" 301 366
    [2015-04-13 17:32:13] [connectionpool] INFO: Starting new HTTPS connection (1): www.archlinux.org
    [2015-04-13 17:32:17] [location] INFO: locale changed to : en_US.UTF-8
    [2015-04-13 17:32:17] [timezone] INFO: location changed to : America/New_York
    [2015-04-13 17:32:18] [connectionpool] DEBUG: "GET /mirrors/status/json/ HTTP/1.1" 200 None
    [2015-04-13 17:32:19] [rank_mirrors] DEBUG: Auto mirror selection has been run successfully
    [2015-04-13 17:32:20] [misc] INFO: locale changed to : en_US.UTF-8
    [2015-04-13 17:32:20] [misc] INFO: locale changed to : en_US.UTF-8
    [2015-04-13 17:32:20] [keymap] INFO: keyboard_layout is USA
    [2015-04-13 17:32:42] [desktop] INFO: Cnchi will install Antergos with the 'xfce' desktop
    [2015-04-13 17:32:52] [features] DEBUG: Selected 'aur' feature to install
    [2015-04-13 17:32:52] [features] DEBUG: Selected 'bluetooth' feature to install
    [2015-04-13 17:32:52] [features] DEBUG: Selected 'cups' feature to install
    [2015-04-13 17:32:52] [features] DEBUG: Selected 'firefox' feature to install
    [2015-04-13 17:32:52] [features] DEBUG: Selected 'firewall' feature to install
    [2015-04-13 17:32:52] [features] DEBUG: Selected 'fonts' feature to install
    [2015-04-13 17:32:52] [features] DEBUG: Selected 'office' feature to install
    [2015-04-13 17:32:52] [features] DEBUG: Selected 'smb' feature to install
    [2015-04-13 17:33:26] [show_message] WARNING: Root partition must be formatted.
    [2015-04-13 17:33:56] [advanced] DEBUG: Added /dev/sda1 to changelist: createme[No] relabel[No] fmt[Yes] mnt[/] encrypt[No]
    [2015-04-13 17:33:56] [advanced] DEBUG: Added /dev/sda2 to changelist: createme[No] relabel[No] fmt[No] mnt[swap] encrypt[No]
    [2015-04-13 17:33:57] [advanced] INFO: Creating new ext4 filesystem in /dev/sda1 labeled Arch
    [2015-04-13 17:34:01] [advanced] INFO: 
    [2015-04-13 17:34:01] [advanced] INFO: Creating new swap filesystem in /dev/sda2
    [2015-04-13 17:34:01] [advanced] INFO: Antergos will install the bootloader grub2 in device /dev/sda
    [2015-04-13 17:34:01] [process] DEBUG: Mounting partition /dev/sda1 into /install directory
    [2015-04-13 17:34:01] [process] DEBUG: Activating swap in /dev/sda2
    [2015-04-13 17:34:01] [process] DEBUG: Prepare pacman...
    [2015-04-13 17:34:01] [process] DEBUG: Creating a temporary pacman.conf for x86_64 architecture
    [2015-04-13 17:34:04] [pac] DEBUG: database dir '/install/var/lib/pacman/sync/' does not exist, creating it
    [2015-04-13 17:34:04] [pac] DEBUG: url: http://mirror.us.leaseweb.net/archlinux/core/os/x86_64/core.db
    [2015-04-13 17:34:04] [pac] DEBUG: maxsize: 26214400
    [2015-04-13 17:34:04] [pac] DEBUG: opened tempfile for download: /install/var/lib/pacman/sync/core.db.part (wb)
    [2015-04-13 17:34:05] [pac] DEBUG: curl returned error 0 from transfer
    [2015-04-13 17:34:05] [pac] DEBUG: response code: 200
    [2015-04-13 17:34:05] [pac] DEBUG: url: http://mirror.us.leaseweb.net/archlinux/extra/os/x86_64/extra.db
    [2015-04-13 17:34:05] [pac] DEBUG: maxsize: 26214400
    [2015-04-13 17:34:05] [pac] DEBUG: opened tempfile for download: /install/var/lib/pacman/sync/extra.db.part (wb)
    [2015-04-13 17:34:09] [pac] DEBUG: curl returned error 0 from transfer
    [2015-04-13 17:34:09] [pac] DEBUG: response code: 200
    [2015-04-13 17:34:09] [pac] DEBUG: url: http://mirror.us.leaseweb.net/archlinux/community/os/x86_64/community.db
    [2015-04-13 17:34:09] [pac] DEBUG: maxsize: 26214400
    [2015-04-13 17:34:09] [pac] DEBUG: opened tempfile for download: /install/var/lib/pacman/sync/community.db.part (wb)
    [2015-04-13 17:34:15] [pac] DEBUG: curl returned error 0 from transfer
    [2015-04-13 17:34:15] [pac] DEBUG: response code: 200
    [2015-04-13 17:34:15] [pac] DEBUG: url: http://mirror.us.leaseweb.net/archlinux/multilib/os/x86_64/multilib.db
    [2015-04-13 17:34:15] [pac] DEBUG: maxsize: 26214400
    [2015-04-13 17:34:15] [pac] DEBUG: opened tempfile for download: /install/var/lib/pacman/sync/multilib.db.part (wb)
    [2015-04-13 17:34:16] [pac] DEBUG: curl returned error 0 from transfer
    [2015-04-13 17:34:16] [pac] DEBUG: response code: 200
    [2015-04-13 17:34:16] [pac] DEBUG: url: http://mirror.us.leaseweb.net/antergos/antergos/x86_64/antergos.db
    [2015-04-13 17:34:16] [pac] DEBUG: maxsize: 26214400
    [2015-04-13 17:34:16] [pac] DEBUG: opened tempfile for download: /install/var/lib/pacman/sync/antergos.db.part (wb)
    [2015-04-13 17:34:17] [pac] DEBUG: curl returned error 0 from transfer
    [2015-04-13 17:34:17] [pac] DEBUG: response code: 200
    [2015-04-13 17:34:17] [process] DEBUG: Pacman ready
    [2015-04-13 17:34:17] [process] DEBUG: Selecting packages...
    [2015-04-13 17:34:17] [process] WARNING: HTTP Error 404: Not Found
    [2015-04-13 17:34:17] [process] DEBUG: Can't retrieve remote package list, using a local file instead.
    [2015-04-13 17:34:17] [process] DEBUG: Adding 'xfce' desktop packages
    [2015-04-13 17:34:17] [process] DEBUG: Hardware module detected this drivers: ['Nouveau', 'ModeSetting']
    [2015-04-13 17:34:17] [process] DEBUG: Hardware module added these packages : xf86-video-nouveau lib32-mesa-libgl lib32-mesa
    [2015-04-13 17:34:17] [process] DEBUG: Adding filesystem packages
    [2015-04-13 17:34:17] [process] DEBUG: Check for user desired features and add them to our installation
    [2015-04-13 17:34:17] [process] DEBUG: Adding packages for 'aur' feature.
    [2015-04-13 17:34:17] [process] DEBUG: Selecting package yaourt for feature aur
    [2015-04-13 17:34:17] [process] DEBUG: Selecting package cmake for feature aur
    [2015-04-13 17:34:17] [process] DEBUG: Selecting package git for feature aur
    [2015-04-13 17:34:17] [process] DEBUG: Selecting package bzr for feature aur
    [2015-04-13 17:34:17] [process] DEBUG: Adding packages for 'bluetooth' feature.
    [2015-04-13 17:34:17] [process] DEBUG: Selecting package bluez-utils for feature bluetooth
    [2015-04-13 17:34:17] [process] DEBUG: Selecting package gnome-bluetooth for feature bluetooth
    [2015-04-13 17:34:17] [process] DEBUG: Adding packages for 'cups' feature.
    [2015-04-13 17:34:17] [process] DEBUG: Selecting package cups for feature cups
    [2015-04-13 17:34:17] [process] DEBUG: Selecting package cups-pk-helper for feature cups
    [2015-04-13 17:34:17] [process] DEBUG: Selecting package gsfonts for feature cups
    [2015-04-13 17:34:17] [process] DEBUG: Selecting package gutenprint for feature cups
    [2015-04-13 17:34:17] [process] DEBUG: Selecting package hplip for feature cups
    [2015-04-13 17:34:17] [process] DEBUG: Selecting package system-config-printer for feature cups
    [2015-04-13 17:34:17] [process] DEBUG: Selecting package splix for feature cups
    [2015-04-13 17:34:17] [process] DEBUG: Adding packages for 'firefox' feature.
    [2015-04-13 17:34:17] [process] DEBUG: Selecting package firefox for feature firefox
    [2015-04-13 17:34:17] [process] DEBUG: Adding packages for 'firewall' feature.
    [2015-04-13 17:34:17] [process] DEBUG: Selecting package gufw for feature firewall
    [2015-04-13 17:34:17] [process] DEBUG: Selecting package ufw for feature firewall
    [2015-04-13 17:34:17] [process] DEBUG: Adding packages for 'fonts' feature.
    [2015-04-13 17:34:17] [process] DEBUG: Selecting package ttf-freefont for feature fonts
    [2015-04-13 17:34:17] [process] DEBUG: Selecting package ttf-google-fonts for feature fonts
    [2015-04-13 17:34:17] [process] DEBUG: Adding packages for 'office' feature.
    [2015-04-13 17:34:17] [process] DEBUG: Selecting package libreoffice-fresh for feature office
    [2015-04-13 17:34:17] [process] DEBUG: Selecting package hunspell-en for feature office
    [2015-04-13 17:34:17] [process] DEBUG: Adding packages for 'smb' feature.
    [2015-04-13 17:34:17] [process] DEBUG: Selecting package gvfs-smb for feature smb
    [2015-04-13 17:34:17] [process] DEBUG: Add libreoffice language package
    [2015-04-13 17:34:17] [process] DEBUG: All features needed packages have been added
    [2015-04-13 17:34:17] [process] DEBUG: Adding 'grub2' bootloader packages
    [2015-04-13 17:34:17] [process] DEBUG: Packages selected
    [2015-04-13 17:34:17] [process] DEBUG: Downloading packages...
    [2015-04-13 17:34:17] [pac] DEBUG: loading package cache for repository 'core'
    [2015-04-13 17:34:17] [pac] DEBUG: opening archive /install/var/lib/pacman/sync/core.db
    [2015-04-13 17:34:17] [pac] DEBUG: added 208 packages to package cache for db 'core'
    [2015-04-13 17:34:17] [pac] DEBUG: loading group cache for repository 'core'
    [2015-04-13 17:34:17] [pac] DEBUG: loading package cache for repository 'extra'
    [2015-04-13 17:34:17] [pac] DEBUG: opening archive /install/var/lib/pacman/sync/extra.db
    [2015-04-13 17:34:17] [pac] DEBUG: added 3096 packages to package cache for db 'extra'
    [2015-04-13 17:34:17] [pac] DEBUG: loading package cache for repository 'community'
    [2015-04-13 17:34:17] [pac] DEBUG: opening archive /install/var/lib/pacman/sync/community.db
    [2015-04-13 17:34:17] [pac] DEBUG: added 3853 packages to package cache for db 'community'
    [2015-04-13 17:34:17] [pac] DEBUG: loading group cache for repository 'community'
    [2015-04-13 17:34:17] [pac] DEBUG: loading package cache for repository 'multilib'
    [2015-04-13 17:34:17] [pac] DEBUG: opening archive /install/var/lib/pacman/sync/multilib.db
    [2015-04-13 17:34:17] [pac] DEBUG: added 186 packages to package cache for db 'multilib'
    [2015-04-13 17:34:17] [pac] DEBUG: loading group cache for repository 'multilib'
    [2015-04-13 17:34:17] [pac] DEBUG: loading package cache for repository 'antergos'
    [2015-04-13 17:34:17] [pac] DEBUG: opening archive /install/var/lib/pacman/sync/antergos.db
    [2015-04-13 17:34:17] [pac] DEBUG: added 64 packages to package cache for db 'antergos'
    [2015-04-13 17:34:17] [pac] DEBUG: loading group cache for repository 'antergos'
    [2015-04-13 17:34:17] [pac] DEBUG: loading package cache for repository 'local'
    [2015-04-13 17:34:17] [pac] DEBUG: added 0 packages to package cache for db 'local'
    [2015-04-13 17:34:17] [pac] DEBUG: loading group cache for repository 'extra'
    [2015-04-13 17:34:24] [pac] ERROR: returning error 6 from alpm_db_get_pkg : wrong or NULL argument passed
    [2015-04-13 17:34:24] [pac] ERROR: returning error 6 from alpm_db_get_group : wrong or NULL argument passed
    [2015-04-13 17:34:24] [pac] ERROR: returning error 6 from alpm_db_get_pkg : wrong or NULL argument passed
    [2015-04-13 17:34:24] [pac] ERROR: returning error 6 from alpm_db_get_group : wrong or NULL argument passed
    [2015-04-13 17:34:24] [pac] ERROR: returning error 6 from alpm_db_get_pkg : wrong or NULL argument passed
    [2015-04-13 17:34:24] [pac] ERROR: returning error 6 from alpm_db_get_group : wrong or NULL argument passed
    [2015-04-13 17:34:24] [pac] ERROR: returning error 6 from alpm_db_get_pkg : wrong or NULL argument passed
    [2015-04-13 17:34:24] [pac] ERROR: returning error 6 from alpm_db_get_group : wrong or NULL argument passed
    [2015-04-13 17:34:24] [pac] ERROR: returning error 6 from alpm_db_get_pkg : wrong or NULL argument passed
    [2015-04-13 17:34:24] [pac] ERROR: returning error 6 from alpm_db_get_group : wrong or NULL argument passed
    [2015-04-13 17:34:24] [metalink] ERROR: Can't find these packages:  
    [2015-04-13 17:34:24] [download] ERROR: Error creating metalink for package . Installation will stop
    [2015-04-13 17:34:24] [process] ERROR: "Can't create download package list. Check log output for details"
    [2015-04-13 17:34:24] [process] ERROR: ['Traceback (most recent call last):\n', '  File "/usr/share/cnchi/cnchi/installation/process.py", line 166, in run\n    self.run_installation()\n', '  File "/usr/share/cnchi/cnchi/misc/misc.py", line 175, in helper\n    return func(*args, **kwargs)\n', '  File "/usr/share/cnchi/cnchi/installation/process.py", line 349, in run_installation\n    self.download_packages()\n', '  File "/usr/share/cnchi/cnchi/installation/process.py", line 400, in download_packages\n    self.packages, use_aria2, pacman_conf_file, pacman_cache_dir, cache_dir, self.callback_queue)\n', '  File "/usr/share/cnchi/cnchi/download/download.py", line 94, in __init__\n    raise InstallError(_("Can\'t create download package list. Check log output for details"))\n', 'misc.misc.InstallError: "Can\'t create download package list. Check log output for details"\n']
    [2015-04-13 17:34:33] [slides] INFO: Installing using the 'advanced' method
    [2015-04-13 17:34:33] [slides] INFO: Updating core database
    [2015-04-13 17:34:33] [slides] INFO: Updating extra database
    [2015-04-13 17:34:33] [slides] INFO: Updating community database
    [2015-04-13 17:34:33] [slides] INFO: Updating multilib database
    [2015-04-13 17:34:33] [slides] INFO: Updating antergos database
    [2015-04-13 17:34:33] [slides] INFO: Getting package list...
    [2015-04-13 17:34:33] [slides] INFO: Creating the list of packages to download...
    [2015-04-13 17:34:33] [show_message] ERROR: "Can't create download package list. Check log output for details"
    
  • Does the same thing with the 64 bit live and minimal iso files downloaded today.

  • It looks like the installer was not able to update itself, possibly due to a bad mirror. If you try it again it should work. Let us know if you still have trouble!

  • if i could interfere, the same problem continues to persist here.

    in rare cases when cnchi succeeds to update itself (from 0.7.303 to 0.8.x), after selecting additional products in Extras
    extras.png
    and filling in Accounts details (real name, computer name, user, password, etc) the installation doesn’t start, returning the error
    error-download.png

    this test was done about 1 hour ago.

    i forgot to grab /tmp/cnchi.log, but can not reproduce the test, to get it as well - on subsequent antergos-2015.04.12-x86_64.iso runs cnchi does not update itself anymore to higher version (0.8.x) and remains at the isos’s default 0.7.303.

    seems impossible, but it’s true - cnchi succeeds to update itself only twice a day here. in other 4…6 daily attempts to run the installer cnchi remains sticked at 0.7.303, without updating. in such case i simply exit from the installer, without proceeding further.

  • @just It sounds like the update script is not able to complete successfully on your system. If you could, please post the updater log. You can find it at /tmp/pacman-boot.log. You can force the installer to update by running these commands (be sure its not running first):

    sudo pacman -R cnchi-dev
    sudo pacman -Syy cnchi --force
    

    Although I think I fixed the problem with libreoffice, its probably best if you do not select the option to install it so that you can complete your install. Let me know how it goes. Cheers!

  • I am getting same error and even file manager not starting to collect error log,

  • @lots.0.logs said:

    sudo pacman -R cnchi-dev
    sudo pacman -Syy cnchi --force

    I did this but still getting same error.

  • I get this error too. Any idea?

  • success!

    @lots.0.logs,
    thank you for not giving up on the problems, for finding a time, while modifying the software, to patiently and politely answer the users in forums, for valuable, well-working suggestions. your help is much appreciated.

    you’re right, the updater fails to update cnchi, after the internet connection has been established. this is the /tmp/pacman-boot.log after the failed initial update:

    :: Synchronizing package databases...
    error: failed to update core (unable to lock database)
    error: failed to update extra (unable to lock database)
    error: failed to update community (unable to lock database)
    error: failed to update antergos (unable to lock database)
    error: failed to update multilib (unable to lock database)
    error: failed to synchronize any databases
    error: failed to init transaction (unable to lock database)
    error: could not lock database: File exists
      if you're sure a package manager is not already
      running, you can remove /var/lib/pacman/db.lck
    warning: database file for 'community' does not exist
    warning: database file for 'antergos' does not exist
    warning: database file for 'multilib' does not exist
    warning: database file for 'antergos' does not exist
    warning: database file for 'multilib' does not exist
    error: target not found: cnchi
    [2015-04-14 10:11:10] [cnchi] INFO: Using GTK v3.16.1
    [2015-04-14 10:11:10] [cnchi] INFO: Using pyalpm v0.7 as interface to libalpm v9.0.1
    [2015-04-14 10:11:10] [updater] WARNING: Could not find 'update.info' file. Cnchi will not be able to update itself.
    [2015-04-14 10:11:11] [main_window] INFO: Cnchi installer version 0.7.303
    [2015-04-14 10:11:11] [gtkbasebox] DEBUG: Loading 'welcome' screen
    

    following your suggestion, and assuring that cnchi was not running, i forced cnchi update by hand. with cnchi updated, i started it from terminal. these are all commands, starting from cnchi update and ending up with a successfully completed instalation:

    [[email protected] ~]$ sudo killall cnchi
    cnchi: no process found
    [[email protected] ~]$ sudo pacman -R cnchi-dev
    checking dependencies...
    
    Packages (1) cnchi-dev-0.8rc4-1
    
    Total Removed Size:  9.11 MiB
    
    :: Do you want to remove these packages? [Y/n] Y
    (1/1) removing cnchi-dev                                                       [############################################] 100%
    [[email protected] ~]$ sudo pacman -Syy cnchi --force
    :: Synchronizing package databases...
    core                                                 121.3 KiB   831K/s 00:00 [############################################] 100%
    extra                                               1797.8 KiB  2.70M/s 00:01 [############################################] 100%
    community                                              2.6 MiB  1987K/s 00:01 [############################################] 100%
    antergos                                             371.0 KiB   626K/s 00:01 [############################################] 100%
    multilib                                             125.0 KiB   735K/s 00:00 [############################################] 100%
    resolving dependencies...
    looking for conflicting packages...
    
    Packages (1) cnchi-0.8.16-3
    
    Total Installed Size:  9.12 MiB
    
    :: Proceed with installation? [Y/n] Y
    (1/1) checking keys in keyring                                                 [############################################] 100%
    (1/1) checking package integrity                                               [############################################] 100%
    (1/1) loading package files                                                    [############################################] 100%
    (1/1) checking for file conflicts                                              [############################################] 100%
    (1/1) checking available disk space                                            [############################################] 100%
    (1/1) installing cnchi                                                         [############################################] 100%
    

    once cnchi is updated, i simply start the installation from terminal:

    [[email protected] ~]$ sudo cnchi
    
    (cnchi.py:1554): Pango-WARNING **: error opening config file '/root/.config/pango/pangorc': Permission denied
    
    /usr/share/cnchi/cnchi/gtkbasebox.py:57: Warning: The property GtkWidget:margin-left is deprecated and shouldn't be used anymore. It will be removed in a future version.
      self.ui.add_from_file(self.ui_file)
    
    (cnchi.py:1554): Gtk-WARNING **: Failed to set property GtkBox.halign to left: Could not parse enum: `left'
    /usr/share/cnchi/cnchi/gtkbasebox.py:57: Warning: The property GtkMisc:xalign is deprecated and shouldn't be used anymore. It will be removed in a future version.
      self.ui.add_from_file(self.ui_file)
    dumpe2fs 1.42.12 (29-Aug-2014)
    dumpe2fs 1.42.12 (29-Aug-2014)
    dumpe2fs 1.42.12 (29-Aug-2014)
    dumpe2fs 1.42.12 (29-Aug-2014)
    dumpe2fs 1.42.12 (29-Aug-2014)
    dumpe2fs 1.42.12 (29-Aug-2014)
    dumpe2fs 1.42.12 (29-Aug-2014)
    dumpe2fs 1.42.12 (29-Aug-2014)
    dumpe2fs 1.42.12 (29-Aug-2014)
    dumpe2fs 1.42.12 (29-Aug-2014)
    dumpe2fs 1.42.12 (29-Aug-2014)
    dumpe2fs 1.42.12 (29-Aug-2014)
    dumpe2fs 1.42.12 (29-Aug-2014)
    dumpe2fs 1.42.12 (29-Aug-2014)
    Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
    gpg: /install/etc/pacman.d/gnupg/trustdb.gpg: trustdb created
    gpg: no ultimately trusted keys found
    gpg: starting migration from earlier GnuPG versions
    gpg: porting secret keys from '/install/etc/pacman.d/gnupg/secring.gpg' to gpg-agent
    gpg: migration succeeded
    gpg: Generating pacman keyring master key...
    gpg: key 66F5139E marked as ultimately trusted
    gpg: directory '/install/etc/pacman.d/gnupg/openpgp-revocs.d' created
    gpg: Done
    ==> Updating trust database...
    gpg: 3 marginal(s) needed, 1 complete(s) needed, PGP trust model
    gpg: depth: 0  valid:   1  signed:   0  trust: 0-, 0q, 0n, 0m, 0f, 1u
    ==> Appending keys from archlinux.gpg...
    gpg: 3 marginal(s) needed, 1 complete(s) needed, PGP trust model
    gpg: depth: 0  valid:   1  signed:   0  trust: 0-, 0q, 0n, 0m, 0f, 1u
    ==> Appending keys from antergos.gpg...
    gpg: 3 marginal(s) needed, 1 complete(s) needed, PGP trust model
    gpg: depth: 0  valid:   1  signed:   0  trust: 0-, 0q, 0n, 0m, 0f, 1u
    ==> Locally signing trusted keys in keyring...
      -> Locally signing key 0E8B644079F599DFC1DDC3973348882F6AC6A4C2...
      -> Locally signing key 684148BB25B49E986A4944C55184252D824B18E8...
      -> Locally signing key 24B445614FAC071891EDCE49CDBD406AA1AA7A1D...
      -> Locally signing key D95436A2E18DA94A72B1A5E2AEA529BF122902E5...
      -> Locally signing key EC3B5CE8FE98DFDF51B705536D6DDA3D2A45C7B4...
      -> Locally signing key 44D4A033AC140143927397D47EFD567D4C7EA887...
      -> Locally signing key 27FFC4769E19F096D41D9265A04F9397CDFD6BB0...
      -> Locally signing key AB19265E5D7D20687D303246BA1DFB64FFF979E7...
    ==> Importing owner trust values...
    gpg: inserting ownertrust of 4
    gpg: setting ownertrust to 4
    gpg: setting ownertrust to 4
    gpg: setting ownertrust to 4
    gpg: setting ownertrust to 4
    gpg: setting ownertrust to 4
    gpg: setting ownertrust to 4
    gpg: setting ownertrust to 4
    ==> Disabling revoked keys in keyring...
      -> Disabling key F5A361A3A13554B85E57DDDAAF7EF7873CFD4BB6...
      -> Disabling key 7FA647CD89891DEDC060287BB9113D1ED21E1A55...
      -> Disabling key D4DE5ABDE2A7287644EAC7E36D1A9E70E19DAA50...
      -> Disabling key BC1FBE4D2826A0B51E47ED62E2539214C6C11350...
      -> Disabling key 9515D8A8EAB88E49BB65EDBCE6B456CAF15447D5...
      -> Disabling key 4A8B17E20B88ACA61860009B5CED81B7C2E5C0D2...
      -> Disabling key 63F395DE2D6398BBE458F281F2DBB4931985A992...
      -> Disabling key 0B20CA1931F5DA3A70D0F8D2EA6836E1AB441196...
      -> Disabling key 8F76BEEA0289F9E1D3E229C05F946DED983D4366...
      -> Disabling key 66BD74A036D522F51DD70A3C7F2A16726521E06D...
      -> Disabling key 81D7F8241DB38BC759C80FCE3A726C6170E80477...
      -> Disabling key E7210A59715F6940CF9A4E36A001876699AD6E84...
    ==> Updating trust database...
    gpg: 3 marginal(s) needed, 1 complete(s) needed, PGP trust model
    gpg: depth: 0  valid:   1  signed:   8  trust: 0-, 0q, 0n, 0m, 0f, 1u
    gpg: depth: 1  valid:   8  signed:  62  trust: 0-, 0q, 0n, 8m, 0f, 0u
    gpg: depth: 2  valid:  62  signed:   5  trust: 62-, 0q, 0n, 0m, 0f, 0u
    gpg: next trustdb check due at 2015-05-09
    [[email protected] ~]$ 
    

    to avoid extra-repository failures, only AUR was selected as an additional product to install:
    01-extras-aur-only.png

    without extra-products, installation proceeded normally, downloading all packages:
    05-downloading-finishes.png

    installing them:
    06-installing-starts.png

    configuring the system:
    07-configuring.png

    and successfully terminating the installation:
    10-finished.png

    the situation here (from end-user’s point of view) looks like:

    1. cnchi not updated: persists, but may be easily updated by hand
    2. extra products don’t install: persists, but may be installed by hand later
    3. “no such file or dir…” after packages download: definitely solved

    nothing difficult for arch user, slightly above the capabilities of an average ubuntu user, far beyond any comprehension for a windowz refugee.

    thanks again.

  • Sorry for my english, but cnchi still not working. In my 2 distros (i686 and x86_64) cnchi-dev is removed by default. After reinstall cnchi, i always see “Can’t create download package list. Check log output for details”.

  • @just Thanks for taking the time to report your findings. We certainly appreciate it!

    @crims After Cnchi updates itself, which version is shown in the top header? The latest (and finally fully functional) version is 0.8.21. If that’s not the version you are getting, the mirrors near you must not be updated yet. Give it another hour or so and try again.

  • Sorry it doesn’t work. It says Antergos Installation Error : "Can’t create download package list. Check log output for details. " I download x86_64 full version (1.5 GB).

    Uninstalled cnchi-dev, reinstalled it using following.
    sudo pacman -R cnchi-dev
    sudo pacman -Syy cnchi --force
    Started cnchi-dev from terminal. But it failes at 83% while downloading package list. I selected openbox desktop and I selected only AUR support.

  • @cb9 You should not use cnchi-dev. The latest (and fully functional) version of Cnchi is 0.8.21. If that’s not the version you get when Cnchi updates itself, you can see the instructions in the previous posts on how to do it manually. Let me know how it goes. Cheers!

  • @lots.0.logs “After Cnchi updates itself, which version is shown in the top header? The latest (and finally fully functional) version is 0.8.21.”
    Screenshot from 2015-04-14 19-20-14.png
    Screenshot from 2015-04-14 19-21-30.png
    Screenshot from 2015-04-14 19-22-42.png
    Screenshot from 2015-04-14 19-23-04.png

  • @lots.0.logs After this installation steps, when Cnchi propose me to create a user, i see THAT(!):
    1.jpg
    2.jpg
    3.jpg
    And my system is locks up and freeze.

  • when cnchi is run from the terminal you must use this command sudo -E cnchi -dv

  • @lots.0.logs said:

    when cnchi is run from the terminal you must use this command sudo -E cnchi -dv
    IMG_2472.JPG
    IMG_2473.JPG
    IMG_2474.JPG
    IMG_2475.JPG
    IMG_2476.JPG
    IMG_2478.JPG

  • @crims Thanks for those details. I see that Arch recently moved the b43-firmware package to the AUR so we’ll have to add it to our repo. It’s building as I type this. However, it will take an hour or two for the mirrors to update.

  • @lots.0.logs said:

    @crims Thanks for those details. I see that Arch recently moved the b43-firmware package to the AUR so we’ll have to add it to our repo. It’s building as I type this. However, it will take an hour or two for the mirrors to update.
    Ok. Thanks. I try again later.

  • Happy to report that install has worked for me (Gnome) enabling only aur and smb. Thanks for your efforts; love Antergos!

create1 cant1 error174 download15 package3 Posts 29Views 15831
Log in to reply