• TARJETA RECONOCIDA PERO SIN SONIDO


    Acabo de instalar Antergos Xfce y mi sorpresa es que reconoce mi tarjeta de sonido externa y me deja escogerla, pero no suena…
    Anteriormente tuve instalado Manjario Xfce y funcionaba bien desde el principio.
    La tarjeta es una Alesis IO2 Express
    Alguna idea de lo que puede pasar?
    Gracias

  • @eldona

    Hola,

    No uso XFCE, pero supongo que utiliza el pulseaudio. Has probado que no sea una cuestion de volumen o que tienes seleccionada una salida incorrecta? Prueba a instal·lar el pavucontrol que es un controlador de pulseaudio. Te permitirá cambiar el volumen y tambien seleccionar la salida (altavozes, auriculares, …)

    Saludos!

  • Hola de nuevo, Karasu!
    Primero intenté instalar pavucontrol desde el gestor de paquetes pero me arrojaba el error “no se pudo bloquear la base de datos” así que estuve averiguando como solucionarlo y una vez hecho instalé pavucontrol.
    En los controles principales de pavucontrol seguía apareciendo mi tarjeta pero no había todavía sonido, fue al abrir pavucontrol de nuevo mientras reproducía una canción desde “parole” cuando apareció en la pestaña “reproducción” un control para dicha aplicación asignado al audio interno donde pude cambiarlo a la salida de la tarjeta externa, que es la que uso.
    Eso me permite asignar la tarjeta externa a cada aplicación por separado (ya lo hice con el navegador de internet también) pero no entiendo porqué no se puede asignar esa tarjeta por defecto para todos los sonidos del sistema…

  • Hola,

    Si vas a dispositivos de salida (creo que es la tercera pestaña), ahí debes seleccionar el dispositivo de salida que quieres. Luego, arriba a la derecha hay tres iconos, uno para emmudir el audio, otro para bloquear los altavozes al mismo volumen y un tercero que sirve para fijar la salida que tengas seleccionada (es decir, para guardar los cambios). Debes seleccionar este tercero icono.

    Esto lo tienes que hacer para cada salida (HDMI, Digital, Analògica… ) que quieras cambiar (aparecen todas en la misma pestaña.

    A ver si te sirve de algo :grin:

  • Si, ese tercer botón del que hablas ya lo había visto. Cuando pongo el puntero encima dice “poner como plan B” y creí que se refería a poner el dispositivo como alternativa en caso de que fallase el principal… pero da lo mismo porque siempre aparece con el check marcado y no se puede desmarcar ni marcar.
    De momento parece que funciona con normalidad, aún no instalé ningún otro programa que necesite audio así que no sé si se establecerá a esa salida por defecto o tendría que asignarla a mano.
    Cuando llegue el caso lo sabremos!
    Muchas gracias por tu ayuda, karasu.

  • This post is deleted!
  • eldona
    Bueno, la verdad es que xfce no me ha convencido del todo y quisiera probar con otro escritorio, el caso es que arranco Antergos en modo live para reinstalar pero no se ejecuta el asistente de bienvenida ni puedo ejecutar Cnchi desde el icono de la propia aplicación. Se queda un rato dando vueltas el circulito como si fuera a ejecutarse pero luego no ocurre nada…
    He probado a reiniciar pero sigue sin aparecer Cnchi por ningún sitio…

  • Hola,

    Qué raro… lo acabo de probar ahora mismo y me aparece perfectamente. Abre una terminal y ejecuta tú mismo cnchi de este modo:

    sudo -E cnchi -dv

    Pon aquí si te sale algun error, please.

    Saludos!

  • @karasu
    Gracias de nuevo por contestar! esto es lo que arroja esa instrucción:

    [2015-04-15 19:19:04] [cnchi] INFO: Using GTK v3.14.6
    [2015-04-15 19:19:04] [cnchi] INFO: Using pyalpm v0.7 as interface to libalpm v9.0.0
    [2015-04-15 19:19:04] [updater] WARNING: Could not find ‘update.info’ file. Cnchi will not be able to update itself.
    Traceback (most recent call last):
    File “/usr/share/cnchi/cnchi/cnchi.py”, line 62, in do_activate
    import main_window
    File “/usr/share/cnchi/cnchi/main_window.py”, line 52, in <module>
    from installation import alongside as installation_alongside
    File “/usr/share/cnchi/cnchi/installation/alongside.py”, line 43, in <module>
    import misc.gtkwidgets as gtkwidgets
    File “/usr/share/cnchi/cnchi/misc/gtkwidgets.py”, line 57, in <module>
    class StylizedFrame(Gtk.Bin):
    File “/usr/share/cnchi/cnchi/misc/gtkwidgets.py”, line 62, in StylizedFrame
    0, GLib.MAXINT, 10, GObject.ParamFlags.READWRITE),
    File “/usr/lib/python3.4/site-packages/gi/module.py”, line 320, in getattr
    return getattr(self._introspection_module, name)
    File “/usr/lib/python3.4/site-packages/gi/module.py”, line 139, in getattr
    self.name, name))
    AttributeError: ‘gi.repository.GLib’ object has no attribute ‘MAXINT’

  • Necesitas una ISO actualizada. La que estás usando es antigua (vienen las GTK 3.14 y con la última versión de Cnchi necesitas las GTK 3.16).

    EDIT: Tambien puedes actualizar tú mismo con sudo pacman -Syu pero yo te recomiendo bajar la última ISO…

  • @karasu

    Vaya! pensé que sería la última porque la baje hace unos dias…
    Ok, ahora descargo entonces la última que esté en la web.
    Gracias karasu!

  • Hahaha… es que estamos a la última!

  • Je, je!!! eso es lo que mola!!!

  • Bueno, pues parece que no dejo de tropezarme una y otra vez…
    Ayer hice la reinstalación de Antergos, esta vez con escritorio Cinnamon, y al terminar el instalador me advirtió que podría haber problemas con el arranque… Efectivamente, al arrancar arrojó el error “grub_rescue” así que me pusé a buscar soluciones y después de probar alguna conseguí reparar el grub, no volví al de Antergos, si no a uno más minimalista, parecido al de Manjaro, pero a pesar de entrar en la instalación de Antergos no me reconocía la contraseña así que volvía a la pantalla de bienvenida una y otra vez…
    Para empezar de nuevo ahora he vuelto a reinstalar Antergos pero volvió a aparecer el aviso de que podría estar mal el arranque y vuelvo a tener el mensaje “grub-rescue”…

  • @eldona Por casualidad no tienes el log? Cnchi lo guarda en /var/log

  • @karasu Aquí está
    ¿Necesitas todo o sirve con esto?

    [2015-04-16 18:43:18] [process] DEBUG: Instalando cargador de arranque…
    [2015-04-16 18:43:18] [process] ERROR: Couldn’t install boot loader: ‘/boot’
    [2015-04-16 18:43:18] [chroot] DEBUG: Directorios especiales no montados. Saltando.
    [2015-04-16 18:43:18] [process] DEBUG: Copying install log to /var/log.

  • Bueno, he seguido buscando info y he vuelto a instalar el grub de Arch… El grub funciona, sin el aspecto del de Antergos, claro, y puedo entrar en windows pero cuando cargo Antergos aparece mi usuario y no reconoce la contraseña…
    Es curioso porque en vez de aparecer el nombre del equipo aparece mi nombre, no se si debería ser así o no pero el caso es que no funciona la contraseña y sería muy raro que me hubiera confundido al establecerla ya que hay que escribirla 2 veces…

  • @eldona

    Cuando arranques Antergos y te pida usuario y contraseña, no los pongas, simplemente pulsa CTRL+ALT+F2 para pasar a una consola.

    Desde allí intenta poner tu nombre de usuario y la contraseña (cuando entres la contraseña no se muestra nada por pantalla, es normal).

    Ya dirás :p

  • Al instalar Antergos me pidió mi nombre, un nombre para el equipo y nombre de usuario. En mi caso fueron “Luis”, “Luislinux” y “Luinux”. En la foto adjunta está lo que pasó al loguearme en consola
    2015-04-18 18.01.50.jpg

  • Creo que el problema vino al hacer la segunda instalación de Antergos Cinnamon sobre las particiones existentes de Antergos Xfce. Cuando instalé Antergos Xfce sobre unas particiones que tenía de Manjaro Xfce se instaló correctamente. Fue al reinstalar la versión Cinnamon cuando se estropeó el Grub. El problema que hay ahora, a pesar de tener el grub de Arch operativo, es que no es capaz de arrancar la sesión, porque me he fijado que si meto una contraseña que no es la mía salta el aviso de contraseña errónea, pero al meter la mía, la buena, no da error si no que hace como un “reset” de la pantalla y vuelve a mostrar la pantalla de bienvenida sin loguear (la del reloj digital)

io2 express1 sonido1 audio28 alesis1 Posts 28Views 9881
Log in to reply