• Possible Bug: Cnchi failing to install - file or folder missing


    Hi guys,

    been using antergos for quite some time now and wanted to do a clean install today.
    Cnchi actually looks much better compared to when I used it last time.
    Nevertheless Installation doesen’t work for me right now which is quite frustrating.

    IMG_20150412_220849.jpg

    So obviously some installer which is requiered for sudo is missing.
    Is this a bug or do I have to keep looking on my side of things?

    Regards

  • Hi,

    That’s strange. Cnchi creates that file, so no missing is possible.

    Did you have enough free space? Can you post here the log? Should be /tmp/cnchi.log

    Thanks.

  • Thanks for the quick reply.

    I was installing to an empty 750 GB hdd so I most likely wasn’t running out of freespace.

    I am going to reproduce the bug and post the log afterwards.

    Edit:
    Reproduced the bug and attached my log.
    cnchi.log

  • I have also encountered this error.
    Definatly got enough free space. Installing on a 2TB HDD.

    Attached is my cnchi.log

  • It is a fact, also the error I get, plus I get another error saying: Could not find the list of packages to download.
    I hope it gets fixed soon.

    PD: Sorry for my english but i don’t talk this language.

  • I’m getting the same error trying to install to a 130GB partition. error.png

    @Emmanuel89 I can’t help with this error but try running “sudo pacman -Syy” before you install to fix the download error. I had the same problem and that seemed to fix it.

  • Thanks, I’ll try and and told them it happened.

  • Screenshot from 2015-04-12 14-35-12.png
    I think waiting a bit when all this is resolved.

  • Yea, looks like all sorts of issues are appearing :confused :/

  • Yes, I to am getting this error on the 32bit minimal installation.

  • Same issue here aswell. Tried both min and full version, testing it out on a vm.

    Chose kde and letting setup erase harddrive automatically.

    I7 3770K@4.3Ghz/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • @Emmanuel89 This may be a a fix here from this post.
    Unfortunately cannot go further due to the missing sudoers.d/10-installer file error.

  • I confirm the same problem. I can not install
    http://imgur.com/lcgjg5g

  • same thing, I get a keyboard error and a sudoers error. 2015.04.12-i686 iso

    [2015-04-12 23:19:21] [slides] INFO: Generating locales…
    [2015-04-12 23:19:21] [slides] INFO: Adjusting hardware clock…
    [2015-04-12 23:19:23] [process] DEBUG: Set /etc/X11/xorg.conf.d/10-keyboard.conf for the xkblayout
    [2015-04-12 23:19:23] [process] ERROR: [Errno 2] No such file or directory: ‘/install/etc/X11/xorg.conf.d/10-keyboard.conf’
    [2015-04-12 23:19:23] [process] ERROR: [‘Traceback (most recent call last):\n’, ’ File “/usr/share/cnchi/cnchi/installation/process.py”, line 166, in run\n self.run_installation()\n’, ’ File “/usr/share/cnchi/cnchi/misc/misc.py”, line 175, in helper\n return func(*args, **kwargs)\n’, ’ File “/usr/share/cnchi/cnchi/installation/process.py”, line 355, in run_installation\n self.configure_system()\n’, ’ File “/usr/share/cnchi/cnchi/installation/process.py”, line 1333, in configure_system\n with open(xorg_conf_xkb_path, “w”) as xorg_conf_xkb:\n’, “FileNotFoundError: [Errno 2] No such file or directory: ‘/install/etc/X11/xorg.conf.d/10-keyboard.conf’\n”]
    [2015-04-12 23:19:23] [show_message] ERROR: [Errno 2] No such file or directory: ‘/install/etc/X11/xorg.conf.d/10-keyboard.conf’

  • @Brandon-TheGreat Unfortunately, same for me… The sudoers error is gone but the keyboard error you mentioned has now replaced it. :(

  • @Matty-Eberhard said:

    @Brandon-TheGreat Unfortunately, same for me… The sudoers error is gone but the keyboard error you mentioned has now replaced it. :(

    Now I have tried the US English keyboard, and Canadian English keyboard, both give me the same error.

  • Hy,
    I’m dealing with the same problem. I fucked up my whole sunday just trying to install Antergos :laughing:

    brgds Buddy

  • @BuddySpencer Just going to have to wait until the Devs fix the issue. I gotta tell ya, they’ve been pretty helpful so far :)

  • Ok guys, another one with the same problem :disappointed: I’m at work, but if I could help whith something…

  • @Matty-Eberhard thanks man, I really hope so :smile:

Posts 78Views 25467
Log in to reply