• [cnchi 0.8.3-2] Doesn't run


    <code>[[email protected] ~]$ sudo cnchi
    Traceback (most recent call last):
    File “/usr/share/cnchi/cnchi/cnchi.py”, line 62, in do_activate
    import main_window
    File “/usr/share/cnchi/cnchi/main_window.py”, line 42, in <module>
    import timezone
    File “/usr/share/cnchi/cnchi/timezone.py”, line 37, in <module>
    import misc.tz as tz/
    File “/usr/share/cnchi/cnchi/misc/tz.py”, line 175, in <module>
    class Location(object):
    File “/usr/share/cnchi/cnchi/misc/tz.py”, line 179, in Location
    ’latitude’: (GObject.TYPE_FLOAT, ‘latitude’, ‘latitude’, 0, GLib.MAXFLOAT, 1, GObject.ParamFlags.READWRITE),
    File “/usr/lib/python3.4/site-packages/gi/module.py”, line 320, in getattr
    return getattr(self._introspection_module, name)
    File “/usr/lib/python3.4/site-packages/gi/module.py”, line 139, in getattr
    self.name, name))
    AttributeError: ‘gi.repository.GLib’ object has no attribute ‘MAXFLOAT’
    </code>

    I wanted to install antergos on my laptop, but I got this error message. :(

    Don't forget to mark as [SOLVED], if your problem was solved!

  • @I-sty

    Hi,

    Are you installing from the newest ISO? If you’re installing from an older one and then updated Cnchi to 0.8 it’s possible you have some GTK incompatibilities.

    What I mean is that with GTK 3.16 here works. As a quick fix, Cnchi 0.8.4 uses old GTK method in that file, but YMMV.

    If you’re in need of install right now, grab the latest testing iso or update your live to Gtk 3.16 before running Cnchi.

    Cheers!

  • @karasu said:

    @I-sty

    Hi,

    Are you installing from the newest ISO? If you’re installing from an older one and then updated Cnchi to 0.8 it’s possible you have some GTK incompatibilities.

    What I mean is that with GTK 3.16 here works. As a quick fix, Cnchi 0.8.4 uses old GTK method in that file, but YMMV.

    If you’re in need of install right now, grab the latest testing iso or update your live to Gtk 3.16 before running Cnchi.

    Cheers!
    I used the latest ISO, with the latest Cnchi.

    Don't forget to mark as [SOLVED], if your problem was solved!

install76 cnchi104 update45 Posts 3Views 1588
Log in to reply