• PPTP-VPN + UFW how to get it to work?


    Hi,

    How can I configure UFW to work allow PPTP-VPN to pass through?

    I have set-up the vpn and if UFW is disabled it is working fine. As soon as I enable it, it does not work anymore.

    I have added the rules in /etc/ufw/before.rules:

    # Allow GRE protocol for VPN
    -A ufw-before-input -p 47 -j ACCEPT
    -A ufw-before-output -p 47 -j ACCEPT
    

    I have also added the rules in GUFW:

    1723   ALLOW IN   EVERYWHERE
    1723   ALLOW OUT   EVERYWHERE
    1723   ALLOW IN (v6)   EVERYWHERE
    1723   ALLOW OUT (v6)   EVERYWHERE
    

    Any help would be greatly appreciated.

    Thanks,
    Rufus

  • This answer is for Ubuntu, but worked fine in my Antergos. (Thanks to Dikei) ;)
    http://askubuntu.com/questions/572497/cant-connect-to-pptp-vpn-with-ufw-enabled-on-ubuntu-14-04-with-kernel-3-18

    Add this rule to the file /etc/ufw/before.rules before the line # drop INVALID packets …
    -A ufw-before-input -p 47 -j ACCEPT

    On Terminal…
    sudo modprobe nf_conntrack_pptp
    sudo ufw disable
    sudo ufw enable

  • Thank you! It works brilliantly!

pptp-vpn1 ufw2 Posts 3Views 4483
Log in to reply