• White screen on LightDM


    Got a problem with LightDM when Antergos loads. All I get is a white screen, no background image, username, nothing. The only thing I can see is the mouse pointer. If I move the pointer it changes depending on where I hover over. If I wait until the mouse pointer changes to a pointing finger and I click on it, I get to see everything? Any ideas?

  • Hmm…sounds like a graphics driver issue. What graphics stack does your system have (Intel/AMD/NVIDIA) also which drivers are you using?

  • Hi lots.0.logs, sorry I should have said in my post that I’m currently evaluating it in VirtualBox. I’ve tried installing the guest additions but it says that they are already installed. Once I log in though, it’s fine.

  • Did you enable vboxservice with systemd?: sudo systemctl enable vboxservice

  • @lots.0.logs I encounter this problem too just after I updated Gnome to 3.16 and then restart, but in real machine. I tried to use Ctrl+Alt+F1 to login through tty so that I can manually express the command to identify the problem, but the shortcut did not work. My graphics card is Intel Mobile GM965/GL960 Integrated Graphics.

  • @Zheng-Xuan-Ho

    Try CTRL+ALT+F2

    Cheers!

  • @lots.0.logs Just tried that and it makes no difference :(

    I did a pacman -Syu today to see if there was an update or something and it updated me to Gnome 3.16 and now my mouse pointer has gone within Gnome itself. I’ve tried to manually reinstall the default gnome icon theme, but still no joy. I’ve googled and found an article saying to use dconf editor to set org/gnome/settings-daemon/plugins/cursor/active to false, but dconf editor says there is no scheme for org/gnome/settings-daemon/plugins/cursor/active?

  • @Ambleston-Dack said:

    @lots.0.logs Just tried that and it makes no difference :(

    I did a pacman -Syu today to see if there was an update or something and it updated me to Gnome 3.16 and now my mouse pointer has gone within Gnome itself. I’ve tried to manually reinstall the default gnome icon theme, but still no joy. I’ve googled and found an article saying to use dconf editor to set org/gnome/settings-daemon/plugins/cursor/active to false, but dconf editor says there is no scheme for org/gnome/settings-daemon/plugins/cursor/active?

    This should resolve your issue: https://wiki.archlinux.org/index.php/VMware/Installing_Arch_as_a_guest#Xorg_configuration

  • I had the same problem on an Acer C720 after the latest batch of updates. Ended up reverting to a previous backup I had since I couldn’t get past the blank white screen. Not sure what to do to be able to install the updates and have a working system. Any help would be greatly appreciated. Thank you.

  • May be time to abandon Lightdm in Gnome and use default GDM ??
    sudo systemctl disable lightdm
    sudo pacman -S gdm
    sudo systemctl enable gdm

    Intel NUC D54250WYK, 16 Gb RAM, 1 Tb SSD
    Multi -boot (no MS-Win &no UEFI) Legacy MBR with GPT

  • @lots.0.logs OK. I’ll give that a go and see if it will resolve my issues :)

  • @ant77 Already tried that and I had no mouse pointer on GDM, so I reverted back to LightDM.

  • @karasu I actually already tried Ctrl+Alt+(F1~F7), but none of them works.

  • Same problem with a fresh install on an Acer Aspire One. Also had the problem with a VirtualBox install. lxdm works.

  • @lots.0.logs said:

    @Ambleston-Dack said:

    @lots.0.logs Just tried that and it makes no difference :(

    I did a pacman -Syu today to see if there was an update or something and it updated me to Gnome 3.16 and now my mouse pointer has gone within Gnome itself. I’ve tried to manually reinstall the default gnome icon theme, but still no joy. I’ve googled and found an article saying to use dconf editor to set org/gnome/settings-daemon/plugins/cursor/active to false, but dconf editor says there is no scheme for org/gnome/settings-daemon/plugins/cursor/active?

    This should resolve your issue: https://wiki.archlinux.org/index.php/VMware/Installing_Arch_as_a_guest#Xorg_configuration

    Tried that suggestion and nothing changed. Ah well, I’ve played enough with it in a VM to know that I’m going to blitz my spare box and install it on that with real hardware. Thanks for the help lots.0.logs

  • @ant77 Hey thanks! This worked for me. :+1: :smile:

  • @ant77 Using GDM worked for me too. Thanks for the suggestion.

  • I was trying to complete a succesful install since the gnome 3.16 was released, my most recent try was on last night installing with Cnchi 0.8.64, I still have the white screen instead of the lightdm screen.
    My logs:
    lightdm
    Xorg.0
    Cnchi
    I’m installing directly on my hd for an hp netbook.

    Thanks for the help.

  • @eliko There is a bug in Virtualbox related to its vboxvideo kernel module that is causing the lightdm webkit greeter to malfunction. I’m afraid there’s not much that can be done besides use an alternative until a fix it released by the vbox devs. Sorry!

  • @lots.0.logs I think the bug relates to more than just virtualbox – as I said, I got a white screen on my Aspire One.

lightdm96 Posts 23Views 22179
Log in to reply