• Help for a clean install on a Laptop with SSD & HDD


    Hello. I need help installing Antergos on my Acer Laptop that has a 24G SSD & 500G HDD.
    I’m close to noob and not that knowledgeable with partitions and linux setup. I’ve read other threads here and i think i may have similar problems but not sure.
    Was Windows on it then installed Ubuntu automatically over it in the SSD. I was later told its better that i install /home on the HDD for storage purposes. I’d rather start all over and install Antergos. I tried the Cnchi manually a few times and i think i screwed up the partitions. I finally tried the automatic installation on the HDD and still doesnt work. it basically freezes up at start & just get “grub>” or cant find grub or kernel…
    I’ve listed the Cnchi partition screen below. The laptop is currently on Legacy setting but there is UEFI too. Appreciate any help, thanks!

    sda 500G
    sda1 ext4 254M
    sda2 ext4 antergos swap 7G
    sda3 ext4 antergos root 29G
    sda4 ext4 antergos home 461G

    sdb 24G
    sdb1 ext4 1M
    sdb2 ext4 21G
    free space 2G

    Use device below for boot loader installation (currently on the HDD)

  • Hi,

    There’s not a better way or only way to do this, I’ll just show what I would do if I wanted to keep things uncomplicated.

    I’m assuming you’re using GPT, but if you want to use MBR it would not change this layout.

    What I would do:

    sda 500G
    sda1 498G ext4 /home
    sda2 2G swap

    sdb 24G
    sdb1 256M ext4 /boot
    sdb2 23G (well, the rest) ext4 / (root)

    You should install the GRUB(2) bootloader in /dev/sda.

    It’s strange that your ssd is sdb instead of sda, though… I’m not very familiar with laptops.

    P.S. There’s people that recommend installing /var in a non SSD disk. I tested both approaches and didn’t find any substantial differences, so that’s why I do not setup a different /var partition.

    EDIT: Sorry! You must not create your swap partition in a SSD disk… what was I thinking?

  • Sorry! You must not create your swap partition in a SSD disk… what was I thinking?

    Why would you not put swap on the SSD? Of course you never want your system to have to use swap, but if ever it needs to, it will be a lot more effective on the SSD than it would on the HDD. I know some may say that there’s concern for wear/tear on the SSD. Though based on all of the information I’ve read on the subject of SSD durability and my own personal experience, there’s no need for concern. :smile:

  • "I know some may say that there’s concern for wear/tear on the SSD. "
    I’m one of them! :grin:

    No, seriously, I’ve read many reports that you have to avoid a lot of writings/erasings in a SSD… but hey, I’m not an expert :grinning:

  • but hey, I’m not an expert

    Same goes for me! This was more a concern a few years ago when SSDs were just beginning to become common. The information I found today shows that you will probably buy a new computer before enough time passes for the ssd to reach EOL. That’s even under write-heavy use. Check this article out if your interested:

    http://techreport.com/review/27436/the-ssd-endurance-experiment-two-freaking-petabytes

    Cheers!

  • Thanks for your replies!
    So i tried the suggested setup 3 times and the Cnchi installer always freezes near the end of the setting up process saying “Error” the installer cannot continue. There is no choices but to redo from the beginning. I finally tried an Automatic install on the HDD and that worked. the SSD is left alone and not mounted. Curiously the installer adds a 8G swap on the HDD.
    Is there any way i could fix this and put the / & /Home back on the SSD?

  • Hmm…We would need to see the installer log to know what is preventing the installs from completing. It is technically possible to move your root and home to the SSD. HOwever, it’s a very involved process. I would recommend reinstalling. Though if it fails to complete, grab the logs located in /tmp before you exit the live session. and post them here.

    Best Regards,
    Dustin

  • So i tried reinstalling. The same thing happens after around 1 minute into installation.
    Antergos Installer - Error
    [Errno2} No such file or directory:’/installer/etc/sudoers.d/10-installer’

    When i then try over again i notice that the re-partitioning almost worked but it did not create the /(root) in sdb.

    Any suggestions would be great. Thanks!

hdd6 laptop35 ssd21 Posts 8Views 3584
Log in to reply