• Keyboard issue :Solved


    So I installed antergos with openbox. But I dont got the swedish character as I supposed to have on my keyboard… If I go in to /etc/locale.gen
    I got everything whit the swedish things unhashed as it should and if I print
    localectl status I got System Locale: LANG=sv_SE.UTF-8
    VC Keymap: sv-latin1-nodeadkeys
    X11 Layout: sv-latin1-nodeadkeys
    . Dont know what to do next…

  • Hi,

    It works in the console? (not in a terminal inside Xorg but outside, in another console)… and which DE are you using?

  • Nope … doesent work at all… not in lx terminal . not in chromium etc etc. I guess I have us keyboard because the charcters works whit the picture of us keyboard from google… DE? I guess you mean openbox here?

  • Hi,

    In lxterminal, writing setxkbmap se fixes the issue?

  • Yes it did. Thank you!! But what did I actually do?

  • Hi,

    Hey, I think it’s not really solved. When you restart it will be back again to en-US, I’m afraid.

    You have to setup your xorg to use SE keyboard layout… tell me if restarting makes en-US come back and we’ll try to setup it.

  • yepp you where right… back to us

  • Ok, that confirms that Xorg setup is wrong. You have to create a text file (or edit it if you already have one).

    It should be /etc/X11/xorg.conf.d/10-keyboard.conf (old versions of Cnchi named it 00-keyboard.conf, if that is your case rename it to 10-keyboard.conf)

    That file should contain the definition of your keyboard layout. Something like:

    Section "InputClass"
            Identifier "system-keyboard"
            MatchIsKeyboard "on"
            Option "XkbLayout" "se"
            Option "XkbModel" "pc105"
    EndSection
    

    Tell me if you have any problems editing that file.

  • ok now I have edit the file and renamed it to 10-keyboard.conf from 00-keyboard.conf …I did test a reboot again and that did not do the trick

  • Hi,

    Let’s try another thing, you said you’re running openbox, don’t you? Well, you can do a dirty hack, edit your .xinitrc file (it’s in your home directory), and add this line before calling openbox:
    setxkbmap se &
    This will make your system run that line before running the openbox window manager.

  • #!/bin/sh

    if [ -d /etc/X11/xinit/xinitrc.d ]; then
    for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x “$f” ] && . "$f"
    done
    unset f
    fi

    export GTK2_RC_FILES="$HOME/.gtkrc-2.0"

    exec dbus-launch --exit-with-session openbox-session

    so between the line export gtk2 and exec dbus launch ?

  • Ups, sorry, no, it’s not that file!

    Its in the /home/user/.config/openbox (replace user for your username and note the starting dot in .config) directory, and the file is called autostart.

    Something like /home/snoken/.config/openbox/autostart

    That file starts all your programs (it’s run by openbox-session).

    Just add the line at the end and do not forget the trailing &
    setxkbmap se &

    Sorry for the confusion.

  • Yepp that worked! did a restart and still got the right layout! thank you for the help and your patience 🙂

  • @snoken Glad we solved it!
    Cheers!

  • This post is deleted!
  • For me the same prob but i run gnome and setxkbmap se works in term but I want it to remain the setting after reboot/ ivar

  • @iwar
    You have to setup your keyboard in gnome-settings. Search the forum, I’m sure you’re not the first with problems changing the keyboard layout in Gnome.

  • Yes thats right i found it and have seen it before but did not understand how to use it
    I thougt i try another swedish layout and it worked and now i understand the tech .better!
    thankyou for youre time/ iW

  • @iwar
    You’re welcome! I’m glad I could help.

    Cheers!

  • @karasu said:

    Ups, sorry, no, it’s not that file!

    Its in the /home/user/.config/openbox (replace user for your username and note the starting dot in .config) directory, and the file is called autostart.

    Something like /home/snoken/.config/openbox/autostart

    That file starts all your programs (it’s run by openbox-session).

    Just add the line at the end and do not forget the trailing &
    setxkbmap se &

    Sorry for the confusion.

Posts 24Views 7634
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.