• Recover from Hibernation


    I tried hibernating my laptop for the first time today. Running Cinnamon, if it matters. I went into power settings and marked the option to hibernate if the lid was closed. Looks like it hibernated just fine. But when I reopened the lid, I got the Antergos boot screen, followed by a black screen with a cursor that just sat for about ten minutes before I finally just held the power button and restarted. It came back up as normal, but it’d be cool if hibernation worked properly. I have no clue where to even being troubleshooting. Systemd log files are attached and any help is greatly appreciated.

    Thankslogs.tar

  • In each of the three boots for which you grabbed the logs, there is no indication that a hibernated session was detected. Did you grab the logs immediately after the hard reboot (when it was stuck at the black screen)?

  • Check your grub setup, you have to tell the kernel which is your swap partition (used to store the current state before hibernation).

    See: https://wiki.archlinux.org/index.php/Suspend_and_hibernate#Hibernation

    P.S. : Sorry if you already knew all this…

  • @karasu That’s useful information indeed. I was operating under the assumption that he installed using Cnchi which would have taken care of adding the resume partition to the default grub file. Though now it occurs to me that there can be cases where Cnchi didn’t take care of it (b/c it didn’t set up bootloader) :stuck_out_tongue_winking_eye:

  • @karasu said:

    Check your grub setup, you have to tell the kernel which is your swap partition (used to store the current state before hibernation).

    See: https://wiki.archlinux.org/index.php/Suspend_and_hibernate#Hibernation

    P.S. : Sorry if you already knew all this…

    Nope, I didn’ know this, and even if I did, that information may be helpful for others.

    As for when I gathered the logs, it was after forcing a shutdown and restarting. I couldn’t get to a TTY or anything when I first tried to resume, it just locked up. I’ll read that article and try to do what it says, then try again.

    Thanks

  • @lots.0.logs I did install using Cnchi. Did I miss some step in setup or something? Or did we spot a possible bug in the installer?

    Here’s a copy of my current, untouched GRUB configuration:

    GRUB_DEFAULT=0
    GRUB_TIMEOUT=5
    GRUB_DISTRIBUTOR=Antergos
    GRUB_CMDLINE_LINUX_DEFAULT="resume=UUID=2a1664fe-e987-4d89-b87b-a5950e08bffd quiet"
    GRUB_CMDLINE_LINUX=""
    
    # Preload both GPT and MBR modules so that they are not missed
    GRUB_PRELOAD_MODULES="part_gpt part_msdos"
    
    # Uncomment to enable Hidden Menu, and optionally hide the timeout count
    #GRUB_HIDDEN_TIMEOUT=5
    #GRUB_HIDDEN_TIMEOUT_QUIET=true
    
    # Uncomment to use basic console
    GRUB_TERMINAL_INPUT=console
    
    # Uncomment to disable graphical terminal
    #GRUB_TERMINAL_OUTPUT=console
    
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    GRUB_GFXMODE=auto
    
    # Uncomment to allow the kernel use the same resolution used by grub
    GRUB_GFXPAYLOAD_LINUX=keep
    
    # Uncomment if you want GRUB to pass to the Linux kernel the old parameter
    # format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
    #GRUB_DISABLE_LINUX_UUID=true
    
    # Uncomment to disable generation of recovery mode menu entries
    GRUB_DISABLE_RECOVERY=true
    
    # Uncomment and set to the desired menu colors.  Used by normal and wallpaper
    # modes only.  Entries specified as foreground/background.
    #GRUB_COLOR_NORMAL="light-blue/black"
    #GRUB_COLOR_HIGHLIGHT="light-cyan/blue"
    
    # Uncomment one of them for the gfx desired, a image background or a gfxtheme
    #GRUB_BACKGROUND="/path/to/wallpaper"
    GRUB_THEME="/boot/grub/themes/Antergos-Default/theme.txt"
    
    # Uncomment to get a beep at GRUB start
    #GRUB_INIT_TUNE="480 440 1"
    
    #GRUB_SAVEDEFAULT="true"
    
  • I think I may require some more hand holding on this one, if you don’t mind. I do already have a resume line declared in my grub config. I also verified that the UUID matches what is reported in fstab.

    What else can I check?

    Thanks,

  • Hi,

    Now comes to mind /etc/mkinitcpio.conf, check that in the HOOKS line you have the resume hook. Oh, and it MUST go after the udev one.

    After editing that file, you must issue an:
    sudo mkinitcpio -p linux
    and reboot!

    Hope this helps.

  • @karasu said:

    Hi,

    Now comes to mind /etc/mkinitcpio.conf, check that in the HOOKS line you have the resume hook. Oh, and it MUST go after the udev one.

    After editing that file, you must issue an:
    sudo mkinitcpio -p linux
    and reboot!

    Hope this helps.

    Mine line reads as follows:

    HOOKS=“base udev autodetect modconf block keyboard keymap lvm2 resume filesystems fsck”

    I have not edited anything.

  • Hey, could you try and grab the logs again after it hangs trying to resume? Also, try removing quiet from the kernel boot command (press e when grub starts). That might allow you to see more output before the hang.

  • Just wanted to resurrect this thread. I was contacted by another user with the same issue.

    Since this thread, I have upgraded my laptop with a solid state drive, and while suspend works just fine, Hibernate still produces the same result, even after a fresh install of the latest, which I did last week.

    Any further words of wisdom on the topic?

Posts 11Views 2695
Log in to reply