• No Bootable Media


    Hello,
    I am currently trying to install Antergos as the only Distribution on my Machine. Up until now i used Ubuntu 14.10 and 15.04 beta with much success on this machine, but i want to start learning Arch. However, the installation never leaves me with a bootable drive, inspite of no error messages during or after the installation. To me, this feels similar to the problem described here http://forum.antergos.com/topic/1810/not-a-valid-boot-medium , but i can’t know that for sure.

    My Machine is a http://www.acer.de/ac/de/DE/content/professional-model/NX.VA1EG.002
    The BIOS is set to UEFI boot only with secure boot enabled (i just assumed Antergos could handle this, since older Ubuntu installers can too, however, i didn’t have any luck with secureboot disabled either)

    On my last installation attempt i did the following things:
    I used a USB-Drive with the current minimal antergos iso written to it.
    I booted Antergos-Minimal from the USB Drive.
    I waited for Cnchi to update over my wired connection and restart itself. (0.6.53)
    As suggested in the other thread, i switched to console (ctrl-alt-f2), logged in as root and ran "sudo modprobe -a efivarfs"
    I switched back to the Desktop (crtl-alt-f1) and continued the cinchi installation.
    I chose to use the whole disk with encryption and LVM (in previous attempts i tried without lvm and encryption, but it failed too)
    I made sure the correct drive was selected during the encryption password step.
    After the installation finished i chose not to reboot immediately and copied the /tmp folder to an external drive first. (to get the logs)
    Rebooting the device yields a message saying there is “No bootable Media” present.
    I booted another live-instance to copy the contents of the boot partition to an external drive . (to get the grub.cfg)

    I will attach the cnchi.log and the grub.cfg . If you need anything else, please ask!

    cnchi.log
    grub.cfg

  • Hi,

    First, Secure Boot is not supported with Antergos/Arch. It should always be disabled. That’s important to note for any future attempts that you make. The log indicates that you had not booted using UEFI. Are you certain you were in UEFI mode? Which bootloader did you see when booting, was it text based or graphical?

  • I attempted another install:
    I tried again with secureboot disabled but left UEFI mode on, see picture. https://dl.dropboxusercontent.com/u/20021473/antergos/bios.jpg
    I am not sure which bootloader is which, so i took another picture.
    https://dl.dropboxusercontent.com/u/20021473/antergos/boot.jpg
    I used the modprobe command from ealier, see pciture. https://dl.dropboxusercontent.com/u/20021473/antergos/modprobe.jpg
    However, i got an error during installation, see picture (again :) ). https://dl.dropboxusercontent.com/u/20021473/antergos/error.jpg

    I grabed the /tmp folder before rebooting, just to be safe.
    cnchi.log

    Thanks for your effort!

  • Hi,

    There was an issue with one of the packages in our repo that caused the installer to fail. I think you tried to install during the time that. It has since been resolved. Your install should be okay now. Let me know how it goes :smile:

  • Well, sadly it didn’t work, but atleast the previous package error is indeed gone.

    After installing again with Secureboot disabled, “modprobe -a efivarfs”, whole HDD usage with LVM and encryption i got a “no bootable media” after the post-install reboot. I made sure to grab /tmp and the contents of the partition containing grub.cfg.

    cnchi.log
    grub.cfg

    If you need any additional information about the hardware, or anything else, please don’t hesitate to ask.
    I really appreciate your help.

  • Hmm…Still appears that its not booting into UEFI mode properly. I know that some Acer systems don’t work with Arch’s ISO media. It seems like you may have one of those systems. Have you updated your BIOS to the latest version available here:

    http://us.acer.com/ac/en/US/content/drivers/5328;-;TravelMate B115-M

    If that doesnt help, does it have an option to use legacy BIOS boot? That might be the only option at this point. Sorry!

  • Oh well, what a shame. I had really high hopes this would be working in UEFI, since older Ubuntu releases worked so well on this laptop :/
    The BIOS is up-to-date and yes, there is a legacy boot option, but this causes very weird hardware behavior, especially for the Trackpad and usb3-port :(

    For which cnchi milestone should i look out to try again and more importantly: Is there anything I can provide to help things along? uefidump, dmidecode, god-knows-what :D

    Anyway, another big thank you for everything!

  • Unfortunately there’s not much we can do about the issue. It’s very low-level stuff, beyond our skillset I’m afraid. Sorry! Perhaps it will be resolved in a future kernel version. fingers-crossed

  • Update!

    I didn’t believe it was Kernel stuff, so i kept trying with the new cnchi version. (Would be really odd, ubuntu works in UEFI on this machine since at least kernel 3.16 after all… )

    And i have found a way to install Antergos!

    First of all, the completly automatic solution shown here still doesn’t work Screenshot from 2015-04-18 01-29-21.png Neither GRUB2 nor gummiboot give working bootloader using this method. Just that bootloader warning at the end and an unbootable system after restarting.

    However, using the advanced installation mode shown here works! Screenshot from 2015-04-18 01-31-21.png
    If i kept the setup as simple as shown (GPT was used for partition table), the installation would finish without a warning or error (here, i only tested gummiboot though). The system would then be bootable as expected (ofcourse still in UEFI-only mode) after the restart. Yay!
    Choosing an luks encryption for the root partition installs a working bootloader, but gives wrong paths inside the loader.conf and a luks mounting error i couldn’t solve on my own, so i’ll stick nonencrypted for now.

    I hope this information helps fixing cnchi and anyone else trying to install antergos.

    Update 2: After the 0.8.48 update the advanced installation fails again, for gummiboot and grub :/ I just wanted to quickly test some of the alternatives to gnome, should have kept the installation while it worked :) Oh well

    Update 3: 0.8.48 broke the advanced install, but the automatic install is working now, at least for grub, not for gummiboot… weird.

uefi35 cnchi 0.6.531 Posts 9Views 2743
Log in to reply