• Antergos, Windows 8.1 and weird boot up problem


    This is a really strange problem, and is intermittent, so I’m finding it had to work out what’s going on. Firstly, the issue is not specifically to do with Antergos. It happens with Manjaro too, and I suspect will happen under all Linux systems.

    I currently have two hard drives – a 3 TB drive I use for storage, and a 2TB drive I use for Windows 8.1, Antergos and storage. The issue is, sometimes Antergos fails on bootup, and it happens exclusively when I’ve just booted into Windows. What happens is that my external drive partitions fail to mount. and I get a string of messages along the lines of…

    [FAILED] failed to mount /media/audiobooks
    See "systemctl status media-audiomount for details
    [9.385045] system[1]: failed to mount /media/audiobooks

    This is just a small example of what goes wrong. Every partition on my secondary drive fails to mount, and I’m no sure how to get more information. ‘systemctl -xb’ works from the command line post-failure when I’m stuck at the command prompt – the X Server always fails to start – but I’m not sure how to dump all that information into a text file in order to save it and post it here.

    All I have to do to fix the issue is to boot Windows 8.1 as far as the log-in screen, restart, and Antergos loads perfectly and will do again until I use Windows again.

    Now, I rarely use Windows. I didn’t use it for three months recently and the problem never occurred. This past week I’ve had to use Windows every day, and the problem’s happened a few times. It doesn’t happen every time, and I’m tempted to say that the problem is somehow to do with Windows Updates. The issue seems to occur either before I install Windows Updates or immediately after. It doesn’t happen every time I use Windows, but every time it does happen I’ve either just installed some Windows updates, or Windows is informing me that I need to install some updates. Might be a wild coincidence… might not.

    Again, to stop the problem, all I have to do is boot Windows as far as log-in, restart, boot into Antergos and the problem’s fixed.

    Can anyone advise me what might be the issue here, or give me a few ideas on how to view the logs of a previous bootup failure, or progress with the issue? I’m not sure whether it’s relevant, but I have a non-UEFI motherboard, all the drives were formatted using msdos (as opposed to GPT), but all partitions are much smaller than 2 TB in size.

    Many thanks.

  • What type of filesystem is used for the partitions that fail to mount. Also, what’s the output of systemctl status -l media-audiomount after a failure occurs?

  • All mounted partitions are NTFS. Obviously, systemctl status -l media-audiomount will work after a failure from the command prompt, but have you any idea how I can dump the information into a text file so I can examine it after a successful boot and post it here later?

    As the issue is intermittent, and only seems to happen after I update Windows, it may be a while before it happens again. I’ll post in this thread when it does.

    Thanks.

  • This post is deleted!
  • It sounds like Windows Update is in some way locking your bootloader during updates. I’ve never heard of it happening before but perhaps a quick web search will find similar reports?

  • Finally some information. This morning I tried to boot Antergos and got the usual fail message. I typed in ‘systemctl status -l media-Encrypted.mount’ and it threw out the following. (I typed it all out by hand, so there may be the odd mistake, but the bulk of it should be reasonably accurate.)

    • Media-Encrypted.mount - /media/Encrypted
      Loaded: loaded (/etc/fstab)
      Active: failed (Result: exit-code) since Tue 2015-04-07 12:07:05 BST; 5min ago
      Where: /media/Encrypted
      What: /dev/disk/by-uuid/241C35C9BBBEED8
      Docs: man:fstab(5)
      man:systemd-fstab-generator(8)
      Process: 307 ExecMount=/bin/mount -n /dev/disk/by-uuid/241C35C93BBBEED8 /media/Encrypted -t ntfs-3G -o defaults,locale=en_GB.UTF-8 (code=exited, status=14)
      Apr 07 12:07:06 melchizedek mount [307] : The disk contains an unclean file system (0,0)
      Apr 07 12:07:06 melchizedek mount [307] : Metadata kept in Windows cache, refused to mount
      Apr 07 12:07:06 melchizedek mount [307] : Failed to mount ‘/dev/sdb7’ : Operation not permitted
      Apr 07 12:07:06 melchizedek mount [307] : The NTFS partition is in an unsafe state. Please resume and shutdown
      Apr 07 12:07:06 melchizedek mount [307] : Windows fully (no hibernation or fast restarting), or mount the volume
      Apr 07 12:07:06 melchizedek mount [307] : read-only with the ‘to’ mount option

    So I restarted, booted into Windows, completed the update which was waiting for me, rebooted into Antergos and all is fine. This only seems to occur when there’s a Windows update needing installation or in the process of installation. I think you might be right about Windows Update somehow locking me out. I’ll do a Google search for a solution. An obvious shot term fix might be to disable Windows auto-updater and just do manual checks from time to time.

    If you wouldn’t mind checking the above error message and confirming that nothing else seems amiss, I’d really appreciate it.

    Many thanks.

  • After a bit of Googling around (well StartPaging, but you know what I mean), the issue seems to be with how Windows 8.0/8.1 shuts down. Instead of shutting down completely, it instead removes all user data but keeps the kernel data in hibernation mode, thus locking all partitions. Why this happens in my case only when Windows has to update, I have no idea. I think I’m going to continue with manually updating Windows and see whether that helps.

    If it doesn’t, the fix is to apparently turn off Windows Fastboot. I’m going to post how to do that below in case anyone else encounters a similar problem. (Also so I can reference it if it happens to me again.)

    1. Open Control Panel and click on Power Options.
    2. Click on Choose what the power buttons do.
    3. Click on Change currently available settings.
    4. Untick Turn On Fast Startup (recommended).

    If there’s anything else wrong in the error message I posted above, I’d still like to know. If not, I’ll continue as I’ve outlined, and report back my findings, and hopefully mark the thread as solved.

windows 8.1 a1 Posts 7Views 1674
Log in to reply