• [Solved]Cannot boot into Antergos after doing a Windows install.


    As the title suggest, I can no longer access the Antergos partition on my SSD. My laptop is an Asus x202e and it came with Windows 8 pre-installed. About 1 year ago I removed Windows in favor of Linux. Last night I decided that I would give Windows 10 a try.

    I first created a GPT partition table(Windows 8.1 will not install without it). I went to the installer and did the following:

    1. Create a boot partition and formatted it to FAT32.
    2. Created a root partition and formatted it to EXT4.

    I gave Antergos the larger partition on the SSD because I want Linux as my primary OS for various reasons. I continued with the installation and when it was finished I could boot into Antergos without issue.

    Next, I inserted the Windows USB installation media. I installed Windows 8.1 and then upgraded to Windows 10 immediately. I tried to use EasyBCD to help me boot into Antergos but it doesn’t work. EasyBCD does not support efi boot partitions at the moment.

    What I don’t think the problem is:

    1. Windows 10 - It’s not Windows 10 because I have the same dual boot setup on my other laptop. Antergos is on a larger partition and Windows 10 is on a smaller one. However that Antergos installation was from since 2014,which has an EXT2 or EXT4(can’t remember) boot partition and not a efi FAT32 boot partition. As such EasyBCD easily recognizes it and I can boot into the Antergos grub.
      Secure boot - Secure boot and fast boot are both disabled. In fact, that is the only way I can install boot from a liveUSB.

    I’ve tried creating a live Antergos USB from an old ISO image that I had but the install refuses to let me go any further with the installation if my boot partition isn’t formatted to FAT32.

    I really, really need to get this to work! I am learning programming and using Linux avoid all the yak shaving I would have to do on Windows. I also enjoy using Linux and the freedoms it give me to play around and tweak things, I choose an Arch based distro because of pacman and the AUR and I chose Antergos because it gives me access to Arch without the overhead.

    I also don’t want to visualize Window in a VM.

    Also, the only boot option available in the BIOS is the Windows Boot Manager created by the Antergos installer.

    TL;DR: Enable CSM or Legacy BIOS, disable secure boot, create MSDOS partition tables, boot into none-efi state of the liveUSB for Windows, install Windows, boot into the none-efi state of the Antergos Installer, install Antergos.

    Thank in advance for the help! I hope something could be done.

  • Try installing Windows first, and then installing Antergos. Linux has been designed to co-exists with Windows since its creation so it should work for you that way. Let us know the result.

    Cheers!

  • @lots.0.logs I was trying to avoid that. That’s going to take a while but I’ll try and I’ll report back. Is there any way I can install Antergos the old way? By that I mean create a non-EFI boot partition. I would love to create an EXT2 boot partition.

  • Not unless your system includes a method of booting the ISO using BIOS Boot. Some hardware included the option when UEFI was new though most new hardware only includes UEFI. With Cnchi v0.8 you will be able to decline bootloader installation when using advanced mode if that helps. We will be releasing it within the next few days.

  • @lots.0.logs It does help indeed! That is fantastic news. Especially with word of Microsoft no longer forcing OEMs to create a legacy bios option.

    I solved the issue

    I managed to get this working last night, although I still greatly appreciate the advice and help. I enabled CSM and inserted the liveUSB. I found out something by accident. The Asus firmware I have, I had to disable CSM, save and exit, return to the firmware menu, enable CSM and save and exit and return again. I am guessing it is a firmware bug. After I did that I then saw two instances of the Antergos live USB. One for a UEFI state and one for the legacy state.

    I selected the legacy state and was able to install Antergos without needing to create a EFI partition. Before all of this I opted to create MSDOS partition tables and installed Windows first. I installed Antergos after and everything works almost perfectly. I did run into one issue though. This might be completely anecdotal but I wasn’t able to update Windows 8.1 to Windows 10 while the GRUB boot loader had the boot flag on it. In 4 attempts I got error updates.

    Windows created a boot partition so I gave it the boot flag instead. On my first try after that the updates could be downloaded without error. It could just be a coincidence though. The strange thing is that a reboot takes me straight to grub, even though it no longer has the boot flag on it. But all is well now.

    Thanks for all the assistance! :)

windows105 windows8.14 boot165 Posts 5Views 3322
Log in to reply