• Can't make X use correct keyboardlayout on boot


    Hi guys

    After I’ve installed antergos on my Desktop computer & absolutely loving it, I’ve also intalled it on my Laptop.
    But I’ve had the same issue on both installations: Even after selecting the Swiss German keyboard layout in the graphical installer, X does not load the correct keyboard layout on boot. In the TTY the layout is fine, though.

    While I’ve managed to fix the issue on the desktop with little effort by modifying /etc/locale.conf, it’s not that easy on my laptop.

    What should be noted first is that X is perfectly capable of using the correct keyboard layout. I can set it after booting with the command ‘setxkbmap -layout ch’ and it works perfectly. But that setting does disapper as soon as i reboot, so that’s not the solution.

    I’ve also tried setting the keyboard layout using ‘localectl set-x11-keymap -layout ch’, which changes the /etc/X11/xorg.conf.d/00-keyboard.conf, but after all it still does not chose the right keyboard layout at boot. The current contents of the file are:

    # Read and parsed by systemd-localed. It's probably wise not to edit this file
    # manually too freely.
    Section "InputClass"
            Identifier "system-keyboard"
            MatchIsKeyboard "on"
            Option "XkbLayout" "ch"
    EndSection
    

    I’ve also tried some different configurations I’ve found in the wiki and other pages but none seemed to work for me.

    Any ideas?

    Thank you very much!

  • Which desktop did you install? Have you tried using the GUI controls provided by the desktop environment to configure your layout?

  • I’ve installed the Laptop with Gnome 3. Sadly, there wasn’t any GUI tool preinstalled for setting the keyboard layout, unlike in Cinnamon that has one in the settings. What’s strange: My previous system, Fedora 21, had one and also used Gnome 3. Isn’t this a standard tool of Gnome 3?

    Long story short: I couldn’t because there isn’t one :(

    Btw: Thank you lots.0.logs for your awesome work. I’m seriously impressed by your work in the forums & in development of Antergos! How do you get the time for that? :)

  • OH. MY. GOD. I was wrong! I did a Google Search for how to set the keyboard layout in Gnome 3, and found out that I have to klick on that that small tiny ninja link “input sources” in the keyboard settings. After setting the keyboard layout there, everythiIng works fine :D All those hours I’ve spent… Never mind, it works and that makes me happy now :)

    I’m just wondering what that tool does that I seemed to be unable to do. But I’ll find it out ;)

    One thing though: This seems to be some kind of bug of cnchi, that fails to set the chosen keyboard layout in gnome 3 (at least on some, or just my devices). This might be worth looking into further.

    Again: Thank you for all of this!!

  • Glad to see this is resolved :smile: We’ll look into it further to ensure its not a bug in cnchi. Thanks for reporting it!

  • the very same prob here i must set whith setxkbmap se
    in input sources i can read sverige i have a new install of antergos

keyboard-layout3 Posts 7Views 1769
Log in to reply