• [Solved] problem with gnome fresh install (need default LUKS "device-mapper name")


    Hi, I just did a fresh gnome install, but as soon as I get to the login I get a garbled screen beyond recognition :smile: , i think something wrong with the default video drivers. So I would like to try and install my nvidia-340xx drivers for my 8800gt by chrooting in it but, :worried: problem is that I did an install with encryption and I don’t know the default device-mapper name to unlock with cryptsetup before chrooting.
    Does any body know the default device-mapper name?
    Strange thing is that I don’t have this problem with a fresh kde install

  • The Root partition will be: /dev/mapper/cryptAntergos
    If you chose a separate /home then it will be: /dev/mapper/cryptAntergosHome

    You can boot into multi-user (non-graphical) mode and access the system journal to identify the problem. Add the following to the end of the kernel boot command (press e when grub appears):

    systemd.unit=multiuser.target
    

    You can access the logs from the previous boot attempt (not the one you are in currently as the problem would not have occurred yet at that stage):

    sudo journalctl -b 1
    

    Let us know what you find.

  • @lots.0.logs

    Hi,
    thanks for your reply, so I tried to boot again and I managed to get past the login (no messed up screen this time… …don’t know why) rendering was very sluggish, I got my journalctl output at that stage, but I don’t know what to look for:
    journalctl
    so then i finally installed my driver, rebooted, i did nvidia-xconfig and complained about:

    "Package xorg-server was not found in the pkg-config search path.
    Perhaps you should add the directory containing `xorg-server.pc’
    to the PKG_CONFIG_PATH environment variable
    No package ‘xorg-server’ found
    New X configuration file written to '/etc/X11/xorg.conf "

    so i installed xorg-server-devel and nvidia-xconfig again, things are better but still not ok still a bit sluggish when I move windows around but especially video playback is slow and the screen goes green occasionally, tried with and without VDPAU, still slow, here is my latest journalctl output, I know its a long list, if any one could tell me what to look for or has an idea of whats going on :smile: :

    journalctl2

    i really don’t want to go back to kde

    p.s. how do you embed long text in the post?

    thanks again

  • Your logs indicate that nouveau is being used (not the nvidia-made driver). Try installing the nvidia drivers using the following commands. It will say there is a conflict and ask if you wish to proceed (choose Yes).

    sudo pacman -Syyu
    sudo pacman -S  nvidia-340xx nvidia-340xx-libgl
    sudo pacman -Rs xf86-video-nouveau
    

    After that is done, go ahead and reboot and see the result. X should be able to handle things without a xorg.conf file. However, if you notice any issues then go ahead and run the nvidia -xconfig tool. Let me know the result. Cheers!

  • Hep, works perfectly now. thanks man :smile: , still get the flicking green screen with vlc but not with smplayer.

    thanks

  • Glad to see its resolved! :smile:

Posts 6Views 1477
Log in to reply