• Not a valid boot medium?


    Hello, I’ve tried installing Antergos multiple times, from different Antergos images as well. Every time, the installer reports no errors, and seems to work fine. When I boot up the computer, my monitor displays “No boot medium found, please insert valid boot device”, or something along those lines. If I installed Antergos to dual-boot with another Linux partition, then my computer just boots to the other partition, not Antergos.

    Any help with this? My motherboard is a Biostar TA75M, and my processor is the A8-8350.

  • Hmmm…That’s strange. If you could, please mount the installed Antergos Root and grab the installer log as well as the grub.cfg.

    /var/log/cnchi-INSTALL_DATE.log
    /boot/grub/grub.cfg
    
  • @lots.0.logs said:

    Hmmm…That’s strange. If you could, please mount the installed Antergos Root and grab the installer log as well as the grub.cfg.

    /var/log/cnchi-INSTALL_DATE.log
    /boot/grub/grub.cfg
    

    Hi, thanks for replying so quick. I’ve installed Antergos again, but it’s not looking so good. The log from /var is 0 bytes. Completely blank, and so is the “post-install” file next to it. Also, the /boot directory is also completely empty. Looks like everything else is fine for the most part. The Antergos partition is 5.8GB filled and all that, but there isn’t any of the stuff you asked for.

    Sorry I can’t give you a proper bug report or anything. This is really weird.

  • Hi,

    Did you choose automatic or advanced installation?
    If automatic, which options?
    If advanced, which partitions?

  • @karasu said:

    Hi,

    Did you choose automatic or advanced installation?
    If automatic, which options?
    If advanced, which partitions?

    Hello, I’ve chosen both on different occasions with the same result. The most recent one which I posted about in this thread was the advanced partitioning. I had a 500 MiB fat16 /boot, I believe. 2 GiB swap partition, and the rest as an ext4 root. Sorry, but I don’t remember the options when I did the automatic partitioning.

  • Hi,

    Do you recall which version of Cnchi did you use? In other words, did you give it time to update itself?

    It’s the first time we get a report like this, so something odd must be happening to you…

  • @karasu said:

    Hi,

    Do you recall which version of Cnchi did you use? In other words, did you give it time to update itself?

    It’s the first time we get a report like this, so something odd must be happening to you…

    Sorry, I don’t remember. I just waited each time, and then Cnchi ran itself.

    And yeah, it’s pretty weird. Maybe it has something to do with partition tables? After I installed it the last time, it botched my Fedora install, and I couldn’t reinstall Fedora until I wiped the drive and reinstalled a GPT partition table on the device. Might be related.

  • It sounds as though the post install tasks are not being completed. That is where cnchi installs grub and copies the logs from /tmp into the new installed system. we would need to see the logs to figure this out. If you make another attempt, grab the logs from /tmp before rebooting. If you don’t have time or don’t want to risk your other good installs, we certainly understand.

    Cheers!

  • @lots.0.logs said:

    It sounds as though the post install tasks are not being completed. That is where cnchi installs grub and copies the logs from /tmp into the new installed system. we would need to see the logs to figure this out. If you make another attempt, grab the logs from /tmp before rebooting. If you don’t have time or don’t want to risk your other good installs, we certainly understand.

    Cheers!

    That’s all good. It’s a pain to reinstall over and over again, but I’d like to try and help provide more information. It would be nice to be able to use Antergos properly too.

    I just might not be able to do it right now, but I can certainly try some other time.

  • No worries. Just let us know when you do! :smile:

  • @lots.0.logs said:

    No worries. Just let us know when you do! :smile:

    @karasu said:

    Hi,

    Do you recall which version of Cnchi did you use? In other words, did you give it time to update itself?

    It’s the first time we get a report like this, so something odd must be happening to you…

    Okay, some things changed so I had the time to reinstall again! The /boot/grub/grub.cfg file was present. Here are its contents.

    grub.cfg

    I can’t find a cnchi log file marked with the install date, but I assume that cnchi.log is the same, considering I haven’t restarted yet?

    cnchi.log

    I hope I’ve got the right information, I’ll stay on for a while before restarting, in case someone’s online right now. Also, this time I chose automatic partitioning to my 60GB SSD, because I couldn’t be bothered to manually set it up again. I didn’t change any options, just left them at the defaults.

  • Does your system support UEFI Boot or is it BIOS Boot only?

  • @lots.0.logs said:

    Does your system support UEFI Boot or is it BIOS Boot only?

    I would believe so, I chose “UEFI boot” for the Antergos Live CD, at the least.

    Here’s a link to my motherboard’s specs in case I’m not understanding something about UEFI, which might be the case.

  • Hmm…that’s strange. The log indicates that its missing a kernel module that should be automatically enabled when booting UEFI mode. Before performing the install, open a terminal and run this command:

    sudo modprobe -a efivarfs
    

    That should fix the error I found in the logs and hopefully the issue as well.

  • @lots.0.logs said:

    Hmm…that’s strange. The log indicates that its missing a kernel module that should be automatically enabled when booting UEFI mode. Before performing the install, open a terminal and run this command:

    sudo modprobe -a efivarfs
    

    That should fix the error I found in the logs and hopefully the issue as well.

    Tried to install again so I could do this. Unfortunately, I can’t access the terminal. This also occurred the last time. The terminal reports:
    “There was an error creating the child process for this terminal
    grantpt failed: Operation not permitted”

    I guess that’s an entirely separate problem, though. Will try it from the tty terminal thing by using Ctrl + Alt + F2.

    EDIT: Tried that, and the shell didn’t give me any errors or feedback. Restarted and the problem still persists. I think I’ll take a break for now.

  • “”“Tried to install again so I could do this. Unfortunately, I can’t access the terminal. This also occurred the last time. The terminal reports:
    “There was an error creating the child process for this terminal
    grantpt failed: Operation not permitted””"

    This is an issue that we fixed in 0.8 Cnchi (it will be released very soon), and as you guessed it has nothing to do with your issue.

    I’ll check your log asap.

  • Hi,

    There’s this error in your log:
    grub-probe: error: cannot find a GRUB drive for /dev/sdc1. Check your device.map.

    Why is your /boot fat32?

  • @karasu said:

    Hi,

    There’s this error in your log:
    grub-probe: error: cannot find a GRUB drive for /dev/sdc1. Check your device.map.

    Why is your /boot fat32?

    sdc1 was most likely the USB drive I used to install Antergos. Also, fat32 must have been used when I manually partitioned it. Same result for the automatic installer though.

    Also, it must be something with base Arch, rather than the installer. When using the EvoLution installer for Arch, I get exactly the same boot error that I get with Antergos. When installing Arch normally, slightly further than that, but still can’t boot properly (forgot the exact message, a bit longer than Antergos/EvoLution’s though). I guess I’d have to read some more on the Arch Wiki to even get a chance at using Arch or an Arch derivative.

    Thanks for your time though!

Posts 18Views 3985
Log in to reply