• \[SOLVED\] Can't boot after update


    Hello. I made a mistake after updating yesterday (with yaourt -Syu). grub2 was updated and a /boot/grub/grub.cfg.pacnew file was created. So, without thinking, I did what I’ve done for other packages for which I haven’t customized any configuration: I replaced the old grub.cfg with the pacnew file. Now when I boot grub apparently doesn’t know anything about my computer or where to look for a boot partition. Problem is, I don’t know anything about grub. So, I don’t know how to tell it. I see how you can edit the commands for each boot menu option (Antergos and Antergos with fallback kernel) and you can get to a grub> command line. But I haven’t been able to figure anything out from there.

  • Hello. I made a mistake after updating yesterday (with yaourt -Syu). grub2 was updated and a /boot/grub/grub.cfg.pacnew file was created. So, without thinking, I did what I’ve done for other packages for which I haven’t customized any configuration: I replaced the old grub.cfg with the pacnew file. Now when I boot grub apparently doesn’t know anything about my computer or where to look for a boot partition. Problem is, I don’t know anything about grub. So, I don’t know how to tell it. I see how you can edit the commands for each boot menu option (Antergos and Antergos with fallback kernel) and you can get to a grub> command line. But I haven’t been able to figure anything out from there.

  • So, I’ve figured out (after reading some instructions on the arch wiki) that vmlinux-linux and initramfs-linux.img are on my hd0,1 and all the folders that I normally see in my root directory are on hd0,3. So, I did the following commands:

    set root=(hd0,1)  
    linux /vmlinuz-linux root=/dev/sda3  
    initrd /initramfs-linux.img  
    boot
    

    And it booted!

    I then did

    sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    And it rebooted fine.

Posts 3Views 1618
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.