• I can't seem to disable Gnome on start-up


    I have used the “systemctl disable gdm” command, and it went through, but on reboot Gnome still starts up. On the Antergos start-up menu it says I can disable graphical boot by adding “systemd.unit=multi-user.target” to the kernel command line, but I have no idea on how to do this. Anyone willing to help a noob?

  • What is it exactly that you want to do? Are you trying to configure you system to always boot to the command line instead of the GUI?

  • @lots.0.logs
    Yes. I want the computer to boot into a command-line interface, or however you phrase that, instead of the GUI. If I wanted to, however, I would like to start the GUI from the command line

  • @Cereal_Junior Ok, you will need to disable the display manager;
    sudo systemctl disable gdm
    or
    sudo systemctl disable lightdm

    whichever you are using. Then reboot, you will be at a command line. To start your de or wm you can use startx. You will need to edit your xinitrc to start the de or wm you are wanting to start when you run startx. More information on that here:
    https://wiki.archlinux.org/index.php/Xinitrc

    gmail: [email protected]
    irc: [email protected]

  • @detrimental

    I’ve tried those commands exactly, but I still boot into gdm. The terminal gives me no error and continues like the command went through, but upon restart nothing has changed.

  • This should do it for you:

    sudo systemctl set-default -f multi-user.target
    

    Cheers!

  • @lots.0.logs
    and if I wanted to load gdm from the command line, would I type “sudo service gdm start”?

  • @lots.0.logs
    Okay, so I’ve done that and successfully stopped it from booting into gdm. Now how do I tell it to start gdm from the command line?

  • Antergos uses systemd (soon ubuntu/debian will also). You can start a service like this:

    sudo systemctl start gdm
    

    More info can be found here: https://wiki.archlinux.org/index.php/systemd

  • @lots.0.logs
    It worked! Thanks a bunch! I bet you can tell I’m a bit more used to Ubuntu :satisfied:

startup14 gnome229 disable12 boot163 start-up4 Posts 10Views 4020
Log in to reply