• seagate 3TB hard drive install failure


    HI All,

    I’ve tried partitioning this drive with GPARTED (using GPT boot partition) then ext4 file system (using both command line and gui installer. Most recently I’ve tried this using the full size regular live iso for 64 bit.

    Last night it took well over 45 minutes and did not finish (mounting the partition and formatting it).

    Never before has this step taken longer than a minute or two.

    DMESG produced this output when it wouldn’t mount and format the partition. But I don’t know how to read the output.

    http://pastebin.com/fCmZwQ5M

    I’ve no idea what to do, any help much appreciated.

    Ideally I would like to use the full 2.7 allowable terabytes of this drive as a single partition (since I bought it to finally sort out all the duplicate photos and files I have).

  • @Joshua-Serry it looks to me that your GPT partition table got corrupted.

    What I recommend you is to first wipe the disk using wipefs and then try again with cgdisk.

  • Karasu, thanks for your help and recommendation. I’ve never heard of those tools however.

    1. Are they available inside the antergos regular live iso already?

    2. Can you give me a primer on how to use them. I assume they are both command line tools?

    3. for my education - what would be the difference with using those tools as compared to gparted which I’ve been using for formatting/deleting/wiping partitions

    When I delete the partitions using gparted and then the disk becomes unallocated and grey hadsn’t this task effectively wiped the disk?

  • Hi @Yoshiserry

    1. Yes, they’re on the live ISO (in fact, they’re used by our installer when it does an “automatic” installation
    2. cgdisk has a sort of text ui. You have to use the cursor keys and it’s very straightforward (it’s not as easy to use as gparted, though). Wipefs is a command line tool, yes, you only have to run it this way:
      wipefs -a /dev/sda
      (if sda is the drive you want to wipe out)
    3. I think you can use Gparted instead of cgdisk without any issues at all. It’s just that I like it more because it gives me the feeling of more control. Also, cgdisk is a tool created specifically for GPT partitioning.

    When you delete the partitions, you just delete them, but you do not wipe the disk.

  • Karasu, I feel like I have fine something wrong here. First I used wipefs, then I used cdisk with o as in oh command and then w. Then I used cgdisk to create a small 1mb partition of type ef02. For the BIOS. And the remainder 2.7 tb was just 8300 Linux formatting the default value.

    Then I restarted it and I got further on in the terminal based installer to the point where it said it was completely finished I installed grub xfce and added users rather quickly actually as quick as I’ve ever done it. Which is why I suspect something is wrong.

    I then took out the live CD to restart only to find that grub says error attempt to read or write outside of disk hd0 entering rescue mode. Which confirms something is wrong.

    I’m going to try wiping with wipefs and then format with cgdisk again and I can’t figure out when I use the GUI installer after formatting how I can select to install on one of the partitions I.e sda1. Both the erase while disk install option and the one which let me pick advanced partitions would only let me choose SDA not a partition. And the adcanced one wouldn’t let me continue with the > arrow.

  • @Yoshiserry ,

    So you have a BIOS system and want to use GPT for your disk, right?

    Forget about cdisk or cfdisk, you should use cgdisk. It seems you forgot to create a swap partition, Linux needs one.

    Then, in advanced screen, you must tell Cnchi (the Antergos Installer) which partition must be mounted as root and which one will be the swap one. That’s it.

    If you want to read more:
    https://wiki.archlinux.org/index.php/partitioning
    http://www.linuxveda.com/2014/06/07/arch-linux-tutorial/2/

  • Thanks Karasu. I read both the ubuntu and the arch articles and interestingly the arch one towards the end said you don’t need a swap and so did the ubuntu. anyway with 2gb ram i chose to create a 4gb swap and a 32gb root partition, and a 1mb bios boot ef02 partition using cgdisk (after I had wiped the disk with wipefs and gdisk using o as in oh and w parameters.

    then in the advanced gui install where you select your own partition I reformatted three out of four of the partitions (leaving the bios boot one alone, as it was already formatted as ef02 bios boot and the installer didn’t provide that option.)

    Then I partitioned and formatted the root partition as ext4 root,
    the swap as swap partition, and also checked format box like before in this case
    lastly I formatted and labelled the remainder of the disk as data which is where all my media will go.

    Thanks very much for your patience and help.

  • @Yoshiserry ,

    Glad you worked it out.

    Just to clarify, having a swap partition is not mandatory, but it’s adviseable. It highly depends on the amount of RAM that you have at your disposal. However, if you don’t have a swap partition you will not be able to suspend to disk (hibernate) your computer.

    Cheers!

  • @karasu is absolutely correct. With only 2GB of RAM at your systems disposal, you definitely need some swap space!

  • Uh -Oh…
    Your post is making me a little nervous,
    I gotta 3TB Seagate sitting here on my desk, just arrived today. I really hope I don’t have any issues, but thanx for posting - if I do it’s good to know that I have this thread as a roadmap for its recovery.

install78 gpt6 ext45 dmesg1 64bit2 Posts 10Views 2446
Log in to reply