• Can't find kernel package to downgrade from 3.19.2-1


    Hi,
    after latest kernel upgrade my system won’t boot so I tried to downgrade the kernel but I’m unable to find the previous kernel package in:
    /var/cache/pacman/pkg

    What should I do?

    thanks

  • Resolved downloading the packages directly from:
    http://seblu.net/a/arm

    then starting from antergos live:

    1.connect to internet
    2.open terminal:

    su

    fdisk -l to locate your linux system partition (in this case sda3)

    mkdir /mnt/arch
    mount /dev/sda3 /mnt/arch

    if you have separated partitions for /boot /home etc… mount them too

    cd /mnt/arch
    mount -t proc proc proc/
    mount --rbind /sys sys/
    mount --rbind /dev dev/

    cp /etc/resolv.conf etc/resolv.conf

    test if connection to the internet works: ** ping -c 3 www.google.com**

    chroot /mnt/arch /bin/bash

    copy the downloaded pkg in /var/cache/pacman/pkg (the one in your arch installation - you’ll need root permissions)

    back to the terminal:

    cd /var/cache/pacman/pkg

    now you can proceed downgrading kernels packages, example:

    pacman -U linux-XXXX-x86_64.pkg.tar.xz linux-headers-XXXXX-x86_64.pkg.tar.xz virtualbox-host-modules-XXXX-x86_64.pkg.tar.xz


    By the way that didn’t work to get my system back, I even tried removing dropbox (cause it was cause of trouble in a couple of occasions) and virtualbox.

    Seems like I’ll have to do a fresh install and that’s really annoying…

  • This post is deleted!
  • I was not affected but thank you for posting how you solved ;)

  • Hope it will be usefull for someone else, as for me I sadly had to format :(

Posts 5Views 1357
Log in to reply