• [Solved] problem after update to kernel 3.19.2-1


    Hi guys, i just updated to 3.19.2-1 and on reboot when i need to enter my luks password, its like the keyboard input is dead no response, I can’t even ctrl+alt+canc. So now I i’m stuck with fallback.
    Any ideas are welcome…
    thanks

  • Hi,

    As a quick and dirty solution, you can downgrade to 3.19.1 easely. Just install the downgrade package from AUR, it’s very easy to use.

    Have you checked your /etc/mkinitcpio.conf file? Check that base, autodetect, modconf, block, keyboard, keymap, encrypt, lvm2, filesystems, fsck, are present in your HOOKS line. It is important that the encrypt hook comes before the filesystems hook.

    Well, post here your /etc/mkinitcpio.conf if you have any doubts.

    If you change this file remember to issue a sudo mkinitcpio -p linux afterwards.

    Cheers!

  • @karasu

    Hi Karasu,

    thanks for your reply, here are my hooks :
    HOOKS="base udev autodetect modconf block keyboard keymap encrypt lvm2 resume filesystems fsck"
    looks ok …i think?

    Here is a strange thing, I attached a ps/2 keyboard that I had around as well as my usual usb wifi keyboard, so when luks asks me the password I can enter it with the ps2 but not with the usb wifi one, but funny thing is when I login I have no problem with the usb-wifi keyboard and everything goes back to normal …:smile:
    any thoughts on this behavior?

    thanks again…

  • @Mandala
    Hi,
    Strange… the keymap module should take care of your usb keyboard… maybe being wifi is a problem here.

    Could you post here the result of lsmod | grep -i usb when using the wifi usb keyboard?

    Also, do not use a USB3 port for the usb stick (I know you don’t, but just in case…)

  • @karasu

    Hi, here is my lsmod | grep -i usb output, the keyboard is logitech:

    rt2800usb 26171 0
    rt2x00usb 17642 1 rt2800usb
    rt2800lib 85279 1 rt2800usb
    rt2x00lib 46262 3 rt2x00usb,rt2800lib,rt2800usb
    mac80211 648753 3 rt2x00lib,rt2x00usb,rt2800lib
    usbhid 48596 0
    hid 110513 4 hid_generic,usbhid,hid_logitech_dj,hid_logitech_hidpp
    usb_storage 60311 1 uas
    scsi_mod 147395 5 uas,usb_storage,libata,sd_mod,wd719x
    usbcore 199382 9 uas,rt2x00usb,usb_storage,ohci_hcd,ohci_pci,rt2800usb,ehci_hcd,ehci_pci,usbhid
    usb_common 12561 1 usbcore

  • @Mandala
    Hi,
    I do not have a wireless keyboard, so I’m not really sure, but you could try to add the modules hid_generic and usbhid to your MODULES line in mkinitcpio.conf and issue a sudo mkinitcpio -p linux
    If that does not work, try adding also hid_logitech_dj and hid_logitech_hidpp
    I’m just guessing that the kernel has not loaded your usb wireless keyboard modules when LUKS is waiting for your password.

  • @karasu

    Hi,
    So I added hd_generic and usbhid and it worked, all back to normal :smile:
    THANK YOU VERY MUCH…
    see you around…

Posts 7Views 2216
Log in to reply