• GRUB Not Properly Booting After Migrating Antergos to New SSD


    Hello, I recently moved my Btrfs Antergos partition, which I had dual booted with Windows 8, to a separate SSD so as to give it a bit more room to work with (So that Windows 8 is on the old SSD and Antergos is on the new one). Unfortunately I haven’t been able to get my system to boot properly since making the move. I used the arch-chroot command to open a chroot into my Btrfs partition from an Antergos install on an external hard disk, and I mounted my new /boot partition (formatted to GPT and set to work as a EFI system by gdisk), then I ran

    grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=grub_uefi --recheck
    
    grub-mkconfig -o /boot/grub/grub.cfg
    

    Which successfully executed. However when I tried to boot I got the default GRUB boot screen instead of the Antergos one, and the only partition listed was the Windows 8 partition, which in turn did not boot. What should I be doing differently? Here is my fdisk -l as seen from within the chroot:

    http://pastebin.com/3sEmWtdf

    Where the Windows 8 Partitions are on /dev/sda and the boot and Antergos (/) partitions are /dev/sdb1 and /dev/sdb2 respectively.

    My fstab is as follows

    http://pastebin.com/ewzHLsPd

    My /etc/grub is as follows

    http://pastebin.com/LDhvShBv

    Finally here is my lsblk -f executed outside the chroot so you can check out the UUIDs

    http://pastebin.com/MH8YJjZe

    Thanks for any help you can provide, I’ve been at this for hours without any luck.

  • @WiegrafFolles I was thinking that maybe because the chroot environment can’t see the UUIDs of the various partitions GRUB isn’t properly finding the drive targets. Could this be the problem?

  • Are you sure you’re booting from the right disk? That is, is it possible you did this on sdb but the machine is booting from sda?

dual-boot11 grub79 boot175 Posts 3Views 1495
Log in to reply