• CUPS 2.02 usa mucha CPU


    Hice una nueva instalación de KDE, como siempre un gran trabajo de Antergos, sólo tengo dos problemas:
    No puedo instalar mi impresora (Canon MP230), estos son los pasos que he dado:
    Primero los drivers de mi impresora link text AUR(en)-cnijifilter-mg3200 donde se edita para escoger, el nombre de la impresora y el driver.
    Segundo:
    systemctl disable cups.service
    Enabled cups and avahi
    systemctl enable avahi-daemon.service
    systemctl enable org.cups.cupsd.service
    systemctl start avahi-daemon.service
    systemctl start org.cups.cupsd.service
    Hasta ahí todo bien…CUPS si reconoce mi impresora:
    cups2.png
    Pero no la instala y el CPU se va por las nubes entre foomatic y cups consumen más del 60% del CPU y tengo que reiniciar. Antes de que reinstalara el sistema si funcionaba. Si lo hago a través de Preferencias Del Sistema este es el error que me da:
    cups1.png .

    El otro error que no logro arreglar es este:
    PREFERENCIA DEL SISTEMA–>ARRANQUE Y APAGADO–>CARGADOR DE ARRANQUE GRUB2
    grub2.png

    Como siempre, muchas gracias de antemano por su ayuda. Saludos

  • He seguido el hilo link text donde aconsejan modificar /etc/cups/client.conf, de esta manera:
    remove ServerName /run/cups/cups.sock and replace it with ServerName localhost:631
    También en este post link text que al igual que yo no reconoce la impresora unable to get list of printer drivers, aconsejan eliminar este file [cups-driverd] Bad driver information file “/usr/share/cups/model/foomatic-db-ppds/Kyocera/ReadMe.htm”!
    pero igual no funciona para mi, sigue cups y foomatic usando el 100% del CPU y además que no deja instalar la impresora aunque reconozca los drivers. Muchas gracias por su ayuda. Saludos

  • Hola,

    Has mirado qué te sale en el log del cups? (en /var/log/cups)

    Así, sin más, no tengo ni idea de que puede estar pasando, lo siento.

  • Hola Karasu, esto es lo que me sale en /var/log/cups/error_log (te mando una imagen que me sale error al querer poner todo el texto)
    error_post1.png
    E [04/Mar/2015:08:02:16 -0600] [Client 14] Returning HTTP Prohibido for CUPS-Get-Devices (no URI) from localhost es cuando cambie remove ServerName /run/cups/cups.sock and replace it with ServerName localhost:631 Después lo puse otra vez por defecto. Como siempre muchas gracias por tu ayuda.

    P.D. antes de la re-instalación, solo ponía el driver con yaourt AUR(en)-cnijifilter-mg3200, conectaba el USB y el sistema reconocía inmediatamente la impresora y lo hacía con preferencias del sistema.

  • Siguiendo los hilos del foro de Arch, uno de ellos expuso que tenía conflicto con foomatic-db, foomatic-db-nonfree, así que puse la siguiente instrucción la terminal pacman -Si cups-filters y efectivamente decía que había conflicto con este archivo y cups-filters, así pues desistalé estos dos archivos y reinicié. Coloque el usb de la impresora, KDE detecto mi impresora y finalmente se pudo instalar sin ningún tipo de inconveniente. El único problema es que siempre cups usa 50% del cpu y como se calienta, pero es un problema CUPS 2.0 que según los foros de Arch todos tienen, he aquí mi imagen:
    cups5.png
    Cualquier ayuda para resolver el excesivo consumo de CUPS muchas gracias. Saludos

grub224 cups14 Posts 5Views 2226
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.