• Power Management, Screen Dim, Something or Other


    I am a new Antergos user, and installed on my laptop two days ago. I chose Gnome as my DE because, hey, why not…

    Anyway, everything is working well but I am having difficultly witha couple of little things.

    I go to the power management settings in Gnome and I find that my screen is supposed to dim after 15 minutes of inactivity. It never happens, though.

    From what little bit I “think” I understand, this may be due to LightDM being used instead of GDM.

    Before I break something, what is the proper method to get screen dimming and automatic lock after a period on inactivity?

    Thanks,

  • Currently the only method for fully functional screen locking in GNOME is by using GDM. We are working on a solution to the problem. In the meantime you can switch to GDM using these commands:

    su
    systemctl disable lightdm
    pacman -Rc lightdm
    pacman -S gdm
    systemctl enable gdm
    
  • @lots.0.logs

    Are there any caveats for using GDM versus LightDM? I assume the default was changed for a reason. I can use the keypress for manual locking if using GDM will cause other “real” problems.

    Thanks

  • Hi,

    We use lightdm in all desktops (Gnome, Cinnamon, KDE, …) , this way the user always gets the same look’n’feel 😉

    You can use gdm if it works better for you.

    Cheers!

  • Just tested as I was having the same issue. GDM is working where LightDM was not.

  • That is the same issue I had. I installed the LTS Kernel but Power Management did not work correctly.

    Lightdm has borked more than one installation of Antergos…

  • I tried the command above listed by @lots.0.logs , and it left me without a login screen.

    I was able to log into terminal using Alt+Ctrl+F2 and revert it, but that was slightly scary 😉

    What was missing? Is there something more that should have installed?

    Thanks

  • @Myk-Robinson No, that should have worked for you. Was your system fully updated when you tried it? Try it again, but run this first:

    pacman -Syyu
    

    If GDM still fails, it could be a graphics driver issue. I would need to see the logs to determine the problem though.

Posts 8Views 2752
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.