• \[SOVED\] can not mount ntfs partitions in xfce


    i installed antergoes with gnome desktop. it works well and i can mount ntfs partitions by clicking on their name in nautilus. then i installed xfce4 and xfce4-goodies groups. the xfce4 desktop works well except that i can not mount ntfs partiions by clicking their icons neither on desktop nor in thunar. the error messsage is "Failed to mount “name_of_my_ntfs_partition”. Not authorized to perform operation"is there any other packages that should be installed?

  • i installed antergoes with gnome desktop. it works well and i can mount ntfs partitions by clicking on their name in nautilus. then i installed xfce4 and xfce4-goodies groups. the xfce4 desktop works well except that i can not mount ntfs partiions by clicking their icons neither on desktop nor in thunar. the error messsage is "Failed to mount “name_of_my_ntfs_partition”. Not authorized to perform operation"is there any other packages that should be installed?

  • Try adding the following line to your ~/xinitrc file and then restart your system. Let me know if it works!

    exec startxfce4
    
  • there is neither “xinitrc” not “.xinitrc” file in my home.

    [[email protected] ~]$ ls -la ~/xinit\* ~/.xinit\*  
    ls: cannot access /home/hadian/xinit\*: No such file or directory  
    ls: cannot access /home/hadian/.xinit\*: No such file or directory  
    
    

    there are 2 xinitrc file in the system. the first is /etc/X11/xinit/xinitrc and here is its contents:

    \#!/bin/sh  
      
    userresources=$HOME/.Xresources  
    usermodmap=$HOME/.Xmodmap  
    sysresources=/etc/X11/xinit/.Xresources  
    sysmodmap=/etc/X11/xinit/.Xmodmap  
      
    \# merge in defaults and keymaps  
      
    if [ -f $sysresources ]; then  
      
      
      
      
      
      
      
    xrdb -merge $sysresources  
      
    fi  
      
    if [ -f $sysmodmap ]; then  
    xmodmap $sysmodmap  
    fi  
      
    if [ -f "$userresources" ]; then  
      
      
      
      
      
      
      
    xrdb -merge "$userresources"  
      
    fi  
      
    if [ -f "$usermodmap" ]; then  
    xmodmap "$usermodmap"  
    fi  
      
    \# start some nice programs  
      
      
    if [ -d /etc/X11/xinit/xinitrc.d ] ; then  
    for f in /etc/X11/xinit/xinitrc.d/\* ; do  
    [ -x "$f" ] && . "$f"  
    done  
    unset f  
    fi  
      
    twm &  
    xclock -geometry 50x50-1+1 &  
    xterm -geometry 80x50+494+51 &  
    xterm -geometry 80x20+494-0 &  
    exec xterm -geometry 80x66+0+0 -name login
    

    and the other one is /etc/xdg/xfce4/xinitrc and here is its contents:

    \#!/bin/sh  
      
    \# fix broken $UID on some system...  
    if test "x$UID" = "x"; then  
    if test -x /usr/xpg4/bin/id; then  
    UID=\`/usr/xpg4/bin/id -u\`;  
    else  
    UID=\`id -u\`;  
    fi  
    fi  
      
    \# set $XDG\_MENU\_PREFIX to "xfce-" so that "xfce-applications.menu" is picked  
    \# over "applications.menu" in all Xfce applications.  
    if test "x$XDG\_MENU\_PREFIX" = "x"; then  
    XDG\_MENU\_PREFIX="xfce-"  
    export XDG\_MENU\_PREFIX  
    fi  
      
    \# set DESKTOP\_SESSION so that one can detect easily if an Xfce session is running  
    if test "x$DESKTOP\_SESSION" = "x"; then  
    DESKTOP\_SESSION="xfce"  
    export DESKTOP\_SESSION  
    fi  
      
    \# $XDG\_CONFIG\_HOME defines the base directory relative to which user specific  
    \# configuration files should be stored. If $XDG\_CONFIG\_HOME is either not set  
    \# or empty, a default equal to $HOME/.config should be used.  
    if test "x$XDG\_CONFIG\_HOME" = "x" ; then  
    XDG\_CONFIG\_HOME=$HOME/.config  
    fi  
    [ -d "$XDG\_CONFIG\_HOME" ] || mkdir "$XDG\_CONFIG\_HOME"  
      
    \# $XDG\_CACHE\_HOME defines the base directory relative to which user specific  
    \# non-essential data files should be stored. If $XDG\_CACHE\_HOME is either not  
    \# set or empty, a default equal to $HOME/.cache should be used.  
    if test "x$XDG\_CACHE\_HOME" = "x" ; then  
    XDG\_CACHE\_HOME=$HOME/.cache  
    fi  
    [ -d "$XDG\_CACHE\_HOME" ] || mkdir "$XDG\_CACHE\_HOME"  
      
    \# set up XDG user directores. see  
    \# http://freedesktop.org/wiki/Software/xdg-user-dirs  
    if which xdg-user-dirs-update \>/dev/null 2\>&1; then  
    xdg-user-dirs-update  
    fi  
      
    \# Modify libglade and glade environment variables so that  
    \# it will find the files installed by Xfce  
    GLADE\_CATALOG\_PATH="$GLADE\_CATALOG\_PATH:"  
    GLADE\_PIXMAP\_PATH="$GLADE\_PIXMAP\_PATH:"  
    GLADE\_MODULE\_PATH="$GLADE\_MODULE\_PATH:"  
    export GLADE\_CATALOG\_PATH  
    export GLADE\_PIXMAP\_PATH  
    export GLADE\_MODULE\_PATH  
      
    \# For now, start with an empty list  
    XRESOURCES=""  
      
    \# Has to go prior to merging Xft.xrdb, as its the "Defaults" file  
    test -r "/etc/xdg/xfce4/Xft.xrdb" && XRESOURCES="$XRESOURCES /etc/xdg/xfce4/Xft.xrdb"  
    test -r $HOME/.Xdefaults && XRESOURCES="$XRESOURCES $HOME/.Xdefaults"  
      
    BASEDIR=$XDG\_CONFIG\_HOME/xfce4  
    if test -r "$BASEDIR/Xft.xrdb"; then  
    XRESOURCES="$XRESOURCES $BASEDIR/Xft.xrdb"  
    elif test -r "$XFCE4HOME/Xft.xrdb"; then  
    mkdir -p "$BASEDIR"  
    cp "$XFCE4HOME/Xft.xrdb" "$BASEDIR"/  
    XRESOURCES="$XRESOURCES $BASEDIR/Xft.xrdb"  
    fi  
      
    \# merge in X cursor settings  
    test -r "$BASEDIR/Xcursor.xrdb" && XRESOURCES="$XRESOURCES $BASEDIR/Xcursor.xrdb"  
      
    \# ~/.Xresources contains overrides to the above  
    test -r "$HOME/.Xresources" && XRESOURCES="$XRESOURCES $HOME/.Xresources"  
      
    \# load all X resources (adds /dev/null to avoid an empty list that would hang the process)  
    cat /dev/null $XRESOURCES | xrdb -nocpp -merge -  
      
    \# load local modmap  
    test -r $HOME/.Xmodmap && xmodmap $HOME/.Xmodmap  
      
    \# run xfce4-session if installed  
    if which xfce4-session \>/dev/null 2\>&1; then  
      
    \# check if we start xfce4-session with ck-launch-session. this is only  
    \# required for starting from a console, not a login manager  
    if test "x$XFCE4\_SESSION\_WITH\_CK" = "x1"; then  
    if which ck-launch-session \>/dev/null 2\>&1; then  
    ck-launch-session xfce4-session  
    else  
    echo  
    echo "You have tried to start Xfce with consolekit support, but"  
    echo "ck-launch-session is not installed."  
    echo "Aborted startup..."  
    echo  
      
    exit 1  
    fi  
    else  
    \# start xfce4-session normally  
    xfce4-session  
    fi  
      
    exit 0  
    fi  
      
    \#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#  
    \# IMPORTANT NOTE \#  
    \#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#  
      
    \# Everything below here ONLY gets executed if you are NOT using xfce4-session  
    \# (Xfce's session manager). If you are using the session manager, everything  
    \# below is handled by it, and the code below is not executed at all. If you're  
    \# not sure if you're using the session manager, type 'ps -e|grep xfce4-session'  
    \# in a terminal while Xfce is running.  
      
    \#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#  
      
    \# Use dbus-launch if installed.  
    if test x"$DBUS\_SESSION\_BUS\_ADDRESS" = x""; then  
    if which dbus-launch \>/dev/null 2\>&1; then  
    eval \`dbus-launch --sh-syntax --exit-with-session\`  
    \# some older versions of dbus don't export the var properly  
    export DBUS\_SESSION\_BUS\_ADDRESS  
    else  
    echo "Could not find dbus-launch; Xfce will not work properly" \>&2  
    fi  
    fi  
      
    \# this is only necessary when running w/o xfce4-session  
    xsetroot -solid black -cursor\_name watch  
      
    \# or use old-fashioned startup script otherwise  
      
    xfsettingsd &  
    xfwm4 --daemon  
      
    \# start up stuff in $XDG\_CONFIG\_HOME/autostart/  
    if test -d "$XDG\_CONFIG\_HOME/autostart"; then  
    for i in ${XDG\_CONFIG\_HOME}/autostart/\*.desktop; do  
    grep -q -E "^Hidden=true" "$i" && continue  
    if grep -q -E "^OnlyShowIn=" "$i"; then  
    \# need to test twice, as lack of the line entirely means we still run it  
    grep -E "^OnlyShowIn=" "$i" | grep -q 'XFCE;' || continue  
    fi  
    grep -E "^NotShowIn=" "$i" | grep -q 'XFCE;' && continue  
      
    \# check for TryExec  
    trycmd=\`grep -E "^TryExec=" "$i" | cut -d'=' -f2\`  
    if test "$trycmd"; then  
    which "$trycmd" \>/dev/null 2\>&1 || continue  
    fi  
      
    cmd=\`grep -E "^Exec=" "$i" | cut -d'=' -f2\`  
    if test "$cmd" && which "$cmd" \>/dev/null 2\>&1; then  
    $cmd &  
    fi  
    done  
    fi  
      
    xfdesktop&  
    orage &  
      
    panel=\`which xfce4-panel\`  
    case "x$panel" in  
    x|xno\*)  
    ;;  
    \*)  
    $panel  
    ret=$?  
    while test $ret -ne 0; do  
    xmessage -center -file - -timeout 20 -title Error <<EOF  
    A crash occured in the panel  
    Please report this to the [email protected] list  
    or on http://bugs.xfce.org  
    Meanwhile the panel will be restarted  
    EOF  
    cat \>&2 <<EOF  
    A crash occured in the panel  
    Please report this to the [email protected] list  
    or on http://bugs.xfce.org  
    Meanwhile the panel will be restarted  
    EOF  
    $panel  
    ret=$?  
    done  
    ;;  
    esac  
      
    xsetroot -bg white -fg red -solid black -cursor\_name watch
    
  • The output of the command that I posted to your GOA issue will help me steer you in the right direction on this. I am going to install xfce tonight on my test machine so I can see if this issue is specific to your system or all installs of xfce in Antergos. I’ll let you know what I find!

  • no comment or suggestion?

  • Make sure you have the package “udisk” installed and then restart and try to mount.

  • it is already installed.

    [[email protected] ~]\# pacman -Ss udisk  
    extra/udisks 1.0.4-8 [installed]  
    Disk Management Service  
    extra/udisks2 2.1.0-3 [installed]  
    Disk Management Service, version 2  
    community/udiskie 0.4.1-4  
    Removable disk automounter using udisks  
    [[email protected] ~]\# pacman -Q | grep udisk  
    udisks 1.0.4-8  
    udisks2 2.1.0-3  
      
    
    
  • Is ntfs-3g installed?

  • yes.
    i do not have any problem in gnome and the ntfs partitions mount without any problem. the problem is in xfce desktop.

  • Then the only package that comes to my mind that could cause something like that would be gvfs :s

  • this package is already installed too!!!

  • I don’t understand what is causing this issue. You have all required packages. I am out of ideas. If it were me having the issue, I would just use nautilus as default instead of Thunar or download PcmanFM. Only choose one so they aren’t stepping on each others toes so to speak

  • i tried to mount it from nautilus in xfce but get the reeoe message:‌ "Unable to access “My_Partition_Name”. Not authorized to perform operation"
    i another test i mounted the partitions in gnome and the loged out and loged in to xfce. the partitions were mounted in both thunar and nautilus. then i unmounted them in thunar and tried to mount them again. but faced the above error message!!!

  • Are you using GDM as your desktop manager?

  • Okay, log into Xfce and check to see if “polkit-gnome-authentication-agent-1” has been started and is running. I am thinking it won’t be. If that is the case you need to set it to automatically run at startup via Settings Manager > Session and Startup. If that fixes it then we are done if not then proceed to check logs for errors related that polkit agent which may look something like this:

    (xfce4-session:3472): xfce4-session-WARNING \*\*: Unable to launch "/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1"
    

    Look in ~/.xsession-errors to see if error is occuring:
    (If you dont have one or it contains old information use terminal command "sudo journalctl -u xfce4-session)

    Also check /etc/pam.d/system-auth and add these two lines to the file. (If they aren’t there already)

      
    session optional pam\_loginuid.so  
    session optional pam\_systemd.so  
    
    

    Well, that’s all I came up with. Let me know the result!

  • i do not have “polkit-gnome-authentication-agent-1” service even in Gnome. after logging to gnome i used this commands:

    [[email protected] ~]$ systemctl status | grep polkit  
    polkit.service -\> '/org/freedesktop/systemd1/unit/polkit\_2eservice'  
    polkit.service - Authorization Manager  
    Loaded: loaded (/usr/lib/systemd/system/polkit.service; static)  
    Docs: man:polkit(8)  
    Main PID: 710 (polkitd)  
    CGroup: name=systemd:/system/polkit.service  
    └─710 /usr/lib/polkit-1/polkitd --no-debug  
    
    

    after loging to xfce i activated 2 options from “Setting Manager”:
    1- “GNOME Settings Daemon” from “Application Autustart” tab.
    2- “Launch GNOME services on startup” from “Advanced” tab.
    then i rebooted the system.
    i noticed that there is no .xsession file and i do not have those lines in /etc/pam.d/system-auth. here is the commands i used in xfce:

    [[email protected] ~]$ pacman -Ss polkit  
    extra/polkit 0.111-1 [installed]  
    Application development toolkit for controlling system-wide privileges  
    extra/polkit-kde 0.99.0-2  
    Daemon providing a polkit authentication UI for KDE  
    extra/polkit-qt 0.103.0-2  
    A library that allows developers to access PolicyKit API with a nice  
    Qt-style API  
    community/polkit-gnome 0.105-1  
    PolicyKit integration for the GNOME desktop  
    [[email protected] ~]$ systemctl status | grep polkit  
    polkit.service -\> '/org/freedesktop/systemd1/unit/polkit\_2eservice'  
    polkit.service - Authorization Manager  
    Loaded: loaded (/usr/lib/systemd/system/polkit.service; static)  
    Docs: man:polkit(8)  
    Main PID: 357 (polkitd)  
    CGroup: name=systemd:/system/polkit.service  
    └─357 /usr/lib/polkit-1/polkitd --no-debug  
    [[email protected] ~]$ ps -aux | grep polkit  
    polkitd 357 0.1 0.3 74680 12200 ? Ssl 17:23 0:00 /usr/lib/polkit-1/polkitd --no-debug  
    hadian 1825 0.0 0.0 4552 944 pts/1 S+ 17:25 0:00 grep polkit  
    [[email protected] ~]$ ls ~/.xsession  
    ls: cannot access /home/hadian/.xsession: No such file or directory  
    [[email protected] ~]$ sudo journalctl -u xfce4-session  
    [sudo] password for hadian:   
    -- Logs begin at Wed 2013-07-03 16:16:40 IRDT, end at Wed 2013-08-14 17:25:59 IR  
    [[email protected] ~]$ cat /etc/pam.d/system-auth   
    \#%PAM-1.0  
      
    auth required pam\_env.so  
    auth required pam\_unix.so try\_first\_pass nullok  
    auth optional pam\_permit.so  
      
    account required pam\_unix.so  
    account optional pam\_permit.so  
    account required pam\_time.so  
      
    password required pam\_unix.so try\_first\_pass nullok sha512 shadow  
    password optional pam\_permit.so  
      
    session required pam\_limits.so  
    session required pam\_env.so  
    session required pam\_unix.so  
    session optional pam\_permit.so  
      
    session optional pam\_loginuid.so  
    session optional pam\_systemd.so 
    
  • “polkit-gnome-authentication-agent-1” doesnt run in gnome anymore b/c gnome shell has polkit integrated directly. So it would seem to me this is the cause of your problem. When you are running xfce you need to make sure that daemon is running. You can install it with package “polkit-gnome”. After install reboot and it should be working

  • thank you so much. that solved the problem.

Posts 21Views 3450
Log in to reply