• Dude.. Where's my sound?? {SOLVED}


    This is an “Asked & Answered” post - I can’t believe I was the only one who had this issue.

    After an upgrade, I had no sound output whatsoever. I dualboot, so testing the other OS revealed there was nothing wrong with the speakers or connections.

    It took me a while, but basically I downgraded “libpulse” & “pulseaudio” from 6.0.1 to their previous versions, 5.0.1 - & now sound is restored;

    cd  /var/cache/pacman/pkg    
    
    sudo pacman -U pulseaudio-5.0-1-x86_64.pkg.tar.xz libpulse-5.0-1-x86_64.pkg.tar.xz
    

    Then prevent pacman from upgrading these packages;

    cd /etc && sudo nano pacman.conf           
    

    Uncomment IgnorePkg from /etc/pacman.conf and add them in sequence

    IgnorePkg = libpulse pulseaudio
    

    That 's it! This solution brought to you on the back of much sweat, tears & frustration on my part.
    It is the first significant problem I’ve had after over a year running Antergos, other than a “libxcursor” issue many moons ago. Super happy with this distro - thanx for your hard work!

  • Hi!

    Thanks a lot for sharing your solution.

    For completeness, could you share which sound system are you using? (a simple lspci -nnn will suffice)

    Thanks again.

  • @karasu said:

    lspci -nnn

    Sure,
    It’s just Intel onboard audio - this is the relevant output from above command;

    00:1b.0 Audio device [0403]: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio [8086:3b56] (rev 06)

  • I have same problem.
    My device :
    01:00.1 Audio device [0403]: NVIDIA Corporation High Definition Audio Controller [10de:0be3] (rev a1)

    Something strange : ONLY Gnome notification and speaker test works ???

    Trying previous version of pulse audio…

  • Would be great to know if it did solve your problem - like I said, I’m really surprised this wasn’t an issue for more people out there.

  • False alarm for me.
    My laptop has been used on HDMI output (to TV) and after disconnection while the OS was running, it was still outputting sound to HDMI without me having control in the system sound setting (only internal speakers was available and could not activate it).

    I had to reconnect HDMI and found out that sound was on my tv, only then i could select internal speakers to re-enable them.

    So there’s a bug but not related to this one.

  • I found that the problem was in the Settings Manager, Startup applications and untick Start Pulse.
    The command that is there is deprecated.
    I had the same issue on Manjaro and did exactly what you did. Went to PulseAudio site and read up on what the heck changed since there is no change log.

  • Dude, THANKS!!! I’ve just noticed some days ago and the idea of troubleshooting was kind of horrible. Your solution worked perfectly! Thanks for saving me an evening of imprecations.

    Btw, what’s up with pulseaudio new version not working? any idea?

  • Hey - glad that it helped, & weirdly - good to know that it wasn’t just me that had pulse problems.
    As for why? I don’t ask - I chalk it up as the consequence of living life on the bleeding edge; In this case it’s a niche problem affecting just a small section of us with particular chipsets. The developers do all their testing but the real test comes once the software is released into the wild, whereupon rightfully we should file bug reports & the issue gets fixed. For me, if something breaks - my troubleshooting inevitably leads to downgrading a package, so that’s where I start.

  • Hi there! I noticed that pulseaudio recently upgraded to 7.0.x, so i decided to give it a try and updating it. Still doesn’t work. No audio just like 6.0.x.

    Anybody investigated on this? Any solution?

sound44 audio30 pulse3 pacman80 alsamixer3 Posts 10Views 3580
Log in to reply