• Power Issues

    I think I may have come across a bug with Antergos. I installed kde 4.15 and my power settings did not work (turn off monitor at five minutes). I updated to Plasma 5.2 with the same issue. I started over with Cinnamon only to have my monitor on with Power Management settings ignored. I decided to try Gnome with the same issue.

    The Monitor should shut off at the 5 minute mark. As way of comparison, I tried Fedora 21 with Cinnamon, Opensuse 13.2 with kde and Mint 17.1. All three distors shut the monitor off at 5 minutes. I’m not sure what is going on, but I need to have the Power Settings work.

    Has anyone else noticed the issue and more importantly, is there anything that can be done to address the issue? I prefer to stay with Antergos, but am now using Mint 17.1 as my monitor turns off at the 5 minute mark, as it should.


  • It sounds like an issue related to the graphics driver. What’s your system specs?

  • @lots.0.logs System: Here You Go. Thanks for any help.
    Dell XPS 8700
    CPU: Quad core Intel Core i7-4790 CPU Graphics:
    Card: NVIDIA GT720X.Org: 1.15.1 drivers: nvidia
    Network: Card-1: Qualcomm Atheros AR9485 Wireless Network Adapter
    12 GB Ram
    Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller

    Edit: I wonder if this could solve the problem.

    link text

  • @parkslope said:


    Hmm…I’m using an 8700 with similar specs and don’t have any problems. The graphics card is not the same model (GTX645) but it’s in the same “family” as yours so there shouldn’t be that much difference. Could you post your system journal after doing a fresh boot and allowing ample time where the monitor should be turned off by your power settings? Thanks.

  • @lots.0.logs

    I was looking for the thread with instructions on how to obtain and provide my Journal. I haven’t done it in a long time and don’t remember how. The new forum seems to have me stumped as to where certain threads are located.


  • The lightdm.log is empty. I saved the Xorg file as a text document.

    I hope this is alright. Please advise.

  • Try switching to the NVIDIA drivers (made by NVIDIA):

    sudo pacman -S nvidia
  • I thought of that. Won’t that cause a problem every time the kernel is updated?

  • No. The nvidia drivers are packaged officially in the Arch Repos so you don’t have to worry about kernel updates. Of course you should still be mindful of what you are updating incase you are performing an update while packages are still being moved into the repos (so you don’t miss any).

  • Easy installation. Monitor still will not go into power saving mode. Any ideas?

    I appreciate the help.

    Edit: What I find interesting is that all posts online seem to have users wanting to disable this setting, not turn it on. I really don’t have an answer for the issue at this point. Further, this is a problem that only occurred with the recent installation of three different installations of Plasma 5.2, Cinnamon and Gnome.

    I have never had an issue with this computer before when it came to blanking the monitor, until now. I’m stumped.

  • It’s possible that its a kernel bug. You could install the lts kernel and test the result. If it is a kernel bug, at least you know and wont waste time trying to fix it. I’d check to see that the issue is reported upstream (of course). That’s all moot if the issue is the same with the LTS kernel though!

  • I have NOT given much thought or time to this issue, myself. I simply do this, when I want to deactivate my screen…

    For the impatient, try this:

        xscreensaver &
    The xscreensaver-demo (1) program pops up a dialog box that lets you configure the screen saver, and experiment with the various display modes.
    Note that xscreensaver has a client-server model: the xscreensaver program is a daemon that runs in the background; it is controlled by the foreground xscreensaver-demo (1) and xscreensaver-command (1) programs. ***

    (Of course, there are all the configurations and options you might need. Check it out)…

  • I thought it might be a kernel issue. For some reason I was leaning towards an update that has caused this issue. I guess I can install the LTS kernel when time permits for me to figure out how to do it.

    As for the xscreensaver idea, I tried that with Plasma 5.2 but had mixed results. Also I don’t think it addresses the power issue. I’ll give it a try now that I’m using Gnome.

    I’ll report back. Thanks.

    Edit: I don’t use Antergos Grub. I triple boot W 8.1, Mint and Antergos. I let Mint Grub run the show. Could this have anything to do with the power issue?

  • I had this issue last year with a different laptop and a solution that was offered to me back then (which worked) was to login into a Cinnamon desktop and setup the power settings there. Now that I have a newer HP Envy laptop with an Intel video card, that solution is not working for me.

  • I thought of doing that. Instead I use Linux Mint. Power issues do not exist and all is well. I will come back to Antergos at some, just not now. It really is too much of a headache to deal with. I like the direction the developers are taking, but there seems to be many growing pains at the moment.

    Also, the new format of the Forums is bizarre, just another reason to step away.

  • I installed GDM and enabled it today. Now my power settings are working as expected within gnome.

  • @parkslope I’m sorry you feel that way. Though, I certainly understand. A rolling release distribution isn’t good for all workflows. Should you wish to check us out in the future, you know where to find us 😉


  • Thanks for being so gracious Dustin. I will be back when time permits. There are times when my job is really slow and other times when it gets super hectic.

    The community is great. The Cnchi installer is working nicely and is super fast. It plays well with other distros (please don’t do something like Calamares which does not!).

    To be continued when time permits. :)

  • I just installed the newly released Gnome version last night that utilizes Gnome 3.16. I am having the same issue with the monitor not automatically shutting down. I tried changing the setting to 15 minutes and it still will not work. This feature works on both Fedora 21 and 22 (Gnome 3.14 and Gnome 3.16) so it doesn’t seem to be directly related to Gnome itself. Is there any additional information I can provide? I am using proprietary driver for an Nvidia GTX750 ti.

Posts 28Views 12400
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.