• Automatic or manual system update ?


    Hello,

    The automatic updates doesn’t work for me in XFCE when I click on top right /!\ pink update warning icon I see the list of updates required but then when I try to apply the update I’m stuck with an authentification error message. I think it’s normal as the application doesn’t ask for any sudo password. So I use the manual command line: pacman -Syu but is there any another faster solution please ?

    Thanks in advance for your help,

  • Hi, Pamac relies on polkit for authentication. Check to see that you have polkit and polkit-gnome installed (or lxpolkit if you prefer). Also check that the polkit auth agent is launched at the start of your session. More information can be found here: https://wiki.archlinux.org/index.php/Polkit

    Cheers!

  • Thank you for your quick answer, I will try it.

  • I’ve looked into it but stopped as it seems to be a known issue in GitHub: Lxpolkit in XFCE #249
    Opened by prescott66 . I didn’t know there was a Github bug report page.

  • I’m not sure about lxsession but I use polkit-gnome with XFCE on my laptop and it works fine.

pacman76 update45 Posts 5Views 1961
Log in to reply