• GRUB extremely slow after update


    Since my last update of Arch (today) I have found the GRUB bootloader to be extremely slow. It takes a very long time to display the OS selection menu and then a very long time to boot Linux as well.

    Here is my /etc/default/grub

      
    GRUB\_DEFAULT=0  
    GRUB\_TIMEOUT=5  
    GRUB\_DISTRIBUTOR=Antergos  
    GRUB\_CMDLINE\_LINUX\_DEFAULT="rcutree.rcu\_idle\_gp\_delay=1"  
    GRUB\_CMDLINE\_LINUX=""  
      
    \# Preload both GPT and MBR modules so that they are not missed  
    GRUB\_PRELOAD\_MODULES="part\_gpt part\_msdos"  
      
    \# Uncomment to enable Hidden Menu, and optionally hide the timeout count  
    \#GRUB\_HIDDEN\_TIMEOUT=5  
    \#GRUB\_HIDDEN\_TIMEOUT\_QUIET=true  
      
    \# Uncomment to use basic console  
    GRUB\_TERMINAL\_INPUT=console  
      
    \# Uncomment to disable graphical terminal  
    \#GRUB\_TERMINAL\_OUTPUT=console  
      
    \# The resolution used on graphical terminal  
    \# note that you can use only modes which your graphic card supports via VBE  
    \# you can see them in real GRUB with the command \`vbeinfo'  
    GRUB\_GFXMODE=auto  
      
    \# Uncomment to allow the kernel use the same resolution used by grub  
    GRUB\_GFXPAYLOAD\_LINUX=keep  
      
    \# Uncomment if you want GRUB to pass to the Linux kernel the old parameter  
    \# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"  
    \#GRUB\_DISABLE\_LINUX\_UUID=true  
      
    \# Uncomment to disable generation of recovery mode menu entries  
    GRUB\_DISABLE\_RECOVERY=true  
      
    \# Uncomment and set to the desired menu colors. Used by normal and wallpaper  
    \# modes only. Entries specified as foreground/background.  
    \#GRUB\_COLOR\_NORMAL="light-blue/black"  
    \#GRUB\_COLOR\_HIGHLIGHT="light-cyan/blue"  
      
    \# Uncomment one of them for the gfx desired, a image background or a gfxtheme  
    \#GRUB\_BACKGROUND="/path/to/wallpaper"  
    GRUB\_THEME="/boot/grub/themes/Antergos-Default/theme.txt"  
      
    \# Uncomment to get a beep at GRUB start  
    \#GRUB\_INIT\_TUNE="480 440 1"  
      
    \#GRUB\_SAVEDEFAULT="true"  
      
    \# ARGUMENTS TO GET IT WORKING IF NOUVEAU FAILS nomodeset nouveau.modeset=0  
    
    

    Thanks in advance for any help you might be able to provide.

  • Since my last update of Arch (today) I have found the GRUB bootloader to be extremely slow. It takes a very long time to display the OS selection menu and then a very long time to boot Linux as well.

    Here is my /etc/default/grub

      
    GRUB\_DEFAULT=0  
    GRUB\_TIMEOUT=5  
    GRUB\_DISTRIBUTOR=Antergos  
    GRUB\_CMDLINE\_LINUX\_DEFAULT="rcutree.rcu\_idle\_gp\_delay=1"  
    GRUB\_CMDLINE\_LINUX=""  
      
    \# Preload both GPT and MBR modules so that they are not missed  
    GRUB\_PRELOAD\_MODULES="part\_gpt part\_msdos"  
      
    \# Uncomment to enable Hidden Menu, and optionally hide the timeout count  
    \#GRUB\_HIDDEN\_TIMEOUT=5  
    \#GRUB\_HIDDEN\_TIMEOUT\_QUIET=true  
      
    \# Uncomment to use basic console  
    GRUB\_TERMINAL\_INPUT=console  
      
    \# Uncomment to disable graphical terminal  
    \#GRUB\_TERMINAL\_OUTPUT=console  
      
    \# The resolution used on graphical terminal  
    \# note that you can use only modes which your graphic card supports via VBE  
    \# you can see them in real GRUB with the command \`vbeinfo'  
    GRUB\_GFXMODE=auto  
      
    \# Uncomment to allow the kernel use the same resolution used by grub  
    GRUB\_GFXPAYLOAD\_LINUX=keep  
      
    \# Uncomment if you want GRUB to pass to the Linux kernel the old parameter  
    \# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"  
    \#GRUB\_DISABLE\_LINUX\_UUID=true  
      
    \# Uncomment to disable generation of recovery mode menu entries  
    GRUB\_DISABLE\_RECOVERY=true  
      
    \# Uncomment and set to the desired menu colors. Used by normal and wallpaper  
    \# modes only. Entries specified as foreground/background.  
    \#GRUB\_COLOR\_NORMAL="light-blue/black"  
    \#GRUB\_COLOR\_HIGHLIGHT="light-cyan/blue"  
      
    \# Uncomment one of them for the gfx desired, a image background or a gfxtheme  
    \#GRUB\_BACKGROUND="/path/to/wallpaper"  
    GRUB\_THEME="/boot/grub/themes/Antergos-Default/theme.txt"  
      
    \# Uncomment to get a beep at GRUB start  
    \#GRUB\_INIT\_TUNE="480 440 1"  
      
    \#GRUB\_SAVEDEFAULT="true"  
      
    \# ARGUMENTS TO GET IT WORKING IF NOUVEAU FAILS nomodeset nouveau.modeset=0  
    
    

    Thanks in advance for any help you might be able to provide.

  • hi. can you post output of your[i:2tfgm9mc] menu.list[/i:2tfgm9mc] file?

    Here are some possible ideas/solutions:

    If you use hibernation, Grub might be trying to find the /boot partition and it thinks that your file system might be unmounted incorrectly. Hence the waiting time.
    Or there could be a bad BIOS set up. Perhaps you did a BIOS update some time ago depending if you have an older machine or not. If not, most likely you have UEFI, so this may or may not be connected. If you have BIOS, enable the floppy option. Grub has some issue with it for some reason. If that does not apply to you, then perhaps you didn’t update grub correctly.
    Do

    grub-mkconf -o /boot/grub/grub.cfg
    

    Also, check the boot-order of the HDD’S in the bios/UEFI.
    If this does not apply to you either, then perhaps your UUID changed. Grub is trying to find the UUID that were associated with the file before and somewhere, somehow the UUID were/was changed. Check your /etc/fstab file and compare the UUID listed therein with the UUID of, say gparted if you have that installed.
    You can also check them with

    sudo lsblk -f
    

    Can you post the output of

      
    then post the output of   
    systemd-analyze blame
    

    You can also do:

    systemd-analyze critical-chain
    

    If there is nothing remarkable in the above outputs, consider that you might also have a number of services enabled at boot.
    You can/might also want to check your journalctl. Do:

    sudo journalctl
    

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Mysteriously, the problem seems to have resolved itself of its own accord. Thank you for your help!

  • ok. I guess you just need to edit your first post as [Solved].

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

Posts 5Views 2299
Log in to reply