• I need help to create a new boot !!


    Hello,

    I’m new here in antergos was looking for a Linux system to give me a good performance and found the antergos ran it in virtual machine to test and he gave superior performance relative to OpenSUSE, then decided to install on my PC. Here comes the headache, I began to try to install it in November / 2014 and to this day only occurs both before the error installation and now it does not create a boot (installs without giving error and does not create boot). So I gave the boot ISO again and noticed that all the mount the partitions, now and just redo the boot and did the following:

    To see the disks
    #lsblk

    / dev / sda1 / boot
    / dev / sda2 LVM-encrypted

    Now I enter the encrypted partition LVM

    #cryptsetup open / dev / sda2 User

    Now active LVM partition

    #vgchange -a y

    Now to mount the LVM partitions

    #mount / dev / mapper / AntergosVG-AntergosRoot / mnt

    From here comes my doubts as I continue to redo the boot.And lack now use chroot.

  • Hello,

    I’m new here in antergos was looking for a Linux system to give me a good performance and found the antergos ran it in virtual machine to test and he gave superior performance relative to OpenSUSE, then decided to install on my PC. Here comes the headache, I began to try to install it in November / 2014 and to this day only occurs both before the error installation and now it does not create a boot (installs without giving error and does not create boot). So I gave the boot ISO again and noticed that all the mount the partitions, now and just redo the boot and did the following:

    To see the disks
    #lsblk

    / dev / sda1 / boot
    / dev / sda2 LVM-encrypted

    Now I enter the encrypted partition LVM

    #cryptsetup open / dev / sda2 User

    Now active LVM partition

    #vgchange -a y

    Now to mount the LVM partitions

    #mount / dev / mapper / AntergosVG-AntergosRoot / mnt

    From here comes my doubts as I continue to redo the boot.And lack now use chroot.

  • Mount your boot in place (after mounting AntergosRoot as you posted):

    [command:eoj1hvrh]mount /dev/sda1 /mnt/boot[/command:eoj1hvrh]

    To chroot and reinstall grub (that’s what you want, don’t you?) you need to mount certain “special” directories:

    [command:eoj1hvrh]sudo mount /dev /mnt/dev --bind
    sudo mount /proc /mnt/proc --bind
    sudo mount /dev/pts /mnt/dev/pts --bind
    sudo mount /sys /mnt/sys --bind[/command:eoj1hvrh]
    And now you can chroot:
    [command:eoj1hvrh]sudo chroot /mnt[/command:eoj1hvrh]
    Now, just in case, recreate your grub setup:
    [command:eoj1hvrh]sudo grub-mkconfig -o /boot/grub/grub.cfg[/command:eoj1hvrh]
    And, also just in case, reinstall grub to your sda:
    [command:eoj1hvrh]sudo grub-install /dev/sda[/command:eoj1hvrh]
    Please, read carefully these commands before typing and don’t hesitate to ask more questions (this is not an easy task)

    Cheers!

  • I was careful to use the commands that you gave me, however forgot to report that my notebook does not have the UEFI technology, soon appears these errors:

    sudo grub-mkconfig -o /boot/grub/grub.cfg  
    Generating grub configuration file ...  
    /run/lvm/lvmetad.socket: connect failed: No such file or directory  
    WARNING: Failed to connect to lvmetad. Falling back to internal scanning.  
    /run/lvm/lvmetad.socket: connect failed: No such file or directory  
    WARNING: Failed to connect to lvmetad. Falling back to internal scanning.  
    /run/lvm/lvmetad.socket: connect failed: No such file or directory  
    WARNING: Failed to connect to lvmetad. Falling back to internal scanning.  
    /run/lvm/lvmetad.socket: connect failed: No such file or directory  
    WARNING: Failed to connect to lvmetad. Falling back to internal scanning.  
    /run/lvm/lvmetad.socket: connect failed: No such file or directory  
    WARNING: Failed to connect to lvmetad. Falling back to internal scanning.  
    /run/lvm/lvmetad.socket: connect failed: No such file or directory  
    WARNING: Failed to connect to lvmetad. Falling back to internal scanning.  
    /run/lvm/lvmetad.socket: connect failed: No such file or directory  
    WARNING: Failed to connect to lvmetad. Falling back to internal scanning.  
    /run/lvm/lvmetad.socket: connect failed: No such file or directory  
    WARNING: Failed to connect to lvmetad. Falling back to internal scanning.  
    Found theme: /boot/grub/themes/Antergos-Default/theme.txt  
    /run/lvm/lvmetad.socket: connect failed: No such file or directory  
    WARNING: Failed to connect to lvmetad. Falling back to internal scanning.  
    /run/lvm/lvmetad.socket: connect failed: No such file or directory  
    WARNING: Failed to connect to lvmetad. Falling back to internal scanning.  
    Found linux image: /boot/vmlinuz-linux  
    Found initrd image: /boot/initramfs-linux.img  
    Found fallback initramfs image: /boot/initramfs-linux-fallback.img  
    /run/lvm/lvmetad.socket: connect failed: No such file or directory  
    WARNING: Failed to connect to lvmetad. Falling back to internal scanning.  
    /run/lvm/lvmetad.socket: connect failed: No such file or directory  
    WARNING: Failed to connect to lvmetad. Falling back to internal scanning.  
    /run/lvm/lvmetad.socket: connect failed: No such file or directory  
    WARNING: Failed to connect to lvmetad. Falling back to internal scanning.  
    grub-probe: error: cannot find a GRUB drive for /dev/sdc1\. Check your device.map.  
    done  
    
    

    here is my system after I decrypting:

    lsblk   
    NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT  
    sda 8:0 0 465.8G 0 disk   
    |-sda1 8:1 0 243M 0 part /boot  
    \`-sda2 8:2 0 465.5G 0 part   
    \`-gsantos 254:1 0 465.5G 0 crypt   
    |-AntergosVG-AntergosRoot 254:2 0 459.8G 0 lvm /  
    \`-AntergosVG-AntergosSwap 254:3 0 5.8G 0 lvm   
    sdc 8:32 1 14.5G 0 disk   
    |-sdc1 8:33 1 830M 0 part   
    \`-sdc2 8:34 1 31M 0 part   
    sr0 11:0 1 1024M 0 rom   
    loop0 7:0 0 766.9M 1 loop   
    loop1 7:1 0 32G 1 loop   
    \`-arch\_root-image 254:0 0 32G 0 dm   
    loop2 7:2 0 256M 0 loop   
    \`-arch\_root-image 254:0 0 32G 0 dm 
    

    Obs.:I did it atrvez the ISO antergos and other commands work without errors.

  • Hi,

    You can ignore all those warnings, but not this error:

    grub-probe: error: cannot find a GRUB drive for /dev/sdc1. Check your device.map.

    Do you have a /boot/grub/device.map file in your computer? This file is not used anymore (afaik).

    If you have it, please rename it and try running [command:2rxidqfv]sudo grub-mkconfig -o /boot/grub/grub.cfg[/command:2rxidqfv] again.

    Also, remember to run [command:2rxidqfv]sudo grub-install /dev/sda[/command:2rxidqfv] afterwards (that is, if grub-mkconfig works).

  • Hi,

    I do not know why but the error persists, and the worst that installed Antergos around the HD and deleted everything. When I see the directory / boot / grub so I see grub.cfg!

    sudo grub-mkconfig -o /boot/grub/grub.cfg  
    Generating grub configuration file ...  
    /run/lvm/lvmetad.socket: connect failed: No such file or directory  
    WARNING: Failed to connect to lvmetad. Falling back to internal scanning.  
    /run/lvm/lvmetad.socket: connect failed: No such file or directory  
    WARNING: Failed to connect to lvmetad. Falling back to internal scanning.  
    /run/lvm/lvmetad.socket: connect failed: No such file or directory  
    WARNING: Failed to connect to lvmetad. Falling back to internal scanning.  
    /run/lvm/lvmetad.socket: connect failed: No such file or directory  
    WARNING: Failed to connect to lvmetad. Falling back to internal scanning.  
    /run/lvm/lvmetad.socket: connect failed: No such file or directory  
    WARNING: Failed to connect to lvmetad. Falling back to internal scanning.  
    /run/lvm/lvmetad.socket: connect failed: No such file or directory  
    WARNING: Failed to connect to lvmetad. Falling back to internal scanning.  
    /run/lvm/lvmetad.socket: connect failed: No such file or directory  
    WARNING: Failed to connect to lvmetad. Falling back to internal scanning.  
    /run/lvm/lvmetad.socket: connect failed: No such file or directory  
    WARNING: Failed to connect to lvmetad. Falling back to internal scanning.  
    /run/lvm/lvmetad.socket: connect failed: No such file or directory  
    WARNING: Failed to connect to lvmetad. Falling back to internal scanning.  
    /run/lvm/lvmetad.socket: connect failed: No such file or directory  
    WARNING: Failed to connect to lvmetad. Falling back to internal scanning.  
    /run/lvm/lvmetad.socket: connect failed: No such file or directory  
    WARNING: Failed to connect to lvmetad. Falling back to internal scanning.  
    /run/lvm/lvmetad.socket: connect failed: No such file or directory  
    WARNING: Failed to connect to lvmetad. Falling back to internal scanning.  
    /run/lvm/lvmetad.socket: connect failed: No such file or directory  
    WARNING: Failed to connect to lvmetad. Falling back to internal scanning.  
    grub-probe: error: cannot find a GRUB drive for /dev/sdb1\. Check your device.map.  
    done  
    
    
    sudo grub-install /dev/sda  
    Installing for x86\_64-efi platform.  
    
    

    I am open to new suggestions to redo the boot or some alternative to solve my problem.

  • Hi,
    I would like to thank the whole team for antergos look for ways to help me. I realized research and found out that all the arch linux decentedes still depends on it somehow you have problems creating boot. So I decided to try to install the arch of the arch way, and incredible that passarece had problems in the boot, the more I consigui resolve and I can now defrutar the arch linux. I would like to THANK AGAIN YOU BY YOUR COMMITMENT TO HELP ME AND NOT STOP THE DESEMVOLVER The ANTERGOS, AFTER ALL WE ARE HUMAN ERRORS OCCUR. I managed to install more ha who precissice use antergos way to install.

    Thank U.

  • So, you reinstalled again and it worked for you? Sorry but I didn’t fully understand your last message

  • I do not speak English well, but all tried in antergos did not work and luckily managed to install linux arch

Posts 9Views 5951
Log in to reply