• \[Solved\] Errror updating pacman 4.2 v5 to 6


    Dear all,

    today I got the following error when trying to do a system upgrade:

    \> yaourt -Su  
      
      
    ==\> Package upgrade only (new release):  
    core/pacman 4.2.0-5 5 -\> 6  
      
    ==\> Continue upgrade ? [Y/n]  
    ==\> [V]iew package detail [M]anually select packages  
    ==\> --------------------------------------------------  
    ==\>   
    :: Starting full system upgrade...  
    resolving dependencies...  
    looking for conflicting packages...  
      
    Packages (1) pacman-4.2.0-6  
      
    Total Download Size: 0,64 MiB  
    Total Installed Size: 4,22 MiB  
    Net Upgrade Size: 0,00 MiB  
      
    :: Proceed with installation? [Y/n]   
    :: Retrieving packages ...  
    pacman-4.2.0-6-x86\_64 659,2 KiB 6,64M/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (1/1) checking keys in keyring [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (1/1) checking package integrity [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (1/1) loading package files [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (1/1) checking for file conflicts [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    error: failed to commit transaction (conflicting files)  
    pacman: /var/cache/pacman exists in filesystem  
    Errors occurred, no packages were upgraded.  
    
    

    I assume, /var/cache/pacman should exist, shouldn’t it? I did a cache clean-up altready, but that didn’t help.

    Any suggestions?

    Thanks and cheers!

    Dell Latitude E6230 with Intel i7, 8GB RAM, 500 GB SSD
    dual boot: Antergos and Debian Stretch both 64bit and running gnome-shell
    surviving in a Windows world with VMware WS and Codeweavers Crossover

  • Dear all,

    today I got the following error when trying to do a system upgrade:

    \> yaourt -Su  
      
      
    ==\> Package upgrade only (new release):  
    core/pacman 4.2.0-5 5 -\> 6  
      
    ==\> Continue upgrade ? [Y/n]  
    ==\> [V]iew package detail [M]anually select packages  
    ==\> --------------------------------------------------  
    ==\>   
    :: Starting full system upgrade...  
    resolving dependencies...  
    looking for conflicting packages...  
      
    Packages (1) pacman-4.2.0-6  
      
    Total Download Size: 0,64 MiB  
    Total Installed Size: 4,22 MiB  
    Net Upgrade Size: 0,00 MiB  
      
    :: Proceed with installation? [Y/n]   
    :: Retrieving packages ...  
    pacman-4.2.0-6-x86\_64 659,2 KiB 6,64M/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (1/1) checking keys in keyring [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (1/1) checking package integrity [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (1/1) loading package files [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (1/1) checking for file conflicts [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    error: failed to commit transaction (conflicting files)  
    pacman: /var/cache/pacman exists in filesystem  
    Errors occurred, no packages were upgraded.  
    
    

    I assume, /var/cache/pacman should exist, shouldn’t it? I did a cache clean-up altready, but that didn’t help.

    Any suggestions?

    Thanks and cheers!

    Dell Latitude E6230 with Intel i7, 8GB RAM, 500 GB SSD
    dual boot: Antergos and Debian Stretch both 64bit and running gnome-shell
    surviving in a Windows world with VMware WS and Codeweavers Crossover

  • Try sudo pacman -Syu

    Cheers!

  • I think I tried that before, but tried it again anyway. Unfortunately same result :(

    I even just renamed the /var/cache/pacman/pkg directory and tried again. Guess what, pacman recreated the dir and complained then it is there! :)

    Dell Latitude E6230 with Intel i7, 8GB RAM, 500 GB SSD
    dual boot: Antergos and Debian Stretch both 64bit and running gnome-shell
    surviving in a Windows world with VMware WS and Codeweavers Crossover

  • can you try

    pacman -Scc
    

    This is going to ask you if you want to clear your cache. You can respond with ‘yes’.
    Then go

    sudo pacman -Syu
    

    If that doesn’t work, can you try to force an update----> that might be a bit risky. I"m none to sure of that one and I’ve never tried it myself [i:1g2m6hi6][b:1g2m6hi6](I would suggest that you leave this option as a last resort[/b:1g2m6hi6][/i:1g2m6hi6]) I’m leaving this only as an option. If your not sure what [i:1g2m6hi6]–force[/i:1g2m6hi6] does, what happens is that pacman force overwrites your filesystem packages with the same version that was put there in the beginning. But since you’re updating, I can’t say that with any kind of certainty. You’ll have new files that were updated from some other recent [i:1g2m6hi6]pacman -Syu[/i:1g2m6hi6] to ones that are not recent (like the current one your experiencing) all mixed up together and then there’s no syncing of updated code from one to the other. In other words, there’s conflicts. The command for that would be

    sudo pacman -Syu --force  
    
    

    If that doesn’t work, you can try

     sudo pacman -U --dbonly <path to pkg file\>
    

    <path to pkg file> is found at /var/cache/pacman/pkg/
    in your case, it would be /var/cache/pacman/pkg/pacman (what ever the latest version is).
    Then go

    sudo pacman -Syu
    

    then go

    pacman -S filesystem
    

    Answer 'yes’
    If that doesn’t work, sudo into that directory and remove any offending packages that may have been installed. I doubt anything offending may have been installed but just in case I’m say’in.

    Anyways, as I was say’in. If that doesn’t work, you can try downgrading.
    Go

    pacman -U /var/cache/pacman/pkg/pacman's-last-version-in-your-case-tar.xz
    

    Then go:

    sudo pacman -Syu
    

    that’s all I can think of. Hopefullly one of the above mentioned methods work.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Interesting! I solved it.

    I had moved [code:32ff8j4w]/var/cache/pacman[/code:32ff8j4w] to a different partition, because space on the root partition got spare. So the pacman cache under /var was actually a sym-link. And I guess that’s what prevented to update. After I removed the link and moved the cache back to the original location, the update of pacman went through. :)

    Let’s see, if it works still when I restore my linked config :)

    Thanks guys for your help.

    Cheers!

    Update: An update just came it. After the linkage of /var/cache/pacman to a different partition re-established, pacman v6 installed the update of package [i:32ff8j4w]xkeyboard-config[/i:32ff8j4w] just fine. Need to remember though, next time pacman itself is updated again :)

    Dell Latitude E6230 with Intel i7, 8GB RAM, 500 GB SSD
    dual boot: Antergos and Debian Stretch both 64bit and running gnome-shell
    surviving in a Windows world with VMware WS and Codeweavers Crossover

  • good job :)

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

Posts 7Views 1202
Log in to reply