• Grub menu theme


    Just jumping off the back of this thread. I tried to use the suggested solution to fix a distorted version of the Antergos grub theme to no avail. It is still distorted.

    Is there anything else I can do to try and fix this? When I say distorted, I mean that the list of distributions is there with Antergos as default, but it is very big and pixellated and sitting in the bottom right corner of my screen almost off to the right. It just looks a mess.

    Any help appreciated.

  • Just jumping off the back of this thread. I tried to use the suggested solution to fix a distorted version of the Antergos grub theme to no avail. It is still distorted.

    Is there anything else I can do to try and fix this? When I say distorted, I mean that the list of distributions is there with Antergos as default, but it is very big and pixellated and sitting in the bottom right corner of my screen almost off to the right. It just looks a mess.

    Any help appreciated.

  • Did you by chance change or alter any graphics for your grub menu at some point in time?

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Sorry I didn’t see this reply.

    No, no changes and in fact I have just done a completely new install and got exactly the same problem.

  • HI,

    What graphics hardware does your system have? Could you post the contents of /boot/grub/grub.cfg?

  • Thanks for replying lots.0.logs - http://pastebin.com/PcvuBUBU is the log file. I should point out that in fact the only distros showing are antergos and ubuntu, but as you will see there are a few others there as well.

    The graphics card is nvidia GeForce GT 640 with nvidia driver

    I wish I knew how to take a screenshot of grub

  • "I wish I knew how to take a screenshot of grub"
    I don’t think you can. Do you have a mobile phone or a digital camera? Simply take a picture of your monitor, that will suffice ;)

  • Try downloading a clean copy of the theme, delete the current copy, put the new one in its place, and finally run this command:

    sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    You can get a clean copy of the theme by downloading the Cnchi from github: https://github.com/Antergos/Cnchi/archive/master.zip

  • OK just for the record, this is the screen (sorry about thumb!) bad_grub_1.jpg

  • OK, carried out the replace theme suggestion. Nothing changed.

    I did suspect that may be the case because I have had the same problem with two separate installs at different times.

    Also, the menu is not selectable, so I can’t boot the other OS or even select Antergos. I have to wait for the timer to complete and it auto loads.

    Oh, and as you can see, only Antergos and Ubuntu show

  • Seems like it has something to do with the graphics driver. Check your systems BIOS/UEFI menu and see what graphics related options are available and try them to see if it helps.

    Cheers!

  • @opalepatrick said:

    Also, the menu is not selectable, so I can’t boot the other OS or even select Antergos. I have to wait for the timer to complete and it auto loads.

    Oh, and as you can see, only Antergos and Ubuntu show

    Isn’t this a problem with your keyboard? I don’t see any issue with the screenshot of your grub menu. It looks just like mine. But I must go down with the arrows of my keyboard to ‘discover’ all the other menu items. So it seems like grub is just fine, only keyboard is not responding.

    Intel NUC D54250WYK, 16 Gb RAM, 1 Tb SSD
    Multi -boot (no MS-Win &no UEFI) Legacy MBR with GPT

  • I did check to see if there is a bios setting but no. With regard to ant77, I will look at the keyboard thing. Never really though of that as it works fine past this point. Makes sense though!

    Is the screen really supposed to be like that? Seems big, ugly and blocky!

  • @opalepatrick said:

    Is the screen really supposed to be like that? Seems big, ugly and blocky!

    It appears that your system is not capable of displaying a resolution that the theme supports. The available resolutions for that early in the boot process are slim. The theme supports 800x600 and 1024x768. Do you have an extra display monitor you can try. It’s possible that it could be an issue specific to your display and the graphics driver during early boot.

  • Sorry, not igmoring your answers guys. Just caught up at the moment, but will get back to this soon.

  • Your Grub looks more or less like how mine looks. The issue for me is the proprietary nVidia driver. The issue as I understand it is that the free driver is somehow incorporated in the kernel, whereas the nVidia driver doesn’t kick in until later, so once you’ve made the shift from free to proprietary, you’re going to have a problem with the splash.

    Lenovo H50-50 Sharkbay, Intel® Core i7 4790 Haswell CPU @ 3.60 GH, 2047MB NVIDIA GeForce GT 720, 8.00GB Single-Channel DDR3 @ 798MHz, Windows 10 Pro 64-bit, Antergos 64-bit, 2GB WDC (SATA), 3GB TOSHIBA (SATA).

  • Try this

    grub2-theme-archlinux

    In the Arch repository. Looks great and has a timer that is like clock hands going around the Arch symbol.

Posts 18Views 5146
Log in to reply