• \[Solved\] 1/11/15 USB Blank Screen


    Hello, I am a fairly new user to Antergos. I apologize if this matter has been asked before, but I couldn’t find a workable solution for me.

    I cannot get the new .iso (1/11/15) to boot on my UEFI machines. I wrote the .iso with dd to a usb drive, and it boots normally in my legacy machine. Both of my UEFI laptops boot to the menu (I can select Antergos x86_64 UEFI CD/UEFI Shell v1 … etc), but when booting the monitor blanks and as far as I can tell it freezes. The USB read light stops and nothing further happens.

    I have tried disabling Secure Boot, but it doesn’t seem to change anything in this case.

    You guys have been so great at answering all my questions in the past that a solution already existed before I needed it, but I can’t find one for this problem. Any suggestions?

  • Hello, I am a fairly new user to Antergos. I apologize if this matter has been asked before, but I couldn’t find a workable solution for me.

    I cannot get the new .iso (1/11/15) to boot on my UEFI machines. I wrote the .iso with dd to a usb drive, and it boots normally in my legacy machine. Both of my UEFI laptops boot to the menu (I can select Antergos x86_64 UEFI CD/UEFI Shell v1 … etc), but when booting the monitor blanks and as far as I can tell it freezes. The USB read light stops and nothing further happens.

    I have tried disabling Secure Boot, but it doesn’t seem to change anything in this case.

    You guys have been so great at answering all my questions in the past that a solution already existed before I needed it, but I can’t find one for this problem. Any suggestions?

  • Welcome, Atraii. Did you try to disable KMS?
    When the Antergos boot menu appears, add at end of below line [b:goifyeo7]nomodeset[/b:goifyeo7] and press Enter.
    Which graphics card you have?

  • Thanks Dzeri, I can’t find KVM options in my bios for this machine. The machine in question (one of them) is a [b:2hy80ymg]Lenovo G580[/b:2hy80ymg] laptop with [b:2hy80ymg]Intel HD 4000 Graphics[/b:2hy80ymg] integrated graphics. I had an installation of Antergos running on this machine from last year, not sure what is different about this .iso.

    I ran the [b:2hy80ymg]nomodeset[/b:2hy80ymg] at the end of the boot parameters (just after [b:2hy80ymg]earlymodules=loop quiet[/b:2hy80ymg]), but [u:2hy80ymg]nothing changed[/u:2hy80ymg]. The screen still went black and no further operations happened.

    Any other suggestions? Thanks for the attempts already!

  • Sorry, I mistakenly wrote KVM instead KMS. :) KMS stands for Kernel mode settings.
    Look at the bottom of this page: [url:36vpaadi]https://wiki.archlinux.org/index.php/kernel_mode_setting[/url:36vpaadi]
    Please, try with boot parameters [b:36vpaadi]nomodeset i915.modeset=0[/b:36vpaadi] on laptop on which you have Intel graphics card.

  • Ah, well I just tried that. No luck with that either.

  • Hi,

    Try removing “quiet” from the boot command to see if any error messages will be displayed on the screen. Another thing to try is to boot directly to the command prompt by adding the following to the boot command:[code:6e8h608c]systemd.unit=multiuser.target[/code:6e8h608c]Note: Secure Boot [b:6e8h608c]must[/b:6e8h608c] be disabled, [b:6e8h608c]always[/b:6e8h608c].

    Cheers!

  • Secure boot has to be disabled for any linux distro to boot, so it is off.

    Removing the quiet issue did nothing. Still just a blank screen. I also tried w/o the quiet and w/nomodeset just to double check. Still nothing.

    Same thing with the [b:2mqdfoy0]systemd.unit=multiuser.target[/b:2mqdfoy0].

    Nothing seems to be working here. So… dumb question, but is there a location where I can try other .iso’s? I checked the MD5 for the current one and it seems to be fine. I also tried a few different usb drives. Everything has worked on my legacy machine. But all failed on either UEFI machine. It may be some weird problem with the current build.

  • Hmm…no I don’t think its the iso because it works on my UEFI machine. Look through your firmware’s settings and try alternate options for anything related to graphics (if there are any). If that doesnt help, what happens when you try the systemd unit command from my previous post but with [b:2bfiqvoe]emergency.target[/b:2bfiqvoe] instead?

  • I’m not sure if its related to running it with emergency.target and nomodeset or if its from writing the image with win32 Disk imager this time, but I’m now getting

    "Failed to open file: EFI\\archiso\\intel\_ucode.img"
    

    EDIT: For those interested, I pressed ‘e’ during the grub boot menu to edit the command line and removed the first option: [code:9ktk7d1w]initrd=\EFI\archiso\intel_ucode.img[/code:9ktk7d1w]

    It now starts normally.

  • Thanks for that information. This will be corrected soon.

Posts 11Views 2480
Log in to reply