• Problemas con gparted


    Hola,

    Tengo este fallo con el gparted, no lo puedo abrir por el menu, sino solamente mediante la terminal como root y cuando se abre deja este warning en la terminal:

    [[email protected] keos]# gparted

    libparted : 3.2

    (gpartedbin:2013): Gtk-WARNING **: Theme directory 48x48/app of theme Numix-Square has no size field

    Pero lo que quisiera saber es si hay alguna manera de solucionar que se vuelva a abrir simplemente haciendo click sobre el icono – debo decir que lo desintale ayer y lo volvi a intalar para ver si se arreglaba pero sigue igual, gracias por cualquier sugerencia.

    Un saludo

  • Hola,

    Tengo este fallo con el gparted, no lo puedo abrir por el menu, sino solamente mediante la terminal como root y cuando se abre deja este warning en la terminal:

    [[email protected] keos]# gparted

    libparted : 3.2

    (gpartedbin:2013): Gtk-WARNING **: Theme directory 48x48/app of theme Numix-Square has no size field

    Pero lo que quisiera saber es si hay alguna manera de solucionar que se vuelva a abrir simplemente haciendo click sobre el icono – debo decir que lo desintale ayer y lo volvi a intalar para ver si se arreglaba pero sigue igual, gracias por cualquier sugerencia.

    Un saludo

  • Hola,

    El warning lo puedes ignorar, es un problema del tema Numix-Square sin importancia

    Que entorno utilizas (Gnome, KDE, XFCE, …) ? Si abres la terminal i tecleas [code:3osutvlo]gparted_polkit[/code:3osutvlo] qué sucede?

  • Hola

    [[email protected] ~]$ gparted_polkit
    Error executing command as another user: No authentication agent found.
    [[email protected] ~]$

    Saludos

  • Y como root me abre el gparted con esto en la terminal:

    [[email protected] keos]# gparted_polkit
    Too few arguments.

    libparted : 3.2

    (gpartedbin:4148): Gtk-WARNING **: Theme directory 48x48/app of theme Numix-Square has no size field

  • Siento la distraccion no respondi a tu pregunta, XFCE

    Saludos

  • Hola,

    Error executing command as another user: No authentication agent found

    No tienes ningún agente polkit instalado. Prueba a instalar el paquete polkit-gnome

    sudo pacman -S polkit-gnome
    

    Saludos!

  • Hola karasu,

    Ya lo instale y reinicie. No funciona hacer click en el icono, solo cuando abre como root en la terminal es que se puede acceder.

    – Me llama la atencion que en el otro comando gparted_polkit diga que estoy ejecutando el comando como ‘otro usuario’, como que no reconoce mi usuario?

    Saludos

  • Lo de como otro usuario te lo dice porque polkit lo que hace es poder ejecutar el gparted como root y no com tu usuario corriente, es normal.

    Creo que el problema es que el agente polkit no se inicia.

    Prueba esto:

      
    cp /usr/share/applications/polkit-gnome-authentication-agent-1.desktop /etc/xdg/autostart/  
    mkdir -p ~/.config/autostart  
    cp /etc/xdg/autostart/polkit-gnome-authentication-agent-1.desktop ~/.config/autostart  
    
    

    Yo utilizo Gnome3, que ya tiene su propio agente. Siento no poderte darte una solución “segura”, no uso XFCE y no puedo probarlo yo mismo.

    Saludos!

  • Hola karasu, no funciono, me pregunto si sera que yo habre danado algo, pues cuando desintale el gparted lo hice con pacman -Rn y cuando reinicie aun estaba el icono en el menu, y no estaba supuesto a haber seguido ahi, quizas al reinstalarlo nuevamente…

    Saludos.

  • Que raro…

    Una última prueba. Abre una terminal con tu usuario (no root) y pon:

      
    /usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1  
    gparted\_polkit  
    
    

    Si no funciona, dime exactamente que te aparece.
    Saludos!

  • Hola karasu,

    Esto es lo que sale y despues de varios mts. no parece terminar como para poner el proximo comando:

    [[email protected] ~]$ /usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1

    (polkit-gnome-authentication-agent-1:697): Gtk-WARNING **: Theme parsing error: gtk.css:72:18: Not using units is deprecated. Assuming ‘px’.

    (polkit-gnome-authentication-agent-1:697): Gtk-WARNING **: Theme parsing error: gtk.css:72:20: Not using units is deprecated. Assuming ‘px’.

    Estuve pensando si no deberia de tratar polkit-xfce en vez de gnome, digo yo …

    Saludos

  • El gestor de inicio, en donde se pone la clave, cambia la hora, y la iluminacion de la pantalla aumenta y disminuye constantemente hasta que abre el sistema y la hora esta correcta y deja de haber ese cambio intermitente en la iluminacion, todo se normaliza, pero apenas reinicio y vuelve el gestor a aparecer para escribir la clave se repite el problema – lo he hecho varias veces.

    Saludos

  • Vaya, me olvidé del & debes ponerlo al final del primer comando, tal que así:

      
    /usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 &  
    gparted\_polkit  
    
    

    Dime como té va, que ya estoy intrigado…

    Saludos!

    EDIT: Lo del gestor no tiene nada que ver, es un tema del lightdm y seguramente del driver de la tarjeta gráfica. Porqué no habres otro hilo, please?

  • Hola, no se si lo estare haciendo bien:

    [[email protected] ~]$ /usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 &
    [1] 687
    [[email protected] ~]$ gparted_polkit
    (polkit-gnome-authentication-agent-1:687): Gtk-WARNING **: Theme parsing error: gtk.css:72:18: Not using units is deprecated. Assuming ‘px’.

    (polkit-gnome-authentication-agent-1:687): Gtk-WARNING **: Theme parsing error: gtk.css:72:20: Not using units is deprecated. Assuming ‘px’.

    Saludos

  • Lo repito y veo que cambia la numeracion …

    [[email protected] ~]$ /usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 &
    [1] 751
    [[email protected] ~]$ gparted_polkit
    (polkit-gnome-authentication-agent-1:751): Gtk-WARNING **: Theme parsing error: gtk.css:72:18: Not using units is deprecated. Assuming ‘px’.

    (polkit-gnome-authentication-agent-1:751): Gtk-WARNING **: Theme parsing error: gtk.css:72:20: Not using units is deprecated. Assuming ‘px’.

    – sobbre el otro asunto no ha vuelto a suceder, fue quizas por una actualizacion en donde vino un nuevo kernel 3.18 y otras cosas mas …

  • Hola,

    Lo de que cambia la numeración es normal… pero luego de ejecutar gparted_polkit no arranca gparted?

  • No. La misma historia, solo como root por la terminal (?).

    Saludos.

    [[email protected] ~]$ gparted_polkit
    Error executing command as another user: No authentication agent found.
    [[email protected] ~]$

  • Hola,

    Pues sintíendolo mucho, no sé que narices pasa. Dice que no tienes ningún agente pero en realidad si lo tienes (lo estás ejecutando tú mismo con polkit-gnome-authentication-agent-1).

    A ver si a alguien más se le ocurre algo… porqué no pruebas a crear un nuevo hilo en inglés?

    Saludos!

  • Ya lo puse, en XFCE, se te agradece mucho el interés por querer ayudar, mil gracias.

    Un saludo!

Posts 20Views 6199
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.