• Warning when upgrading AUR packages


    Hi,

    I get the following warning when i try to upgrade aur packages:

    ===================================================================================================
    => EXECUTE : yaourt -Syu --aur --nocolor

    tput: No value for $TERM and no -T specified
    ==> WARNUNG:makepkg dropped --asroot support, please run yaourt as a non-privileged user.

    ===================================================================================================
    => done

    I also cannot install packages from AUR since i get this warning.

    What’s going wrong?

    Hylli

  • Hi,

    I get the following warning when i try to upgrade aur packages:

    ===================================================================================================
    => EXECUTE : yaourt -Syu --aur --nocolor

    tput: No value for $TERM and no -T specified
    ==> WARNUNG:makepkg dropped --asroot support, please run yaourt as a non-privileged user.

    ===================================================================================================
    => done

    I also cannot install packages from AUR since i get this warning.

    What’s going wrong?

    Hylli

  • You can’t run yaourt as root anymore.
    Cheers!

  • How can i fix this, when i want to install some programs from AUR?

    Hylli

  • you can just run the command in the terminal adding the package name for installation. That works fine and does not require root rights on the user.

    However, interesting question is how to install AUR packages via pacmanxg which runs under su / sudo privileges and uses yaourt for AUR and consequently fails on the installation with the above message. I suppose, that’s where your original question comes from. I’m currently not on my Antergos install so cannot check myself, but maybe one can start pacmanxg with only user rights? Would only by a work around anyway, since one would need to know before start of pacmanxg from where an installation / update will be performed. Maybe there is a config entry somewhere …

    PS: just booted into Antergos: pacmanxg can be started with user right (there is a corresponding button on the main window when you start it). Doing that you can install packages from AUR but not from the regular Antergos repos anymore as I suspected earlier.

    Dell Latitude E6230 with Intel i7, 8GB RAM, 500 GB SSD
    dual boot: Antergos and Debian Stretch both 64bit and running gnome-shell
    surviving in a Windows world with VMware WS and Codeweavers Crossover

  • Hi,

    thanks for your reply. It worked as you mentioned.

    I also have Antergos installed as virtual machine in Virtualbox. There I didn’t get this error.

    It’s a little bit funny, but OK for me.

    Hylli

  • Glad it works for you!

    @“hylli”:2xju34jv said:

    Hi,

    I also have Antergos installed as virtual machine in Virtualbox. There I didn’t get this error.
    [/quote:2xju34jv]

    Hm, that is indeed funny! I suspect it was caused by some upgrade (probably of “makepkg”) and it’s handling by paxmanxg was not yet adjusted.
    Is your VM fully upgrade to the same level as the other machine? I would assume it should show the same behaviour.

    In know installing from AUR via pacmanxk was working just fine until not too long ago.

    Maybe someone with a deeper knowledge of the paxmanxg working can shed some light? I’m still more a DEB guy than a an AUR guy :)

    Dell Latitude E6230 with Intel i7, 8GB RAM, 500 GB SSD
    dual boot: Antergos and Debian Stretch both 64bit and running gnome-shell
    surviving in a Windows world with VMware WS and Codeweavers Crossover

  • Hi,

    It was the change to pacman 4.2 that made yaourt (and pacmanxg) to not be able to use “root” mode anymore (the --asroot parameter). Pacman devs have decided that this mode shouldn’t exist as they think it’s not secure.

    Cheers!

  • the problem that [b:io8w63aq]hilly[/b:io8w63aq] reports comes trying to update with pacmanXG also.

    with

      
    yaourt -Syua
    

    (no root) on a terminal seems to solve (so far) the issue till pacmanXG solves this bug

Posts 10Views 2143
Log in to reply