• Compton in Xfce


    After trying Gnome, Kde, Cinnamon and Mate I settled with XFCE. It’s the only desktop enviroment that’s not forcing me to reboot several times a day. However, its use of xrender produces stuttering / tearing when playing youtube videos (my laptop uses Intel graphics).

    I’ve heard this issue can be solved by using another compositor, e.g. compton or cairo-compmgr. I’ve found instructions for Ubuntu but was wondering if any of you has actually tried it on Arch? Any help would be very appreciated.

  • After trying Gnome, Kde, Cinnamon and Mate I settled with XFCE. It’s the only desktop enviroment that’s not forcing me to reboot several times a day. However, its use of xrender produces stuttering / tearing when playing youtube videos (my laptop uses Intel graphics).

    I’ve heard this issue can be solved by using another compositor, e.g. compton or cairo-compmgr. I’ve found instructions for Ubuntu but was wondering if any of you has actually tried it on Arch? Any help would be very appreciated.

  • Yes, I have tried it. Actually I have compton installed right now.

    Cnchi installs compton with the openbox desktop if visual effects switch is turned on.

    I’ve never used any DE without composite manager. So, I can’t tell the difference between the video playback experience with/without composite manager.

    but don’t expect absolute tear-free video playback on any xorg composite manager. However, I don’t notice any difference in video playback on gnome and Openbox+Compton desktop.

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • Thanks Yash. I just tried with and without Compton in Xfce and I also didn’t notice any difference on my system.
    Some tearing is still present when watching this test video [https://www.youtube.com/watch?v=2wVC-ZLhIHI][0]">[https://www.youtube.com/watch?v=2wVC-ZLhIHI][1] so I guess it’s my gfx card’s limit.

    [0]: <a href=
    [1]: https://www.youtube.com/watch?v=2wVC-ZLhIHI

  • Maybe an obvious question, but did you disable compositing in xfce before trying Compton?

  • Yes, I did. But I’m using the integrated intel graphics so some video tearing is expected I guess.

  • @“einarth”:lpkc7sm8 said:

    I guess it’s my gfx card’s limit.[/quote:lpkc7sm8]
    Not at all! I just tested that video on my openbox+compton desktop. I saw some tearing too. Well, that was expected!

    Expected not because of out gfx card’s limit but because of the xorg display server.
    Almost every composite manager tries to get over the tearing screen problem but they fail!
    Some handle tearing little bit better than others but still xorg is the culprit!
    (If you have some time, watch [this video[/url:lpkc7sm8] to know more about xorg’s downsides)
    Remembering the days of me using Gnome, I can say compton handle tearing somewhat better than mutter.

    If you see no tearing from the clouds to the end part, you should be fine. The beginning part is more hardcore than our everyday use.

    But still, there’s a way!
    If you want absolutely zero tearing, you can,

    • ditch xorg in favor of wayland(Watch that video above to know more about wayland) (use maui live iso to test wayland)
    • ditch xorg in favor of Mir (Less likely to happen) (use ubuntu-next live iso to test)
    • use KWin (very powerful Win manager) (because they borrowed code from compiz)
    • use compiz (which I use, and I see 0 tearing even in those hardcore tests!)
    • use one of those Microsoft/Apple’s OSes

    Kwin and Compiz pretty much are pretty much same as they give you the same experience except that KWin is more stable.]0

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • I never thought about kwin, if it wasn’t for the qt/gtk themes mess I’d love to have it in xfce. I’m going to try it anyway, thanks a lot.

  • Update: GPU driver can be the culprit too!
    I just moved from opensource AMD drivers to catalyst drivers and I see tearing with that test video even on compiz desktop

    Although you may try KWin. To solve the mismatch between QT and GTK stuff, watch this video[/url:3chrvk3q].

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • I’ve never been able to get rid of the tearing/stuttering with Compton. Maybe I’m doing something wrong?

    Instead, I always use Compiz with Xfce. It seems to be the most consistent and feature-rich. I am having some issues with it now, though. It seems to cause the tearing/stuttering when I get a second monitor attached. Restarting Compiz fixes it, but it’s pretty annoying.

Posts 10Views 3641
Log in to reply