• Error makepkg " perl-gtk2-ex-simple-list"


    hello everyone.
    I have a problem installing “pacmanager” from “yaourt”, and I successfully compile all necessary libraries to run, but when it comes to “perl-gtk2-ex-simple-list” that I always fails. I have tried to compile a control library by downloading the “rpm” and using the “PKGBUILD” from arch, but when I run “makepkg” says “missing package function ()”

    and when installing from yaourt tells me:

    perl-gtk2-ex-simple-list 0.50-2 (Wed Sep 2 21:19:27 CEST 2009)  
    ( Unsupported package: Potentially dangerous ! )  
    ==\> Edit PKGBUILD ? [Y/n] ("A" to abort)  
    ==\> ------------------------------------  
    ==\> n  
      
    ==\> perl-gtk2-ex-simple-list dependencies:  
    - gtk2-perl (already installed)  
    - glib-perl (already installed)  
      
      
    ==\> Continue building perl-gtk2-ex-simple-list ? [Y/n]  
    ==\> --------------------------------------------------  
    ==\>   
    ==\> Building and installing package  
    ==\> ERROR: Missing package() function in /tmp/yaourt-tmp-informatica1-arch/aur-perl-gtk2-ex-simple-list/./PKGBUILD  
    ==\> ERROR: Makepkg was unable to build perl-gtk2-ex-simple-list.  
    ==\> Restart building perl-gtk2-ex-simple-list ? [y/N]  
    
    

    dont know what else to do and arch my knowledge is very limited, but it seems that the problem is in the “PKGBUILD” that is wrong or need to upgrade, but I do not know what else to do. I need this program to work, for now I will continue in debian until you can install this program.
    thanks for the help.

  • hello everyone.
    I have a problem installing “pacmanager” from “yaourt”, and I successfully compile all necessary libraries to run, but when it comes to “perl-gtk2-ex-simple-list” that I always fails. I have tried to compile a control library by downloading the “rpm” and using the “PKGBUILD” from arch, but when I run “makepkg” says “missing package function ()”

    and when installing from yaourt tells me:

    perl-gtk2-ex-simple-list 0.50-2 (Wed Sep 2 21:19:27 CEST 2009)  
    ( Unsupported package: Potentially dangerous ! )  
    ==\> Edit PKGBUILD ? [Y/n] ("A" to abort)  
    ==\> ------------------------------------  
    ==\> n  
      
    ==\> perl-gtk2-ex-simple-list dependencies:  
    - gtk2-perl (already installed)  
    - glib-perl (already installed)  
      
      
    ==\> Continue building perl-gtk2-ex-simple-list ? [Y/n]  
    ==\> --------------------------------------------------  
    ==\>   
    ==\> Building and installing package  
    ==\> ERROR: Missing package() function in /tmp/yaourt-tmp-informatica1-arch/aur-perl-gtk2-ex-simple-list/./PKGBUILD  
    ==\> ERROR: Makepkg was unable to build perl-gtk2-ex-simple-list.  
    ==\> Restart building perl-gtk2-ex-simple-list ? [y/N]  
    
    

    dont know what else to do and arch my knowledge is very limited, but it seems that the problem is in the “PKGBUILD” that is wrong or need to upgrade, but I do not know what else to do. I need this program to work, for now I will continue in debian until you can install this program.
    thanks for the help.

  • in my house I have Antergos installed from August or so, and I have pacmanager correctly installed from yaourt, so this problem has been here a few months back … I’ve had in the laptop with a new installation of Antergos, and have the same problem with this library, I am convinced that the problem is in the “PKGBUILD” file.

Posts 3Views 955
Log in to reply