• PACMAN UPDATED TO VERSION 4.2


    Hi all,

    Well, pacman has been updated to version 4.2

    Please, after updating, remember to run

    sudo pacman-db-upgrade
    

    as pacman tolds you.

    Be aware that Yaourt and pacmanxg4 will not work anymore. Octopi might work as it doesn’t use any library (as I recall) but pamac won’t (I haven’t tested them as I do not use them, please report if they’re are working for you).

    If you try to use our iso’s to install Antergos, do not update to pacman4.2 before doing the installation with Cnchi, as it will break it.

    Cheers!

    EDIT: If you are curious about the pacman update: [url:2rw6k8jv]http://allanmcrae.com/2014/12/pacman-4-2-released[/url:2rw6k8jv]

  • Hi all,

    Well, pacman has been updated to version 4.2

    Please, after updating, remember to run

    sudo pacman-db-upgrade
    

    as pacman tolds you.

    Be aware that Yaourt and pacmanxg4 will not work anymore. Octopi might work as it doesn’t use any library (as I recall) but pamac won’t (I haven’t tested them as I do not use them, please report if they’re are working for you).

    If you try to use our iso’s to install Antergos, do not update to pacman4.2 before doing the installation with Cnchi, as it will break it.

    Cheers!

    EDIT: If you are curious about the pacman update: [url:2rw6k8jv]http://allanmcrae.com/2014/12/pacman-4-2-released[/url:2rw6k8jv]

  • Rebuilding package-query against libalpm 9 fixes the issue with yaourt:

      
    sudo pacman -Rdd package-query  
    wget https://aur.archlinux.org/packages/pa/package-query/package-query.tar.gz  
    tar -xzf package-query.tar.gz  
    cd package-query  
    makepkg -s  
    sudo pacman -U package-query-1.5-2-x86\_64.pkg.tar.xz  
    
    

    EDIT: Fixed package-query version, thanks melchizedek.

  • Just a swift correction, the last line should be:

    sudo pacman -U package-query-1.5-2-x86\_64.pkg.tar.xz
    

    The version number was one out.

    And for the record, Octopi seems to work okay. Oddly enough, so does PacmanXG… unless a reboot screws everything up. The only thing which looks suspect is that the ‘A New Version of PacmanXG is Available’ warning shows in the GUI despite it being the newest version in the repo.

    Thanks for the fix though.

    Lenovo H50-50 Sharkbay, Intel® Core i7 4790 Haswell CPU @ 3.60 GH, 2047MB NVIDIA GeForce GT 720, 8.00GB Single-Channel DDR3 @ 798MHz, Windows 10 Pro 64-bit, Antergos 64-bit, 2GB WDC (SATA), 3GB TOSHIBA (SATA).

  • I tried pamac but it doesn’t even start as it is looking for libalpm.so.8 but pacman is now using libalpm.so.9

  • I have a little off-topic suggestion, not connected with this pacman 4.2 update but its related to pacman. So, I’m talking here…

    It seems lot of antergos users replace PacmanXG with octopi or some other Package manager for update notifications.
    So, why not make antergos give package updates notifications too.
    but instead of replacing the awesome PacmanXG with some other package manager, lets add [b:1gdwndvo]Yapan[/b:1gdwndvo] to Antergos.

    Yapan just has one job, to check for updates on the set intervals. It’s very light and sits in the systray with a pacman icon.
    So, whatsay?

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • I also find that pacman notifications is sth. that Antergos is missing. I hope that sth. could be done…

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • thank you for yapan notifier. I was using before that of pamac

  • After reading the ARCH forums I found a solution. I deleted packagekit and python-packagekit. Then updated without a problem. From what I understand those packages are only needed if you are using gnome-software

  • man, this was freaking me out. I had not perform an update since sunday (nor read this and arch forums where is many threads about it).

    I had to pacman -R yaourt and package-query. Then pacman -Syu and updated.

    I’ll try to reinstall again those packages later, but so far pacman is not complaining anymore.

    thank you for your help

  • What about Pacman 4.2 update? Recently I tried to install btsync on Antegros, and I was informed by AUR script, that Manjaro (sic!) users can not install this software, because syntax has changed and Manjaro has not updated pacman to the 4.2 version. This is huge bug for me…

  • @“marcinp”:3rsjhxc7 said:

    What about Pacman 4.2 update? Recently I tried to install btsync on Antegros, and I was informed by AUR script, that Manjaro (sic!) users can not install this software, because syntax has changed and Manjaro has not updated pacman to the 4.2 version. This is huge bug for me…[/quote:3rsjhxc7]
    That does not apply to Antergos. If you are having trouble installing a package please create a new topic with the details and we will be happy to assist you. Thanks!

Posts 12Views 3619
Log in to reply