• Yaourt error


    after fixing the key error, I have a new problem. When I used the terminal: yaourt -Syua
    it spit this at me
    /usr/lib/yaourt/util.sh: line 166: /usr/bin/package-query: cannot execute binary file: Exec format error

    [img:1pt1tebw]http://i59.tinypic.com/33e3r08.png[/img:1pt1tebw]
    [b:1pt1tebw]Don't forget to mark your thread as [SOLVED] [/b:1pt1tebw]

  • after fixing the key error, I have a new problem. When I used the terminal: yaourt -Syua
    it spit this at me
    /usr/lib/yaourt/util.sh: line 166: /usr/bin/package-query: cannot execute binary file: Exec format error

    [img:1pt1tebw]http://i59.tinypic.com/33e3r08.png[/img:1pt1tebw]
    [b:1pt1tebw]Don't forget to mark your thread as [SOLVED] [/b:1pt1tebw]

  • I fixed it by reinstalling package-query

    [img:1pt1tebw]http://i59.tinypic.com/33e3r08.png[/img:1pt1tebw]
    [b:1pt1tebw]Don't forget to mark your thread as [SOLVED] [/b:1pt1tebw]

  • and with todays update it is broken again!!!

    [img:1pt1tebw]http://i59.tinypic.com/33e3r08.png[/img:1pt1tebw]
    [b:1pt1tebw]Don't forget to mark your thread as [SOLVED] [/b:1pt1tebw]

  • @“maxpro4u”:2o4dkypj said:

    after fixing the key error, I have a new problem. When I used the terminal: yaourt -Syua
    it spit this at me
    /usr/lib/yaourt/util.sh: line 166: /usr/bin/package-query: cannot execute binary file: Exec format error[/quote:2o4dkypj]

    please , I have the same problem but I can not solve .
    at first I came error " UAR " " yaourt " I went to reinstall the package that you say " query package " and I have the same problem with this package with the " yaourt "

    [[email protected] ~]$ sudo pacman -Syu yaourt  
    > :: Sincronizando las bases de datos de los paquetes...  
    > core está actualizado  
    > extra está actualizado  
    > community está actualizado  
    > multilib está actualizado  
    > antergos está actualizado  
    > advertencia: yaourt-1.5-1 está actualizado -- reinstalando  
    > :: Iniciando actualización completa del sistema...  
    > resolviendo dependencias...  
    > Verificando conflictos entre paquetes....  
    >   
    > Paquetes (1) yaourt-1.5-1  
    >   
    > Tamaño total de la descarga: 0,07 MiB  
    > Ocupación total de la instalación: 0,48 MiB  
    > Uso neto tras actualizar: 0,00 MiB  
    >   
    > :: ¿Continuar con la instalación? [S/n] s  
    > :: Recibiendo los paquetes...  
    > yaourt-1.5-1-any 70,5 KiB 659K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    > (1/1) comprobando las claves del llavero [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    > (1/1) verificando la integridad de los paquetes [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    > error: yaourt: signature from "Antergos Build Server (Automated Package Build System) <[email protected]\>" is unknown trust  
    > :: El archivo /var/cache/pacman/pkg/yaourt-1.5-1-any.pkg.tar.xz está dañado (paquete no válido o dañado (firma PGP)).  
    > ¿Quiere eliminarlo? [S/n]   
    > 
    
    [[email protected] ~]$ sudo pacman -Syu package-query   
    > [sudo] password for fransis-antergos:   
    > :: Sincronizando las bases de datos de los paquetes...  
    > core está actualizado  
    > extra está actualizado  
    > community está actualizado  
    > multilib está actualizado  
    > antergos está actualizado  
    > :: Iniciando actualización completa del sistema...  
    > resolviendo dependencias...  
    > Verificando conflictos entre paquetes....  
    >   
    > Paquetes (1) package-query-1.5-2  
    >   
    > Ocupación total de la instalación: 0,08 MiB  
    >   
    > :: ¿Continuar con la instalación? [S/n] s  
    > (1/1) comprobando las claves del llavero [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    > (1/1) verificando la integridad de los paquetes [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    > error: package-query: signature from "Antergos Build Server (Automated Package Build System) <[email protected]\>" is unknown trust  
    > :: El archivo /var/cache/pacman/pkg/package-query-1.5-2-any.pkg.tar.xz está dañado (paquete no válido o dañado (firma PGP)).  
    > ¿Quiere eliminarlo? [S/n]   
    >   
    > 
    
  • @karasu:
    hello karasu , that command has solved the conflict of firms , but yaourt follows me does not work . I uninstalled yaourt and package- query , but still the same .
    if I look any program from " pacmanXG " as " NoMachine " or " teamviewer " that I need for work , nothing appears from " ue " .
    any ideas ??
    I am with the new image of 20,141,219 .
    un saludo y gracias

  • @Fransis:
    Just today pacman has been updated to 4.2, breaking package-query. More info here : [url:2ytzttm7]http://forum.antergos.com/viewtopic.php?f=28&t=2598[/url:2ytzttm7]

    Rebuilding package-query against libalpm 9 fixes the issue:

      
    sudo pacman -Rdd package-query  
    wget https://aur.archlinux.org/packages/pa/package-query/package-query.tar.gz  
    tar -xzf package-query.tar.gz  
    cd package-query  
    makepkg -s  
    sudo pacman -U package-query-1.5-2-x86\_64.pkg.tar.xz  
    
    
  • Gracias, esa fue mi solucion!!! yaourt funcionando de nuevo!

  • A mí también me ha funcionado, con una salvedad, en la última línea:

    sudo pacman -U package-query-1.5-2-x86\_64.pkg.tar.xz
    

    La versión es la 1.5-2

    Saludos

  • Gracias El Guindilla, lo he arreglado en el post anterior.

Posts 11Views 3339
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.