• Pacman issue on update


    :: Synchronizing package databases...  
    testing is up to date  
    core is up to date  
    extra is up to date  
    community-testing is up to date  
    community is up to date  
    antergos is up to date  
    :: Starting full system upgrade...  
    resolving dependencies...  
    looking for inter-conflicts...  
    error: failed to prepare transaction (could not satisfy dependencies)  
    :: package-query: requires pacman<4.2  
    
    

    Just woke up this morning and did the usual update and get this. Leemme know if anyone else gets. ty

  • :: Synchronizing package databases...  
    testing is up to date  
    core is up to date  
    extra is up to date  
    community-testing is up to date  
    community is up to date  
    antergos is up to date  
    :: Starting full system upgrade...  
    resolving dependencies...  
    looking for inter-conflicts...  
    error: failed to prepare transaction (could not satisfy dependencies)  
    :: package-query: requires pacman<4.2  
    
    

    Just woke up this morning and did the usual update and get this. Leemme know if anyone else gets. ty

  • Hi,

    I don’t know why it’s complaining… current pacman version is 4.1.2-7

    Maybe something wrong with your mirror or your databases?

    Please, issue a

     sudo pacman -Syyuuv
    

    to see if it helps. (If it does not help, post here the results).

    If not, have a look at [code:1grjv9ms]/etc/pacman.d/mirrorlist[/code:1grjv9ms] to choose another mirror and try again.

    Tell us how it goes. Cheers!

  • Arch% sudo pacman -Syyuuv  
    Root : /  
    Conf File : /etc/pacman.conf  
    DB Path : /var/lib/pacman/  
    Cache Dirs: /var/cache/pacman/pkg/   
    Lock File : /var/lib/pacman/db.lck  
    Log File : /var/log/pacman.log  
    GPG Dir : /etc/pacman.d/gnupg/  
    Targets : None  
    :: Synchronizing package databases...  
    testing 19.8 KiB 421K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    core 121.6 KiB 515K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    extra 1806.4 KiB 1363K/s 00:01 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    community-testing 15.0 KiB 334K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    community 2.4 MiB 1451K/s 00:02 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    antergos 314.9 KiB 1799K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    :: Starting full system upgrade...  
    resolving dependencies...  
    looking for inter-conflicts...  
    error: failed to prepare transaction (could not satisfy dependencies)  
    :: package-query: requires pacman<4.2
    

    A little new to Arch. Where do I get another mirror list? I have a list of them non are commented out.

    Server = http://mirror.cc.columbia.edu/pub/linux/archlinux/$repo/os/$arch  
    Server = http://mirror.rit.edu/archlinux/$repo/os/$arch  
    Server = http://lug.mtu.edu/archlinux/$repo/os/$arch  
    Server = http://mirror.netcologne.de/archlinux/$repo/os/$arch  
    Server = http://fruk.org/archlinux/$repo/os/$arch  
    Server = http://archlinux.my-universe.com/$repo/os/$arch  
    Server = http://archlinux.polymorf.fr/$repo/os/$arch  
    Server = http://mirror.fluxent.de/archlinux/$repo/os/$arch  
    Server = http://archlinux.mirrors.uk2.net/$repo/os/$arch  
    Server = http://mirror.nl.leaseweb.net/archlinux/$repo/os/$arch  
    Server = http://mirror.bpiotrowski.pl/archlinux/$repo/os/$arch  
    Server = http://mirror.chmuri.net/archmirror/$repo/os/$arch  
    Server = http://mirror.de.leaseweb.net/archlinux/$repo/os/$arch  
    Server = http://mirror.hactar.bz/$repo/os/$arch  
    Server = http://archlinux.c3sl.ufpr.br/$repo/os/$arch  
    Server = http://mirror.cinosure.com/archlinux/$repo/os/$arch  
    Server = http://ftp.lysator.liu.se/pub/archlinux/$repo/os/$arch  
    Server = http://ftp.tuxdroid.org/archlinux/$repo/os/$arch  
    Server = http://mirror.gnomus.de/$repo/os/$arch  
    Server = http://mirror.js-webcoding.de/pub/archlinux/$repo/os/$arch
    
  • i get this message error: failed to prepare transaction (could not satisfy dependencies)
    :: kalu: requires pacman<4.2
    :: package-query: requires pacman<4.2 .

  • Until yesterday I got all updates, but today I got the same error message:

    [[email protected] ~]$ sudo pacman -Syyuuv  
    [sudo] password for Conni:   
    Root : /  
    Conf File : /etc/pacman.conf  
    DB Path : /var/lib/pacman/  
    Cache Dirs: /var/cache/pacman/pkg/   
    Lock File : /var/lib/pacman/db.lck  
    Log File : /var/log/pacman.log  
    GPG Dir : /etc/pacman.d/gnupg/  
    Targets : Nichts  
    :: Synchronisiere Paketdatenbanken...  
    core 121,6 KiB 611K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    extra 1807,9 KiB 712K/s 00:03 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    community 2,4 MiB 713K/s 00:03 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    antergos 321,7 KiB 682K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    :: Starte komplette Systemaktualisierung...  
    :: mesa-dri durch extra/mesa ersetzen? [J/n] J  
    Löse Abhängigkeiten auf...  
    Suche nach Zwischenkonflikten...  
    Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)  
    :: package-query: benötigt pacman<4.2
    
  • Add me up among the ones experiencing this issue. I have just found out I am affected, too!

    error: failed to prepare transaction (could not satisfy dependencies)  
    :: package-query: requires pacman<4.2
    

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Hi,

    Pacman 4.2 has reached the repositories. Could you guys try this again and tell us if anything is changed? If it’s not working, please post the result of

    pacman -Q pacman
    

    Thanks!

  • Hi,

    I have updated antergos this morning using pacman -Syyu. After updating it, itis not possible using pacman anymore.
    See below screenshot.
    [[email protected] gerard]# pacman -Q pacman
    fout:fout bij het initialiseren van de alpm bibliotheek
    (database-versie is onjuist: /var/lib/pacman/)

    fout: probeer het uitvoeren van pacman-db-update

    Using pacman-db-update results in the same erro mesaage as using pacman -Q pacman.

    Please advise how solve this issue

  • Problem solved, although the process involved a freeze of the menu, a shutdown and and a reboot.

    1. I tried to update pacman within PacmanXG and got a similar error message like George @"George said:
    error: failed to prepare transaction (could not satisfy dependencies)  
    > :: package-query: requires pacman<4.2
    
    1. Then I tried both
    pacman-db-update results
    

    and

    sudo pacman -S pacman
    

    and got the same error message again

    1. Then I openend PacmanXG and the list of packages was away

    2. Then I wanted to post something here in the forum, but was not able to copy and paste anything.

    3. Then I wanted to open a program and was not able to reach the panel or menu. On top of that I was also not able to close any of the open programs Firefox, MATE-Terminal and PacmanXG. Therefore

    4. I used the shortcut CTRL+ALT+DEL. I was not able to make a mouse-click, but after the usual 60 seconds the system shutted down

    5. After a successful reboot I opened PacmanXG out of curiosity and surprisingly I was able to update the system, but pacman was not updated.

    6. I tried

    sudo pacman -S pacman
    

    and got another error message, which advised me - these kind of advice is of the goodies in Arch

    [[email protected] ~]$ pacman -Q pacman  
    > pacman 4.2.0-5
    

    Mission accomplished.

  • Hello there,
    I have the same issue here…

    sudo pacman -S pacman
    

    return the same message described above:

    résolution des dépendances...  
    recherche des conflits entre paquets...  
    erreur : la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)  
    
    

    and

    sudo pacman -Q pacman
    

    returns

    pacman 4.1.2-7
    

    Cheers.

    O-p

  • Hi all,

    Please, pacman 4.2 is on the repos since this morning (GMT). Everybody should update, but:
    After updating, remember to run

    sudo pacman-db-upgrade
    

    Yaourt will not work anymore.

    Cheers!

  • @“karasu”:sxv30ite said:

    Yaourt will not work anymore[/quote:sxv30ite]
    Thanks Karasu, but what about yaourt? Is there going to be a fix for this, later on?

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Hi all,
    for me, yaourt and pacmanXG4 work very well :)

    [[email protected] ~]$ yaourt -S pacmanxg4-bin  
      
    ==\> Téléchargement du PKGBUILD de pacmanxg4-bin depuis AUR...  
    x .SRCINFO  
    x pacmanxg4-bin.install  
    x PKGBUILD  
      
    pacmanxg4-bin 4.16.1-4 (dim. janv. 29 19:13:19 CET 2012)  
    ( Paquet non supporté : peut être dangereux ! )  
    ==\> Éditer PKGBUILD ? [O/n] ("A" pour annuler)  
    ==\> ------------------------------------------  
    ==\> n  
      
    ==\> Dépendances de pacmanxg4-bin :  
    - pacman (déjà installé)  
    - lib32-libx11 (déjà installé)  
    - lib32-libxrender (déjà installé)  
    - lib32-gcc-libs (déjà installé)  
    - ssx (paquet trouvé)  
      
      
    ==\> Éditer pacmanxg4-bin.install ? [O/n] ("A" pour annuler)  
    ==\> -------------------------------------------------------  
    ==\> n  
      
    ==\> Lancer la compilation de pacmanxg4-bin ? [O/n]  
    ==\> ----------------------------------------------  
    ==\>   
    ==\> Construction et installation du paquet  
    ==\> Installation/compilation des dépendances manquantes pour pacmanxg4-bin:  
    résolution des dépendances...  
    recherche des conflits entre paquets...  
      
    Paquets (1) ssx-2.2-2  
      
    Taille totale installée : 0,55 MiB  
      
    :: Procéder à l'installation ? [O/n]   
    (1/1) vérification des clés dans le trousseau [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (1/1) vérification de l'intégrité des paquets [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (1/1) chargement des fichiers des paquets [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (1/1) analyse des conflits entre fichiers [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (1/1) vérification de l'espace disque disponible [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (1/1) installation de ssx [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    Dépendances optionnelles pour ssx  
    sudo: Give certain users the ability to run some commands as root [installé]  
    ==\> Création du paquet pacmanxg4-bin 4.16.1-4 (lun. déc. 29 19:31:54 CET 2014)  
    ==\> Vérification des dépendances pour l'exécution...  
    ==\> Vérification des dépendances pour la compilation...  
    ==\> Récupération des sources...  
    -\> Téléchargement de pacmanxg4.16\_64.tar.bz2...  
    % Total % Received % Xferd Average Speed Time Time Time Current  
    Dload Upload Total Spent Left Speed  
    100 94 100 94 0 0 84 0 0:00:01 0:00:01 --:--:-- 84  
    100 1445k 100 1445k 0 0 390k 0 0:00:03 0:00:03 --:--:-- 662k  
    ==\> Validation des fichiers sources avec md5sums...  
    pacmanxg4.16\_64.tar.bz2 ... Réussite  
    ==\> Extraction des sources...  
    -\> Extraction de pacmanxg4.16\_64.tar.bz2 avec bsdtar  
    ==\> Entre dans l'environnement fakeroot...  
    ==\> Lancement de package()...  
    ==\> Nettoyage de l'installation...  
    -\> Suppression des fichiers indésirables...  
    -\> Suppression des fichiers libtool...  
    -\> Suppression des fichiers de bibliothèques statiques...  
    -\> Compression des pages de man/info...  
    ==\> Création du paquet « pacmanxg4-bin »...  
    -\> Génération du fichier .PKGINFO...  
    -\> Ajout du fichier install...  
    -\> Génération du fichier .MTREE...  
    -\> Compression du paquet...   
    ==\> Quitte l'environnement fakeroot.  
    ==\> Création finie : pacmanxg4-bin 4.16.1-4 (lun. déc. 29 19:31:59 CET 2014)  
      
    ==\> Installer pacmanxg4-bin ? [O/n]  
    ==\> [A]fficher le contenu du paquet [V]érifier avec namcap  
    ==\> ------------------------------------------------------  
    ==\>   
      
    chargement des paquets...  
    résolution des dépendances...  
    recherche des conflits entre paquets...  
      
    Paquets (1) pacmanxg4-bin-4.16.1-4  
      
    Taille totale installée : 1,56 MiB  
      
    :: Procéder à l'installation ? [O/n]   
    (1/1) vérification des clés dans le trousseau [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (1/1) vérification de l'intégrité des paquets [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (1/1) chargement des fichiers des paquets [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (1/1) analyse des conflits entre fichiers [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (1/1) vérification de l'espace disque disponible [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    (1/1) installation de pacmanxg4-bin [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    Dépendances optionnelles pour pacmanxg4-bin  
    curl: news and screenshots support [installé]  
    yaourt: AUR support [installé]  
    lib32-libxft: antialiased problem fix for x64  
    pkgfile: pkgfile utility check [installé]  
    scrot: for making screenshots  
    [[email protected] ~]$ pacman -Q pacman  
    pacman 4.2.0-5  
    [[email protected] ~]$
    
  • Actualizando, viendo los post anteriores, con pacman:

    $ sudo pacman -Syu  
    :: Sincronizando las bases de datos de los paquetes...  
    core está actualizado  
    extra está actualizado  
    community está actualizado  
    antergos está actualizado  
    home\_gcala\_Archlinux está actualizado  
    :: Iniciando actualización completa del sistema...  
    ...el sistema ya está actualizado.
    

    Ahora con yaourt da mal:

    $ yaourt -Syyu --aur  
    package-query: error while loading shared libraries: libalpm.so.8: cannot open shared object file: No such file or directory  
    :: Sincronizando las bases de datos de los paquetes...  
    core 121,6 KiB 124K/s 00:01 [----------------------] 100%  
    extra 1809,5 KiB 331K/s 00:05 [----------------------] 100%  
    community 2,4 MiB 351K/s 00:07 [----------------------] 100%  
    antergos 321,7 KiB 190K/s 00:02 [----------------------] 100%  
    home\_gcala\_Archlinux 1006,0 B 0,00B/s 00:00 [----------------------] 100%  
    package-query: error while loading shared libraries: libalpm.so.8: cannot open shared object file: No such file or directory  
      
    package-query: error while loading shared libraries: libalpm.so.8: cannot open shared object file: No such file or directory  
    
    

    Tal ves lo hago mal, ustedes me dirán a mi poca experiencia.
    Mis respetos.-

    Autodidacta en la VIDA …y en Linux, también.

  • Hola comunidad.

    Estoy luchando por 2 días para poder hacer funcionar mi antergos como lo estaba haciendo. Todo empezó porque quise instalar tomahawk y yaourt ya no funcionaba, pero despues iba a hacer un simple pacman -Syu y me empezó a dar el siguiente erro:

    error: error al preparar la transacción (no se pudieron satisfacer las dependencias)  
    :: packagekit: necesita pacman<4.2.0
    

    Pero al hacer pacman -Q pacman obtengo:

    pacman 4.1.2-7
    

    Ya no puedo actualizar el sistema, que podrá ser lo que se puede hacer? No quiero perder mi antergos :(

    Gracias por las contribuciones!!

  • Hi there,

    to upgrade the system I had to remove package-query then upgrade system and then update pacman database.
    It works but it is no longer possible to install yaourt… until when?

    Cheers

    O-p

  • @George and @Oswald-p: If you recompile package-query, yaourt will work again. You have the instructions here: [url:1kc6037c]http://forum.antergos.com/viewtopic.php?f=28&t=2598[/url:1kc6037c]

    @Judd: Tienes que recompilar package-query para que yaourt vuelva a funcionar. Tienes las instrucciones aquí:[url:1kc6037c]http://forum.antergos.com/viewtopic.php?f=28&t=2598[/url:1kc6037c]

    @Eliko: Debes eliminar el paquete packagekit. Simplemente haz un

    sudo pacman -R packagekit
    

    Desupés vuelve a actualizar con

    sudo pacman -Syu
    

    Cheers!

  • No worries, Karasu. Everything is as good as ever again. It was fix a little after it broke with a new update.
    Thank you and a Happy New Year!

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @“karasu”:1xj8l5jv said:

    @George and @Oswald-p: If you recompile package-query, yaourt will work again. You have the instructions here: [url:1xj8l5jv]http://forum.antergos.com/viewtopic.php?f=28&t=2598[/url:1xj8l5jv]

    @Judd: Tienes que recompilar package-query para que yaourt vuelva a funcionar. Tienes las instrucciones aquí:[url:1xj8l5jv]http://forum.antergos.com/viewtopic.php?f=28&t=2598[/url:1xj8l5jv]

    @Eliko: Debes eliminar el paquete packagekit. Simplemente haz un

    sudo pacman -R packagekit
    

    Desupés vuelve a actualizar con

    sudo pacman -Syu
    

    Cheers![/quote:1xj8l5jv]

    Gracias por la pronta respuesta amigo karasu!!!
    Hago mi update como la primera cosa del 2015 gracias a tus instrucciones. }

    Éxitos!!!

Posts 22Views 6868
Log in to reply