• Gnome 3.14 Fresh Install Crash on startup


    So I am running the Cinnamon DE. I love this DE and have been using it for a long time. but I wanted to go back to Gnome which I love just as much as Cinnamon. So I installed gnome and gnome-extra. I also made sure gdm was installed (which should be provided in the gnome-extra package anyways. I restart the PC and I try to load into gnome. But I receive the “uh-oh” error.

    I believe Cinnamon uses lightdm correct? Should I run “systemctl disable lightdm” and enable gdm? Or can both be enabled just not running at the same time? I know cinnamon doesn’t like gdm, but I would like to keep both gnome and cinnamon installed and switch back in forth depending on my mood. SO I guess both displays must stay installed.

    Is there any logs I can provide that would help with the gnome crash? I think my xorg log may help some but do let me know so I don’t waste anybody’s time.

    Thanks all,

    Sandman007

  • So I am running the Cinnamon DE. I love this DE and have been using it for a long time. but I wanted to go back to Gnome which I love just as much as Cinnamon. So I installed gnome and gnome-extra. I also made sure gdm was installed (which should be provided in the gnome-extra package anyways. I restart the PC and I try to load into gnome. But I receive the “uh-oh” error.

    I believe Cinnamon uses lightdm correct? Should I run “systemctl disable lightdm” and enable gdm? Or can both be enabled just not running at the same time? I know cinnamon doesn’t like gdm, but I would like to keep both gnome and cinnamon installed and switch back in forth depending on my mood. SO I guess both displays must stay installed.

    Is there any logs I can provide that would help with the gnome crash? I think my xorg log may help some but do let me know so I don’t waste anybody’s time.

    Thanks all,

    Sandman007

  • Hi,

    @“Sandman007”:x6cqedg6 said:

    Cinnamon uses lightdm correct?[/quote:x6cqedg6]
    All the DEs on Antergos by default use lighdm. Even Gnome.

    If cinnamon hates GDM, then you have to use lightDM for both Gnome and Cinnamon. You may uninstall GDM.

    If Gnome is installed, lightdm should detect it and give you the option to choose the DE at login screen…

    You may test lightdm without restarting your system by
    [command:x6cqedg6]lightdm --test-mode --debug[/command:x6cqedg6]

    Cheers!

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • @“Yash”:vgzx8aeh said:

    Hi,

    @“Sandman007”:vgzx8aeh said:

    Cinnamon uses lightdm correct?[/quote:vgzx8aeh]
    All the DEs on Antergos by default use lighdm. Even Gnome.

    If cinnamon hates GDM, then you have to use lightDM for both Gnome and Cinnamon. You may uninstall GDM.

    If Gnome is installed, lightdm should detect it and give you the option to choose the DE at login screen…

    You may test lightdm without restarting your system by
    [command:vgzx8aeh]lightdm --test-mode --debug[/command:vgzx8aeh]

    Cheers![/quote:vgzx8aeh]
    Thank you for your reply,

    So I uninstalled gnome and gnome-extra. I deleted all downloaded packages from /var/pacman. Just in case I had broken packages. I ran a sync. Then I installed gnome & gnome-extra.

    Then I Removed gdm only. I rebooted. I booted into lightdm of course. Gnome crashes at startup. But then after clicking OK on the “uh-oh” message, gnome starts to load. I get the unlock keyring dialog and a Calendar event popup.

    But that is all I get and I must restart to get back to the log on screen.

  • Ooh thats weird.

    What exactly does the error say? Just a “uh oh” and a ok button?

    Could you post your system logs here?
    [Here’s[/url:2kmf8w08] how to.

    I think the devs will help you now. But you still gotta post the logs. I don’t know what logs are necessary, so you just post all 4 that the ‘how to’ page talks about.]0

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • @“Yash”:1nfdktbz said:

    Ooh thats weird.

    What exactly does the error say? Just a “uh oh” and a ok button?

    Could you post your system logs here?
    [Here’s[/url:1nfdktbz] how to.

    I think the devs will help you now. But you still gotta post the logs. I don’t know what logs are necessary, so you just post all 4 that the ‘how to’ page talks about.[/quote:1nfdktbz]

    OK I’'l try to get to that later today.

    I wanted to ask if maybe this is caused by my xorg version or the fact I am using catalyst-test drivers (AMD). Maybe I should downgrade xorg and go with the stable AMD driver?

    Thanks
    Sadman007]0

  • I use the stable AMD driver and I don’t see any problem with it.
    Also, the latest 14.12 version supports the latest xorg I guess. Maybe you don’t have to downgrade xorg. :/

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • @“Yash”:1ivh33zq said:

    I use the stable AMD driver and I don’t see any problem with it.
    Also, the latest 14.12 version supports the latest xorg I guess. Maybe you don’t have to downgrade xorg. :/[/quote:1ivh33zq]Do you use Gnome? Do you use the latest Gnome from the stable branch or from testing?

  • Gnome.
    Everyhing from stable branch.

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

Posts 9Views 1683
Log in to reply