• Super-wingpanel


    Hi,

    I have no experience in making PKGBUILDs for AUR. and I need a launcher which the developer is only making for debian, ubuntu.

    [This[/url:1lse5qjv] is the github link.

    The launcher is already in [AUR[/url:1lse5qjv] but hasn’t been updated since first submission. That PKGBUILD doesn’t build anymore.

    There’s no makefile in the source either otherwise I would’ve helped myself.

    So, could anyone of you experienced Arch users give me a working PKGBUILD for the launcher?

    Thanks]1]0

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • Hi,

    I have no experience in making PKGBUILDs for AUR. and I need a launcher which the developer is only making for debian, ubuntu.

    [This[/url:1lse5qjv] is the github link.

    The launcher is already in [AUR[/url:1lse5qjv] but hasn’t been updated since first submission. That PKGBUILD doesn’t build anymore.

    There’s no makefile in the source either otherwise I would’ve helped myself.

    So, could anyone of you experienced Arch users give me a working PKGBUILD for the launcher?

    Thanks]1]0

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • Hi,

    Quick and dirty, here you are: [url:vbo0lxbu]http://pastebin.com/kW4q0q4t[/url:vbo0lxbu]

    Tell me if it works for you.

    Cheers!

  • Nope.
    It builds, installs successfully but doesn’t run.

    I click on its icon in menu, nothing happens.

    treminal command ‘ducklauncher’ doesn’t work either.

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • OK, I’ll check it when I get home.

  • @“karasu”:2s9tsdb4 said:

    I’ll check it when I get home.[/quote:2s9tsdb4]

    Buddy, you home yet?

    [This page[/url:2s9tsdb4] is a bliss.

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • Hahaha… I’m really sorry! I totally forgot about this!!!

    Let me test it. I’ll do it right now and come back with my findings. Again, sorry.

  • Hi,

    Well, I managed to make it work (more or less, because it does not show application’s icons).

    Bear in mind that this program is coded with Ubuntu in mind, so…

    If you’re willing to try, I post here what I have done

    1. From where you have the PKGBUILD file:
    sudo makepkg -i
    
    1. Create this symbolic link:
    sudo ln -s /usr/lib/python2.7/duck\_launcher /usr/lib/duck\_launcher
    
    1. Edit /usr/bin/duck_launcher and change the python for python2, so instead of
    python -O /usr/lib/duck\_launcher/Main.py
    

    should read:

    python2 -O /usr/lib/duck\_launcher/Main.py
    
    1. Copy default theme.
      Create the default theme dir:
    sudo mkdir -p /usr/share/duck-launcher/default-theme
    

    Copy files

    sudo cp -Rv "dir where you have the PKGBUILD"/src/launcher/default-theme/\* /usr/share/duck-launcher/default-theme
    
    1. Install missing dependencies:
    sudo pacman -S python2-jinja python2-numpy
    

    To run it, simply type duck-launcher

    As I said, it does not see my app icons and I don’t know why.

    Tell me if you need more help following my instructions.

    Cheers!

  • No need to say sorry.
    Actually, I feel sorry for making you work on something you are not the developer/maintainer of.

    I still see a weird error

    Traceback (most recent call last):  
    File "/usr/lib/duck\_launcher/Main.py", line 39, in <module\>  
    from PyQt4 import QtGui,QtCore,QtWebKit  
    ImportError: No module named PyQt4
    

    I think we can leave this launcher here, I’m not very much interested in this unity-like launcher anymore. Plus, this is more of a ‘bunch of errors’ placed together in a git repo.

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • Oh, that’s telling you that pyqt4 is missing. If you’re still willing to try just do a

    sudo pacman -S python2-pyqt4
    
  • Wow! I just got it working!

    I can now say, this shit is slowest of all the launchers I’ve used till date xD

    I didn’t see any ‘icon’ problem thought.

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • *Edited forum topic*

    Screw the duck launcher, I’m desperately interested in the [b:2q4nneul][super-wingpanel[/url:2q4nneul][/b:2q4nneul].
    Mainly for its float functionality which looks very cool and saves good amount of space.
    This:
    [img:2q4nneul]http://1.bp.blogspot.com/-gLWExmXDOd4/Ugp1SvycxbI/AAAAAAAAAxc/sx4PB96jEIc/s1600/slim.png[/img:2q4nneul]

    but this, just like many other interesting projects is horribly maintained by the arch community. As a result, it doesn’t build anymore.
    But doesn’t look like ‘bogus bunch of errors’ package either(like duck-launcher).

    So, could any of you experienced arch users with nothing else to do set up a working PKGBUILD?

    if not that, can anybody of you suggest me another panel which has slim/intellislim option

    Thanks :)]0

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

Posts 12Views 2733
Log in to reply