• Can not update system


    I have tried and tried and cannot get my system to upgrade. I deleted the db.ick file and have exhauster all means
    I know to fix it. Have been on Arch Wiki and googled it all I know how.

    Please help!

    Also I have tried and tried to upload the error it will not because it’s txt.

    Thanks!

    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------──> sudo pacman -Syyuu
    :: Synchronizing package databases…
    core 122.1 KiB 186K/s 00:01 [----------------------------------------] 100%
    extra 1807.3 KiB 117K/s 00:15 [----------------------------------------] 100%
    community 2.4 MiB 358K/s 00:07 [----------------------------------------] 100%
    antergos 304.8 KiB 651K/s 00:00 [----------------------------------------] 100%
    :: Starting full system upgrade…
    :: Replace ca-certificates-java with core/ca-certificates-utils? [Y/n] y
    :: Replace dirmngr with core/gnupg? [Y/n] y
    :: Replace libltdl with core/libtool? [Y/n] y
    resolving dependencies…
    looking for inter-conflicts…

    Packages (127): archey3-0.5-3 attica-qt5-5.5.0-1 ca-certificates-20140923-7.2 ca-certificates-cacert-20140824-2
    ca-certificates-java-20140324-4 [removal] ca-certificates-mozilla-3.17.3-2
    ca-certificates-utils-20140923-7.2 chromium-39.0.2171.95-1 dbus-1.8.12-1 device-mapper-2.02.114-1
    dhcpcd-6.6.4-1 dirmngr-1.1.1-3 [removal] expat-2.1.0-4 ffmpeg-1:2.5-1 firefox-34.0.5-1
    flac-1.3.1-1 flashplugin-11.2.202.425-1 geoclue-0.12.99-2 glibc-2.20-4 gnupg-2.1.0-7
    gnutls-3.3.11-1 gpgme-1.5.2-1 grep-2.21-1 groff-1.22.3-2 jdk8-openjdk-8.u25-2
    jre8-openjdk-8.u25-2 jre8-openjdk-headless-8.u25-2 kactivities-frameworks-5.5.0-1 karchive-5.5.0-1
    kauth-5.5.0-1 kbookmarks-5.5.0-1 kcmutils-5.5.0-1 kcodecs-5.5.0-1 kcompletion-5.5.0-1
    kconfig-5.5.0-1 kconfigwidgets-5.5.0-1 kcoreaddons-5.5.0-1 kcrash-5.5.0-1 kdbusaddons-5.5.0-1
    kdebase-runtime-4.14.3-1 kdeclarative-5.5.0-1 kdelibs-4.14.3-2 kglobalaccel-5.5.0-1
    kguiaddons-5.5.0-1 ki18n-5.5.0-1 kiconthemes-5.5.0-1 kio-5.5.0-1 kitemviews-5.5.0-1
    kjobwidgets-5.5.0-1 knotifications-5.5.0-1 kservice-5.5.0-1 ktextwidgets-5.5.0-1 kwallet-5.5.0-1
    kwidgetsaddons-5.5.0-1 kwindowsystem-5.5.0-1 kxmlgui-5.5.0-1 libass-0.12.0-1 libassuan-2.1.3-1
    libcap-2.24-2 libdbus-1.8.12-1 libevdev-1.3.2-1 libffi-3.2.1-1 libjpeg-turbo-1.3.1-3
    libkcddb-4.14.3-2 libksba-1.3.2-1 libltdl-2.4.2-15 [removal] libmusicbrainz5-5.1.0-1
    libpng-1.6.15-1 libsystemd-217-8 libteam-1.14-1 libtool-2.4.4-2 libwbclient-4.1.14-1
    linux-3.17.6-1 linux-firmware-20141201.38e5405-1 lirc-utils-1:0.9.1.a-9 lvm2-2.02.114-1 lz4-124-1
    mesa-10.3.5-1 mesa-dri-10.3.5-1 mesa-libgl-10.3.5-1 mesa-vdpau-10.3.5-1 ncurses-5.9-7 npth-1.1-1
    nss-3.17.3-2 numix-frost-themes-1.2-1 numix-icon-theme-0.r285.f69afd4-1
    numix-icon-theme-square-1:0.r79.bb074b2-1 openvpn-2.3.6-1 orc-0.4.22-2 oxygen-icons-4.14.3-1
    p11-kit-0.22.1-3 pacman-4.1.2-7 pcre-8.36-2 phonon-qt4-4.8.3-1 phonon-qt4-vlc-0.8.2-1
    phonon-qt5-4.8.3-1 phonon-qt5-vlc-0.8.2-1 pinentry-0.9.0-1 python2-2.7.9-1 qt4-4.8.6-4
    qt5-base-5.4.0-1 qt5-declarative-5.4.0-1 qt5-location-5.4.0-1 qt5-script-5.4.0-1
    qt5-sensors-5.4.0-1 qt5-svg-5.4.0-1 qt5-webchannel-5.4.0-1 qt5-webkit-5.4.0-1
    qt5-x11extras-5.4.0-1 qt5-xmlpatterns-5.4.0-1 qtchooser-48-1 raptor-2.0.15-1 smbclient-4.1.14-1
    solid-5.5.0-1 sonnet-5.5.0-1 sqlite-3.8.7.4-1 systemd-217-8 systemd-sysvcompat-217-8
    texinfo-5.2-3 upower-0.99.1-4 vim-7.4.537-1 vim-runtime-7.4.537-1 xf86-input-evdev-2.9.1-1
    xfce4-power-manager-1.4.2-2 xfce4-whiskermenu-plugin-1.4.1-1 xorg-server-1.16.2.901-1
    xorg-server-common-1.16.2.901-1

    Total Installed Size: 1261.49 MiB
    Net Upgrade Size: 14.60 MiB

    :: Proceed with installation? [Y/n] y
    (124/124) checking keys in keyring [----------------------------------------] 100%
    (124/124) checking package integrity [----------------------------------------] 100%
    error: numix-frost-themes: signature from “Antergos Build Server (Automated Package Build System) <[email protected]>” is marginal trust
    :: File /var/cache/pacman/pkg/numix-frost-themes-1.2-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: numix-icon-theme: signature from “Antergos Build Server (Automated Package Build System) <[email protected]>” is marginal trust
    :: File /var/cache/pacman/pkg/numix-icon-theme-0.r285.f69afd4-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: numix-icon-theme-square: signature from “Antergos Build Server (Automated Package Build System) <[email protected]>” is marginal trust
    :: File /var/cache/pacman/pkg/numix-icon-theme-square-1:0.r79.bb074b2-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: failed to commit transaction (invalid or corrupted package)
    Errors occurred, no packages were upgraded.

  • I have tried and tried and cannot get my system to upgrade. I deleted the db.ick file and have exhauster all means
    I know to fix it. Have been on Arch Wiki and googled it all I know how.

    Please help!

    Also I have tried and tried to upload the error it will not because it’s txt.

    Thanks!

    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------──> sudo pacman -Syyuu
    :: Synchronizing package databases…
    core 122.1 KiB 186K/s 00:01 [----------------------------------------] 100%
    extra 1807.3 KiB 117K/s 00:15 [----------------------------------------] 100%
    community 2.4 MiB 358K/s 00:07 [----------------------------------------] 100%
    antergos 304.8 KiB 651K/s 00:00 [----------------------------------------] 100%
    :: Starting full system upgrade…
    :: Replace ca-certificates-java with core/ca-certificates-utils? [Y/n] y
    :: Replace dirmngr with core/gnupg? [Y/n] y
    :: Replace libltdl with core/libtool? [Y/n] y
    resolving dependencies…
    looking for inter-conflicts…

    Packages (127): archey3-0.5-3 attica-qt5-5.5.0-1 ca-certificates-20140923-7.2 ca-certificates-cacert-20140824-2
    ca-certificates-java-20140324-4 [removal] ca-certificates-mozilla-3.17.3-2
    ca-certificates-utils-20140923-7.2 chromium-39.0.2171.95-1 dbus-1.8.12-1 device-mapper-2.02.114-1
    dhcpcd-6.6.4-1 dirmngr-1.1.1-3 [removal] expat-2.1.0-4 ffmpeg-1:2.5-1 firefox-34.0.5-1
    flac-1.3.1-1 flashplugin-11.2.202.425-1 geoclue-0.12.99-2 glibc-2.20-4 gnupg-2.1.0-7
    gnutls-3.3.11-1 gpgme-1.5.2-1 grep-2.21-1 groff-1.22.3-2 jdk8-openjdk-8.u25-2
    jre8-openjdk-8.u25-2 jre8-openjdk-headless-8.u25-2 kactivities-frameworks-5.5.0-1 karchive-5.5.0-1
    kauth-5.5.0-1 kbookmarks-5.5.0-1 kcmutils-5.5.0-1 kcodecs-5.5.0-1 kcompletion-5.5.0-1
    kconfig-5.5.0-1 kconfigwidgets-5.5.0-1 kcoreaddons-5.5.0-1 kcrash-5.5.0-1 kdbusaddons-5.5.0-1
    kdebase-runtime-4.14.3-1 kdeclarative-5.5.0-1 kdelibs-4.14.3-2 kglobalaccel-5.5.0-1
    kguiaddons-5.5.0-1 ki18n-5.5.0-1 kiconthemes-5.5.0-1 kio-5.5.0-1 kitemviews-5.5.0-1
    kjobwidgets-5.5.0-1 knotifications-5.5.0-1 kservice-5.5.0-1 ktextwidgets-5.5.0-1 kwallet-5.5.0-1
    kwidgetsaddons-5.5.0-1 kwindowsystem-5.5.0-1 kxmlgui-5.5.0-1 libass-0.12.0-1 libassuan-2.1.3-1
    libcap-2.24-2 libdbus-1.8.12-1 libevdev-1.3.2-1 libffi-3.2.1-1 libjpeg-turbo-1.3.1-3
    libkcddb-4.14.3-2 libksba-1.3.2-1 libltdl-2.4.2-15 [removal] libmusicbrainz5-5.1.0-1
    libpng-1.6.15-1 libsystemd-217-8 libteam-1.14-1 libtool-2.4.4-2 libwbclient-4.1.14-1
    linux-3.17.6-1 linux-firmware-20141201.38e5405-1 lirc-utils-1:0.9.1.a-9 lvm2-2.02.114-1 lz4-124-1
    mesa-10.3.5-1 mesa-dri-10.3.5-1 mesa-libgl-10.3.5-1 mesa-vdpau-10.3.5-1 ncurses-5.9-7 npth-1.1-1
    nss-3.17.3-2 numix-frost-themes-1.2-1 numix-icon-theme-0.r285.f69afd4-1
    numix-icon-theme-square-1:0.r79.bb074b2-1 openvpn-2.3.6-1 orc-0.4.22-2 oxygen-icons-4.14.3-1
    p11-kit-0.22.1-3 pacman-4.1.2-7 pcre-8.36-2 phonon-qt4-4.8.3-1 phonon-qt4-vlc-0.8.2-1
    phonon-qt5-4.8.3-1 phonon-qt5-vlc-0.8.2-1 pinentry-0.9.0-1 python2-2.7.9-1 qt4-4.8.6-4
    qt5-base-5.4.0-1 qt5-declarative-5.4.0-1 qt5-location-5.4.0-1 qt5-script-5.4.0-1
    qt5-sensors-5.4.0-1 qt5-svg-5.4.0-1 qt5-webchannel-5.4.0-1 qt5-webkit-5.4.0-1
    qt5-x11extras-5.4.0-1 qt5-xmlpatterns-5.4.0-1 qtchooser-48-1 raptor-2.0.15-1 smbclient-4.1.14-1
    solid-5.5.0-1 sonnet-5.5.0-1 sqlite-3.8.7.4-1 systemd-217-8 systemd-sysvcompat-217-8
    texinfo-5.2-3 upower-0.99.1-4 vim-7.4.537-1 vim-runtime-7.4.537-1 xf86-input-evdev-2.9.1-1
    xfce4-power-manager-1.4.2-2 xfce4-whiskermenu-plugin-1.4.1-1 xorg-server-1.16.2.901-1
    xorg-server-common-1.16.2.901-1

    Total Installed Size: 1261.49 MiB
    Net Upgrade Size: 14.60 MiB

    :: Proceed with installation? [Y/n] y
    (124/124) checking keys in keyring [----------------------------------------] 100%
    (124/124) checking package integrity [----------------------------------------] 100%
    error: numix-frost-themes: signature from “Antergos Build Server (Automated Package Build System) <[email protected]>” is marginal trust
    :: File /var/cache/pacman/pkg/numix-frost-themes-1.2-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: numix-icon-theme: signature from “Antergos Build Server (Automated Package Build System) <[email protected]>” is marginal trust
    :: File /var/cache/pacman/pkg/numix-icon-theme-0.r285.f69afd4-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: numix-icon-theme-square: signature from “Antergos Build Server (Automated Package Build System) <[email protected]>” is marginal trust
    :: File /var/cache/pacman/pkg/numix-icon-theme-square-1:0.r79.bb074b2-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
    Do you want to delete it? [Y/n] y
    error: failed to commit transaction (invalid or corrupted package)
    Errors occurred, no packages were upgraded.

  • Even the answers in the post [SOLVED] failed to commit transaction (invalid or corrupted package fail to help. I ant get past the first command at the bottom of the page…

  • Hi,

    Have you followed the steps outlined here: [http://forum.antergos.com/viewtopic.php?f=9&t=2526#p11976][0]">viewtopic.php?f=9&t=2526#p11976

    Best Regards,

    [0]: <a href=

Posts 4Views 1282
Log in to reply