• \[SOLVED - sort of\] Ibus installation gives blank graphical login screen


    OK, I have been around and around with this and am ready to ask for help!

    Installed Antergos about a week ago and most everything is working great - fantastic way to get an Arch based distro up and running quickly.

    I have need of writing in Chinese and English. I am using Gnome (with lightdm and lightdm-webkit-greeter), fully updated. The Arch Wiki on ibus says that ibus will be installed if you have Gnome but that doesn’t seem to apply to Antergos - at least it wasn’t installed when I finished my base install. I installed the East Asian font packs that I am used to using with other distros and used the Regions and Language setting tool to add Chinese as an input method - still no go. Now I have a nice little drop down in my upper panel which allows switching from English to Chinese but still won’t allow Chinese input. I can render Chinese materials on the web or in emails/documents with no problems but still can’t write. I decided I needed to install ibus manually.

    First, I generated the proper locale with locale-gen ([url:wtn6jk1t]https://wiki.archlinux.org/index.php/Locale[/url:wtn6jk1t]) and followed the [url:wtn6jk1t]https://wiki.archlinux.org/index.php/IBus#Installation[/url:wtn6jk1t] Arch Wiki to install Ibus and ibus-libpinyin. Followed through with the suggested changes to .bashrc.

    When I try logging out and logging back in the graphical login screen is blank. The only way to recover (that I have found) is to go to a different virtual terminal and

    pacman -R ibus ibus-libpinyin
    

    Any suggestions for getting this to work are appreciated. Surely Chinese input is possible with Antergos!?!

    thomas

  • OK, I have been around and around with this and am ready to ask for help!

    Installed Antergos about a week ago and most everything is working great - fantastic way to get an Arch based distro up and running quickly.

    I have need of writing in Chinese and English. I am using Gnome (with lightdm and lightdm-webkit-greeter), fully updated. The Arch Wiki on ibus says that ibus will be installed if you have Gnome but that doesn’t seem to apply to Antergos - at least it wasn’t installed when I finished my base install. I installed the East Asian font packs that I am used to using with other distros and used the Regions and Language setting tool to add Chinese as an input method - still no go. Now I have a nice little drop down in my upper panel which allows switching from English to Chinese but still won’t allow Chinese input. I can render Chinese materials on the web or in emails/documents with no problems but still can’t write. I decided I needed to install ibus manually.

    First, I generated the proper locale with locale-gen ([url:wtn6jk1t]https://wiki.archlinux.org/index.php/Locale[/url:wtn6jk1t]) and followed the [url:wtn6jk1t]https://wiki.archlinux.org/index.php/IBus#Installation[/url:wtn6jk1t] Arch Wiki to install Ibus and ibus-libpinyin. Followed through with the suggested changes to .bashrc.

    When I try logging out and logging back in the graphical login screen is blank. The only way to recover (that I have found) is to go to a different virtual terminal and

    pacman -R ibus ibus-libpinyin
    

    Any suggestions for getting this to work are appreciated. Surely Chinese input is possible with Antergos!?!

    thomas

  • More poking around lead to a work around.

    Changing to gdm from lightdm allows me to install ibus and login (would prefer to use lightdm - so beautiful - but having Chinese input is more important!). Had to make sure I put the exports in a .xprofile file (as detailed in Ibus Wiki page linked above, in the Initial configuration section, under the Note).

    I did find that after I got the system to allow login I still couldn’t enter Chinese characters. Running Regions and Languages and choosing Chinese (Intelligent Pinyin) rather than simply “Chinese” (the only option available before installing ibus-libpinyin) solved that problem too.

    I hope this will be helpful for others using multilanguage systems!

    thomas

Posts 3Views 1330
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.