• Scientific Packages


    What about scientific packages?

    I tried to install macaulay2, cocoa, singular, Maple1x (x>=6). All packages are wrong :(. This is true for some popular scientific libraries, for example mpir, ntl, gfan.

  • What about scientific packages?

    I tried to install macaulay2, cocoa, singular, Maple1x (x>=6). All packages are wrong :(. This is true for some popular scientific libraries, for example mpir, ntl, gfan.

  • Hi,

    I’m sorry I dont understand. What do you mean “All packages are wrong”?

  • In all cases makepkg signs error(s) and breaks the installation. (I used yaourt)

  • Try removing the following directory and then running the commands listed in the Pacman Key Error announcement post. [code:3h6uzn2k]/etc/pacman.d/gnupg[/code:3h6uzn2k]

  • I tried, but the answer is (the last lines )

    /usr/bin/ld: cannot find -lcddgmp
    collect2: error: ld returned 1 exit status
    Makefile:320: recipe for target ‘gfan’ failed
    make: *** [gfan] Error 1
    ==> HIBA: Hiba történt a build()-ben.
    Megszakítás…
    ==> ERROR: Makepkg was unable to build gfan.
    ==> Restart building gfan ? [y/N]
    ==> -----------------------------

  • It seems, singular is ok

  • The last error is.:

    /usr/bin/ld: cannot find -lcddgmp
    collect2: error: ld returned 1 exit status
    Makefile:320: recipe for target ‘gfan’ failed

  • Can you post here the exact result of trying to install gfan?

    yaourt -S gfan
    

    P.S. Remember to install base-devel first if you don’t have it installed.

Posts 9Views 1657
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.