• Antergos Dual Boot (Legacy)


    Hello!

    Is there actually any guide that helps me figuring out, how to install Antergos alongside Windows? I’ve already shrunk my Windows partition but since the Antergos installer only allows wiping the whole drive or manual partitioning I am kinda lost. What would be the next thing to do? I know I have those two Windows partitions and I need some more: The root, the user/home partion and a SWAP partition. Maybe someone could give me a little hint or two. Thanks!

  • Hello!

    Is there actually any guide that helps me figuring out, how to install Antergos alongside Windows? I’ve already shrunk my Windows partition but since the Antergos installer only allows wiping the whole drive or manual partitioning I am kinda lost. What would be the next thing to do? I know I have those two Windows partitions and I need some more: The root, the user/home partion and a SWAP partition. Maybe someone could give me a little hint or two. Thanks!

  • Hi,

    You should use the advanced install option (manual partitioning, as you say). To leave things uncomplicated, you can work with only two partitions, one for root and one for swap. I recommend using ext4 for your root partition and swap for your swap partition, of course.

    Feel free to ask more questions if you still are in doubt.

    Cheers!

  • Hi,

    Also, Windows can be very picky when it’s partitions are changed by anything other than Windows. If you need to resize one of your Windows partitions in order to create space for linux, I recommend you do that from Windows. There is a partitioning tool included with Windows. It’s hidden away deep in the Control Panel somewhere. Look for something like “System Admin Tools” (if I remember correctly). Also, reviewing the following wiki articles is recommended:

    [https://wiki.archlinux.org/index.php/Windows_and_Arch_dual_boot][0]">[https://wiki.archlinux.org/index.php/Wi][1] … _dual_boot
    [https://wiki.archlinux.org/index.php/partitioning][0]">[https://wiki.archlinux.org/index.php/partitioning][2]

    Good luck :-) Let us know if you have any questions.

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Wi
    [2]: https://wiki.archlinux.org/index.php/partitioning

  • I hope I may add some questions here, I have similar problems. Since I rarely install dual-boot machine, but I found this while trying dual-boot Windows 8 (64-bit) with Antergos (current 64-bit).

    I think before installed, I chosed something like this on the advance partitioning tool:

    /dev/sda1 ntfs primary system reserved 350 MB
    /dev/sda2 ntfs primary [no-label] 200 GB (for enterily C:\ on Windows 8.1)
    /dev/sda3 --> I started here with “extended partition” 97 GB into:
    /dev/sda5 fat32 /boot 250 MB
    /dev/sda6 ext4 / 95 GB
    /dev/sda7 SWAP 2048 MB

    Since bootloader on Windows 8.1 is legacy, I don’t set anything else, and was starting installing Antergos. But on the next boot, I don’t fing any options to boot to Windows. On gparted, the partitions look okay.

    Command: “sudo grub-probe --target=fs_uuid” seems doesn’t work while I tried to create custom configuration.

    Any idea?

    Asus X201EP | Intel Celeron 2x 1.10 GHz | 4 GB DDR3 RAM | Antergos 64-Bit.

  • Regenerating your grub config should fix it:[command:3o7pfvp8]sudo grub-mkconfig -o /boot/grub/grub.cfg[/command:3o7pfvp8]

    Cheers!

  • I have mount all drive, so the ntfs would mount to /run/media/… then run the command:

    $ sudo grub-mkconfig -o /boot/grub/grub.cfg  
    [sudo] password for:   
    Generating grub configuration file ...  
    Found theme: /boot/grub/themes/Antergos-Default/theme.txt  
    Found linux image: /boot/vmlinuz-linux  
    Found initrd image: /boot/initramfs-linux.img  
    Found fallback initramfs image: /boot/initramfs-linux-fallback.img  
    done  
    $ 
    

    It seemed has no Windows boot option.

    Asus X201EP | Intel Celeron 2x 1.10 GHz | 4 GB DDR3 RAM | Antergos 64-Bit.

  • Don’t mount any drives. The grub command will mount them automatically. Try it once more.

    Cheers!

  • Well, it was the same with unmounted devices.

    But, I think it was my mistake. I did previously run live antergos using EFI module/option, since the live UFD automaticaly load this version. Now, when I chose manually to boot non-EFI live UFD and install it from there, system automaticaly found Windows 8.1 boot option (well, it says Windows Vista loader).

    Anyway, my problem solved, thanks Dustin for your time. :)

    Asus X201EP | Intel Celeron 2x 1.10 GHz | 4 GB DDR3 RAM | Antergos 64-Bit.

  • Also to add a question here, as it is an appropriate thread: When dual booting with Windows, if I check the use this device for boot loader installation, will that screw up my Windows partition(s)?

    ext4 173 G /
    swap 9 G swap

  • @Samuel-Murray That will depend on your partition layout. What’s the output of the following command (run it in the live system):

    sudo fdisk -l
    
  • @lots.0.logs Thanks anyway it does not affect my Windows partitiion(s). The installation completed without a hitch. However it will not show up as boot option when i hit f9 for one-time boot device selection. So it is installed, but I cannot access it.

  • @Samuel-Murray If your antergos root partition is a primary partition (partitions 1-4) then you should be able to mark it as bootable using gparted. If that doesn’t help then you’ll need to chroot into it and rerun grub-mkconfig . Let me know if you need the steps on how to do it!

  • ![Screenshot from 2015-02-26 12:10:39.png](/uploads/files/1424970680223-Screenshot from 2015-02-26 12:10:39.png)
    @lots.0.logs
    The closest I can get my root partition is /dev/sda5.

  • @lots.0.logs
    Device Start End Sectors Size Type
    /dev/sda1 2048 821247 819200 400M Windows recovery environment
    /dev/sda2 821248 1353727 532480 260M EFI System
    /dev/sda3 1353728 1615871 262144 128M Microsoft reserved
    /dev/sda4 1615872 1224751103 1223135232 583.2G Microsoft basic data
    /dev/sda5 1224751104 1568739327 343988224 164G EFI System
    /dev/sda6 1570009088 1588441087 18432000 8.8G Linux swap
    /dev/sda7 1568739552 1570009087 1269536 619.9M Apple boot
    /dev/sda9 1910833152 1953523711 42690560 20.4G Microsoft basic data

  • Okay I see. When you did the installation, you should have mounted your existing EFI partition as /boot. As long as you do not select the format option for that mount point, your current bootloader entries would not be affected. The easiest way to fix it is to just reinstall.

  • This post is deleted!
  • You should mount your existing EFI partition (sda2) as /boot Then you can mount sda5 and sad6 as / and swap respectively.

    IMPORTANT: Do not select the format option for your /boot. You do not want to format that partition.

  • Hello I have a related issue that I posted over in Newbie Corner:

    http://forum.antergos.com/topic/1739/grub-not-properly-booting-after-migrating-antergos-to-new-ssd/2

    But I didn’t have any luck getting help there so I’m posting here instead. Having poked at the system a bit more it seems that the EFI partition (/boot) does not actually have the files required to boot Linux. The EFI partition only contains the grub_uefi directory and not any of the other files that were previously on my /boot partition (antergos_grub, BOOT, Microsoft folders, the shellx64_v2.efi file, etc.) This seems to imply that GRUB is not generating them when I run the

    grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=grub_uefi --recheck
    

    command or the

    grub-mkconfig -o /boot/grub/grub.cfg
    

    command. How can I get GRUB to generate these files properly? Please help me, I am on the verge of tears after about ten hours of wrestling with this problem…

  • @lots.0.logs Hello I found out what my problem was: My HP Laptop wouldn’t recognize a legacy install, even with legacy support enabled. So I did a UEFI install and all of my problems were solved. Thanks for the guidance.

Posts 21Views 12917
Log in to reply