• No Internet (though connected to WiFi Network)


    Hey there!

    I have a strange problem here. First of all, I downloaded the recent Antergos image (2014.08.07 - 64bits). After booting (via USB) I was able to connect to my WiFi Network right away, no driver hassle of any kind. Of course I installed Antergos (with GNOME) and everything went through just fine. While installing, I was surfing the web by using the Chromium browser offered by the Live Image.

    Anyhow: Once the installation was complete I rebooted the system and logged in. Now the problem is, that I can connect to my WiFi network and I have access to several devices like printers, NAS drives and so on, but I just can’t go past that and access the Internet. I’ve tried different times to reset the WiFi settings and reconnect but that didn’t fix the problem.

    It’s a bit strange, since the Live Image did not have this problem. Maybe someone out there has some ideas on how to fix this.

    Greetings - Christian

    P.S.: My system specs:
    [list:nv6y1yfu]
    [*:nv6y1yfu]Brand/Model: Lenovo ThinkPad T440s[/*:m:nv6y1yfu]
    [*:nv6y1yfu]CPU: Intel Core i5-4200U 1.6 GHz[/*:m:nv6y1yfu]
    [*:nv6y1yfu]RAM: 12GB[/*:m:nv6y1yfu]
    [*:nv6y1yfu]SSD: Crucial m4 128GB[/*:m:nv6y1yfu]
    [*:nv6y1yfu]GPU: Intel HD Graphics 4400[/*:m:nv6y1yfu]
    [*:nv6y1yfu]Display: 14" Full HD IPS[/*:m:nv6y1yfu]
    [*:nv6y1yfu]Audio: Realtek High Definition Audio[/*:m:nv6y1yfu]
    [*:nv6y1yfu]LAN: Intel PRO/1000 PL Network Connection [/*:m:nv6y1yfu]
    [*:nv6y1yfu]WIFI: Intel Wireless-N 7260[/*:m:nv6y1yfu][/list:u:nv6y1yfu]

  • Hey there!

    I have a strange problem here. First of all, I downloaded the recent Antergos image (2014.08.07 - 64bits). After booting (via USB) I was able to connect to my WiFi Network right away, no driver hassle of any kind. Of course I installed Antergos (with GNOME) and everything went through just fine. While installing, I was surfing the web by using the Chromium browser offered by the Live Image.

    Anyhow: Once the installation was complete I rebooted the system and logged in. Now the problem is, that I can connect to my WiFi network and I have access to several devices like printers, NAS drives and so on, but I just can’t go past that and access the Internet. I’ve tried different times to reset the WiFi settings and reconnect but that didn’t fix the problem.

    It’s a bit strange, since the Live Image did not have this problem. Maybe someone out there has some ideas on how to fix this.

    Greetings - Christian

    P.S.: My system specs:
    [list:nv6y1yfu]
    [*:nv6y1yfu]Brand/Model: Lenovo ThinkPad T440s[/*:m:nv6y1yfu]
    [*:nv6y1yfu]CPU: Intel Core i5-4200U 1.6 GHz[/*:m:nv6y1yfu]
    [*:nv6y1yfu]RAM: 12GB[/*:m:nv6y1yfu]
    [*:nv6y1yfu]SSD: Crucial m4 128GB[/*:m:nv6y1yfu]
    [*:nv6y1yfu]GPU: Intel HD Graphics 4400[/*:m:nv6y1yfu]
    [*:nv6y1yfu]Display: 14" Full HD IPS[/*:m:nv6y1yfu]
    [*:nv6y1yfu]Audio: Realtek High Definition Audio[/*:m:nv6y1yfu]
    [*:nv6y1yfu]LAN: Intel PRO/1000 PL Network Connection [/*:m:nv6y1yfu]
    [*:nv6y1yfu]WIFI: Intel Wireless-N 7260[/*:m:nv6y1yfu][/list:u:nv6y1yfu]

  • Hi,

    Please post the output of the following commands:[command:9gvuz5ds]ip route
    sudo journalctl -b |grep dhcpcd[/command:9gvuz5ds]

    Best Regards,

  • Hey there!

    I’ve managed solve the problem: I adjusted the IP settings manually to a static IP. So the way my home network works is that all the non moveable things like computers, the NAS, the printers, etc. have a static IP. Usually the DHCP server automatically hands out IP addresses for all the devices that are moveable - like the laptop that is used in different networks. For some reason, no IP address was given to my ThinkPad, although it works like a charm in Windows and via Antertgos Live System. Strange…

    P.S.: I will be doing a fresh install again an then post the output of the commands given.

  • I have a Lenovo laptop as well and ALWAYS have this problem with arch. For future reference, after connecting to a network but not having Internet access, this is what I do to auto-assign an ip:

      
    \# iw dev //to get your interface name  
      
    \# dhcpcd wlp2s0 //replace "wlp2s0" with yours  
    
    

    Then it works.

    Distro hopping junkie
    Developer for [Entropy GNU/Linux[/url:22cla13f]]0

Posts 5Views 3620
Log in to reply